[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1540
  • Last Modified:

Programmatically Change Default Font for Emails

Is there a way to to set all Mail Users Default Font and Size ? I know you can change it via "Text - Set Current Font as Mail Default", however I would like to do this via a console command, formula or script.
0
nbtnotes
Asked:
nbtnotes
  • 6
  • 6
  • 2
4 Solutions
 
Sjef BosmanGroupware ConsultantCommented:
AFAIK it's not possible with a Policy either. The only way seems to be a change of the Mail template, and then distributed it. Drawback: every time a new version of Domino is installed you have to re-edit the mail template.
0
 
nbtnotesAuthor Commented:
Nothing happens when I change the font and size of the body field.

Am I missing something ?
0
 
Sjef BosmanGroupware ConsultantCommented:
There are probably several Body fields, in several Forms. Did you modify the one in the form called Message? The alias should be Memo.
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
nbtnotesAuthor Commented:
That is the one I altered and nothing happened. I updated my personal mailbox during this test.
0
 
Sjef BosmanGroupware ConsultantCommented:
Did you try it out on your mail database first, without touching the template?
0
 
nbtnotesAuthor Commented:
Yes I did. It stays on Default Sans with a size of 10.
0
 
Sjef BosmanGroupware ConsultantCommented:
I'll try for myself, tomorrow (02:14 here right now). Promise...
0
 
Sjef BosmanGroupware ConsultantCommented:
If you intend to change the Default Sans Serif font, you can select a different one by going to Preferences, Basic Notes, Default Fonts... But that's local, in your client, like I expect other font settings to be local only.
0
 
Hans Holt, Ph.D.Senior System ConsultantCommented:
I think, that when you want to change the body font - make sure to set the last character/line before the body field with the font you prefer.
0
 
nbtnotesAuthor Commented:
I need to change this for all users in the company because they want all emails sent with the font being Calibri Light\14.

I selected the entire form and change the font to Calibri Light\14. Everything changed except for the Body field.

I have no clue why this Body field will not change. I have change the font for both the Body and wBody fields.
0
 
Hans Holt, Ph.D.Senior System ConsultantCommented:
I have put xxx in front og the Body field changed font and set color to red.

When I create a mail memo I get the red xxx in the beginning of the mail.

My mail has a signature which do not get the new font.

If I start writing just after the xxx I get the desired font.

If I write on the first empty line I get the font of the signature.'


Wiz If you use signatures, make sure that they also use the desired font.
You must use the rich text signature to be able to set the font.

Maybe it is only necessary to set the rich text font, to solve your problem.
0
 
nbtnotesAuthor Commented:
Turns out I had to set the Style for the Body field to None. I could then set the font and size without any issues.
1
 
Sjef BosmanGroupware ConsultantCommented:
Ok. Appreciated.
0
 
nbtnotesAuthor Commented:
Turns out the Style setting in the properties box was the issue. Set it to None and you can change the font and size without any issues.

The other responses also work to some degree, so I have give a few points for those responses. In the end it was a Style issue.
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 6
  • 6
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now