ASA 5505 Configuration - No Internet Access

HELP!!
I have been trying to get my ASA to work for two days with no success. I have a static IP from ISP, I can ping Gateway from ASA, I can ping google DNS server from ASA. But none of my LAN hosts can not get out to the Internet.
Can anyone shed any light???

interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 67.212.x.x 255.255.255.252
!
ftp mode passive
dns domain-lookup inside
dns server-group DefaultDNS
 name-server 66.153.x.x
 name-server 66.153.x.x
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 255.255.255.255 67.212.50.66 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.5-192.168.1.132 inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:e9d5d1604d8a98cee9a3be343812d204
bgreenmicroAsked:
Who is Participating?
 
Cyclops3590Commented:
add
global (outside) 1 interface
0
 
Gareth GudgerCommented:
Change your route outside to:

route outside 0.0.0.0 0.0.0.0 67.212.50.66 1

And do the thing Cyclops said as well. :)
0
 
Cyclops3590Commented:
ha, good catch diggisaur. i hate going back and forth between subnet masks and wildcard masks.  makes me blind to mistakes like that.  :)
0
 
bgreenmicroAuthor Commented:
Thanks guys looks like adding global (outside)1 interface command got my clients out but they were still having DNS issues. I ended up adding another line in the running config dhcpd  dns 8.8.8.8 inside.

ASA is working good now.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.