Solved

Need to change the Email Domain in SBS2008

Posted on 2014-01-13
8
494 Views
Last Modified: 2014-01-14
I have a brand new SBS2008 server that has not yet gone live
- Lets say I called the server domain "ABC.LOCAL" when I built the server
- So when I create new user's accounts, it give them their default email account as "username@abc.local"
- I need to the email account DOMAIN to be the same as their hosted website "ABCDE.COM"

I went under Exchange Manager > Organization Configuration > Hub Transport and attempted to make the changes but if fails the wizard under the tab "Email Address Policies"

What are the correct steps to do this so when I create the user accounts, they pull in the correct email addresses
0
Comment
Question by:agieryic
8 Comments
 
LVL 56

Accepted Solution

by:
Cliff Galiher earned 450 total points
ID: 39777988
All you need to do is run the internet address management wizard, it will ask you what you want your external domain name to be, and will configure DNS, exchange, and IIS for you. Don't try to tweak things manually. You'll just break SBS.
0
 
LVL 53

Expert Comment

by:Will Szymkowski
ID: 39777997
You need to configure an Authoritative Accepted Domain. Once you have this you then create your email address policy and apply it to all of your users.

Accepted Domain - http://technet.microsoft.com/en-us/library/aa996910(v=exchg.80).aspx

Email Address Policy - http://technet.microsoft.com/en-us/library/bb124401(v=exchg.80).aspx

Will.
0
 
LVL 1

Author Comment

by:agieryic
ID: 39778010
I have the server onsite and online - but the router DHCP has not yet been disabled. Users are still running from their current Windows server 2003 (not in a domain) but as a "peer to peer"  server.

Currently I am copying over all their data to the new server using SyncToy (love this tool)
- during the process, I wanted to start creating all the users accounts but stopped when I saw the incorrect email address.

Should I wait to run the "internet address management wizard"
I want to bring this server live with the next two weeks
0
 
LVL 56

Expert Comment

by:Cliff Galiher
ID: 39778024
The dashboard has a to do list for setting up SBS. Don't do things out of order, Running the various setup wizards should definitely be done before creating users. And one of the wizards, the connect to internet wizard, is best run when you are ready for SBS to handle DHCP.

So while I appreciate the desire to multitask, don't rush, you'll see problems like what you've observed with your test user.
0
 
LVL 1

Author Comment

by:agieryic
ID: 39778055
makes total sense and I appreciate your feedback
I'll disable the DHCP after hours and try this
0
 
LVL 1

Author Comment

by:agieryic
ID: 39778185
We have a static Public IP address already in place (because I have a VPN between two offices)
LAN IP of the router is 192.168.2.1
changed the LAN IP address of the server to 192.168.2.2
- changed the DNS on the new server to 192.168.2.2 (same as the static IP address
- disabled the DHCP on the server.
- ran “Connect to the internet” wizard
- ran the “Internet address management” wizard - SUCCESSFULL
This was successful however I received the message “Windows Small Business Server 2008 cannot open ports 25,80, 443 and 987”. I do recall seeing this before and was told to ignore it
- I confirmed the that it picked up the correct email domain. I created a user and the settings looked great

So for now I will leave the router settings in place, and complete the configuration remotely

I already have two successful SBS2008 that I built and running online - but its never 2nd nature

I will be moving the USERFOLDERS to the DATA drive and not on the default C-DRIVE

Let me know if the above makes since
0
 
LVL 18

Assisted Solution

by:Jeremy Weisinger
Jeremy Weisinger earned 50 total points
ID: 39778435
Sounds good. Keep following the steps. As Cliff said, using the wizards is the way to go with SBS.

“Windows Small Business Server 2008 cannot open ports 25,80, 443 and 987”
This is Microsoft trying to use UPnP to configure the firewall and be glad that it failed as I would never want UPnP enabled on my firewall. :-) You can ignore this and just make sure you setup the firewall manually.
0
 
LVL 22

Expert Comment

by:Olaf De Ceuster
ID: 39778557
0

Join & Write a Comment

Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
This tutorial will walk an individual through the process of configuring their Windows Server 2012 domain controller to synchronize its time with a trusted, external resource. Use Google, Bing, or other preferred search engine to locate trusted NTP …

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now