Solved

Browsers won't print to adobe pdf printer

Posted on 2014-01-13
69
14,735 Views
Last Modified: 2014-01-30
In Firefox or IE11, When I try to File>print>Adobe pdf, the process freezes and I get an Acrobat "access denied" error box. I'm using ACROBAT XI (Reader is not installed). The "convert to pdf" plug-in in the toolbar works, but it prints the entire Web page. And with the way the new NYTimes web page is set up, you can only print stories from the File>print option, not the convert option.
0
Comment
Question by:normanml
  • 30
  • 19
  • 16
  • +2
69 Comments
 
LVL 51

Expert Comment

by:Joe Winograd, EE MVE
ID: 39778255
Hi Norman,
I have Acrobat X Standard and have had trouble printing to Adobe PDF. Instead, I use several of the free PDF print drivers out there. Six good ones are Bullzip, CutePDF Writer, doPDF, Nitro PDF Creator (part of the Nitro Reader install), PDFCreator, and PrimoPDF:

http://www.bullzip.com/products/pdf/info.php
http://www.cutepdf.com/Products/CutePDF/writer.asp
http://www.dopdf.com
http://www.nitroreader.com/
http://www.pdfforge.org/pdfcreator
http://www.primopdf.com

They have varying features and some folks prefer one over the other, so you may want to experiment to see which one you like the best. At one time CutePDF was my favorite, then it was doPDF, and my current choice is Bullzip. So I suggest trying Bullzip first to see if it works well for you; if not, try doPDF next; then the others until you find one that you like. All of them install a "printer" so that you can "print" to it from any Windows program, including, of course, FireFox and IE. I've used these free PDF print drivers with Firefox and IE (and Chrome and Opera) for many years, including the latest FF 26.0 and IE11. Regards, Joe
0
 
LVL 18

Expert Comment

by:web_tracker
ID: 39778319
I second the opinion for Bullzip, I have used it for many years and it seems to work flawlessly on windows xp and 7, and on many different versions of IE, which I use the most.
0
 
LVL 30

Expert Comment

by:captain
ID: 39779328
Hm, whilst offering an alternative program certainly circumvents the problem, I wonder if there is not a solution for this.

Access denied always suggests permission issues. Check Devices & Printers> Printer Properties> Security...

What rights do you have?

These access issues either relate to the printer permissions being blocked for your account (unlikely) or access to the application folders, registry keys and temp folder - where A XI tries to spool the file to- being restricted (more likely).

Other possibility are Network security programs blocking this or the temp folder is on a remote share...

Has Acrobat been installed, from a different account or remotely?
Do you have a full admin account and can you try the local computer admin account to see if that makes a difference?

Check the following and make sure you allow yourself or everyone Full Control to the following folders and keys:

Program Files\Adobe
Program Files\Common Files\Adobe

Registry
HKLM\Software\Adobe
HKLM\Software\Wow6432Node\Adobe
HKLM\System\CurrentControlSet\Control\Print\Printers\Adobe PDF

hth
capt.
0
 

Author Comment

by:normanml
ID: 39780708
Captain: Will go through security settings tonight and report back. I too dislike letting a problem with paid software linger. Thanks. But...

Joe and Web-tracker: Good to have those alternatives. I get a lot of data from the WWW for my work. Thank you.

Stay tuned.
0
 

Author Comment

by:normanml
ID: 39782649
I was trying some other things before I fiddled with permissions, and in testing I noticed that I forgot to report to you that in addition to getting an "access denied" error during the process, I also got this:
Frozen dialog process

You'll notice that the PDF Folder it's looking for C:\Documents and Settings\...\MyDocuments, which is NOT part of Win7/64 but rather part of XP. So something, some setting, perhaps in the registry, is asking it to look for a folder that does not exist. Perhaps that is the cause of the access denier.

Nowhere in XI can I find this setting. In printer preferences (Devices and printers) you can specify the Adobe Output folder. I experimented, tried different folders, but the process would then run (I'd get the dialog with the blue progress bar), finish, but produce not pdf. When I try either of the standard output folder settings: "Prompt for Adobe PDF Filename" or "Documents\*.pdf," the printing begins, then hangs the browser and I get the error dialog on access denied and the dialog I've embedded here, that is frozen. Again, when I choose a new destination folder, any folder, it seems to be printing but does not produce a pdf.  

As I said, as soon as I saw the non-existent folder the program was looking for, I decided to report it here before changing permission.
0
 
LVL 51

Expert Comment

by:Joe Winograd, EE MVE
ID: 39782657
Here's the problem: There's an asterisk in the file name. That's an illegal character for a file name.
0
 

Author Comment

by:normanml
ID: 39782679
That's one of Adobe's standard choices is that dialog box. I think it's simply to indicate a wildcard that the user fills in when presented with a dialog box.
0
 
LVL 51

Expert Comment

by:Joe Winograd, EE MVE
ID: 39782687
No, it's not. That's the document name (file name) that it is printing and trying to create. It will work fine if you change the file name. Try it. For example, here's what it looks like with a legal document (file) name:

Adobe PDF dialogRegards, Joe
0
 
LVL 30

Expert Comment

by:captain
ID: 39783526
If you have a Windows 7 install that was an upgrade from XP, Win 7 locks the Documents & Settings folder. If you have this folder you can try accessing this from Explorer and it will give you the same error. As you don't have that folder it will go searching for it and then not find it.

Something seems seriously strange. The * in the Docunebt Name and the path...

Have you tried restoring the preferences folder(from Adobe www):
    Quit Acrobat.

    In Windows Explorer, go to the Preferences folder:

        (Windows 7/Vista) C:\Users\[username]\AppData\Roaming\Adobe\Acrobat\[version]

          Move the Preferences folder to another location (for example, C:\Temp).

    Restart Acrobat.

Acrobat will recreate your preferences with defaults. If this does not help, you can move the old ones back.

capt.
0
 

Author Comment

by:normanml
ID: 39783909
Just FYI on the * in the document name. Here's the settings choices.
Adobe settingsAs you can see, Documents\*.pdf is simply a standard setting that puts the pdf in the documents folder and gives it a name (or number) depending, I'm guessing, on what's in the metadata. I have it set for "Prompt for Adobe PDF Filename." A dialog box comes up that says "printing," it goes for a few seconds, freezes, crashes the browser, I then get an "Access Denied" box error, then I get the "creating adobe pdf" dialog above, which also freezes.
0
 

Author Comment

by:normanml
ID: 39783944
Moved preferences, started Acrobat; it did indeed create a new preferences folder. Alas, still can not print to Adobe printer from browser. Might as well try the permissions.
0
 
LVL 51

Expert Comment

by:Joe Winograd, EE MVE
ID: 39784071
> As you can see, Documents\*.pdf is simply a standard setting that puts the pdf in the documents folder and gives it a name (or number) depending, I'm guessing, on what's in the metadata.

Not exactly. That setting puts the documents in <c:\Users\username\Documents\> in W7 (\Users is the equivalent of XP's \Documents and Settings). It gets the file name from the source document, such as a Word file, but I've never seen it show an asterisk in the Document Name or the PDF Progress bar. Anyway, setting the drop-down choice in the Adobe PDF Printing Preferences to "Prompt for Adobe PDF filename" should certainly have worked if you navigated to a writable folder. You say that it freezes and crashes when you print from the browser. Which browser? And what happens when you print from another app, like Excel or Word? Or from a different browser?
0
 

Author Comment

by:normanml
ID: 39784189
Good questions. Tested MSWord 2010, Notetab (plain text editor) and Firefox and IE11. Both browsers have an Acrobat plug-in that converts the entire page to a pdf. Same is true for Word, but not Notetab. BUT you can't "print" to Adobe PDF printer from any of the above. Same thing -- each program freezes and I get an access denied error box. Actually this is good because I think it narrows the problem to Acrobat XI and the Adobe Printer.  Acrobat itself prints without a problem. It's the "Adobe Printer" that seems to be the problem. Yes, I tried a repair. No change. I can't print to the Adobe Printer from any program, as it turns out. (I had never tried to print to Adobe from those programs so this was very useful in trouble-shooting.) So the Acrobat Converter Plug-in works in both browsers and in all MS Office programs, but you can not print to the Adobe PDF printer from File>Print.
0
 
LVL 51

Expert Comment

by:Joe Winograd, EE MVE
ID: 39784248
That is excellent progress in troubleshooting! To continue the troubleshooting, let's see if some other PDF print driver works. Although I mentioned earlier that I prefer Bullzip these days, I prefer doPDF for troubleshooting, because it has no dependencies on other software (Bullzip does). So I recommend downloading doPDF from here:
http://www.dopdf.com/

Install it and you will have a "printer" called doPDF v7. Then see if you can print to it. Regards, Joe
0
 
LVL 44

Expert Comment

by:Karl Heinz Kremer
ID: 39786904
There is a lot of information in this thread, but I don't think it was recommended to repair your Acrobat installation: Go to the Help menu and select to Repair your installation. Does this fix the problem with the frozen dialog (and the problem creating PDF documents via the Adobe PDF printer)?
0
 
LVL 44

Expert Comment

by:Karl Heinz Kremer
ID: 39786936
One more thing: I found this discussion, which has a similar symptom (hanging print progress dialog): http://forums.adobe.com/thread/1058522

A solution suggested in this discussion is to change the spooling behavior to "Start Printing after last page is spooled". I would give this a try.
0
 
LVL 51

Expert Comment

by:Joe Winograd, EE MVE
ID: 39786945
@khkremer,
Take a look at http:#a39784189
Yes, I tried a repair. No change.

Regards, Joe
0
 

Author Comment

by:normanml
ID: 39791548
Tried all above suggestions...except installing another pdf printer. In fact I have Snagit (a screen capture utility installed) and it will save it's capture as a pdf without problems, so I thought it redundant to try yet another program. I think we're at the point where I'm going to uninstall, then run Adobe's new V2 cleanup utility http://labs.adobe.com/downloads/acrobatcleaner.html. Yes, I remember to deactivate my current install before I uninstall and run the cleanup program. Then I'll reinstall from disk, update and we'll see. Captain: info on cleanup tool says it removes permissions from current install. If you search (and I've been at this for weeks), a number of people have encountered a problem with Acrobat 10-11 and Win7/64 trying to print to Adobe PDF printer.
0
 
LVL 51

Expert Comment

by:Joe Winograd, EE MVE
ID: 39791557
Just curious...why haven't you tried installing another PDF printer? That would be extremely helpful in isolating the problem. Screen capture is completely different from a print driver. Doesn't matter if the screen capture is saving to BMP, JPG, PDF, whatever...it's still different from a print driver. I'd really like to know what happens for you with doPDF, but if you're not willing to try, so be it. Regards, Joe
0
 

Author Comment

by:normanml
ID: 39792621
Joe et al: Okay, to satisfy my own curiosity I uninstalled Acrobat, ran the cleanup, reinstalled from disk (restarting all the way, disabling AVs etc, taking care not to miss the usual steps.) And...same problem..."Access denied", whatever program I'm trying to print from freezes, then appears the dialog above that says it wants to save to a folder that is not on WIN7 system.

Once I got that out of my system, I downloaded and installed dodpf-7, which worked just fine from all MS Programs and browsers as a selected printer. Quick too. I suppose I could stop here, accept what others on many forums (perhaps unknowingly) suggest is a bug in the latest version of Acrobat printer, and use the simple dopdf as a workaround, but like the Captain, I'd sure like to fix Acrobat. So what do you think, Joe? Is the Captain right? Somehow the Adobe installs are not granting the right permissions, or are you thinking something else.
0
 
LVL 51

Expert Comment

by:Joe Winograd, EE MVE
ID: 39792665
normanml,
The Captain is among the most knowledgeable Acrobat experts on EE (to be precise, he's #2 overall), as attested to by his Genius certification and more than 1.2 million points in the Adobe Acrobat Topic. He knows much, much more about Acrobat than I do and when he says something, I pay attention. I think if you hang in there with him in this thread, you stand a good chance of figuring out the problem. Also, you have khkremer in this thread, who, indeed, is the #1 overall Acrobat expert with an Ace certification in it and more than 3.1 million points just in the Acrobat Topic. If your problem is fixable, these two experts can do it!

My approach was a simple, pragmatic one – try another software package that performs largely the same function. While I often try to fix problems with a piece of software, in this particular case, I recommended the try-another-product approach because I've had a fair amount of grief myself with the Adobe PDF print driver. But if you really want to get Adobe PDF working, hang in there with the Captain and khkremer. Regards, Joe
0
 

Author Comment

by:normanml
ID: 39792710
khkremer and Capt: I have tried ALL your suggestions except changing permissions in the two folders and three registry keys you listed. I confess the last time I tried to change permissions I screwed up two files and folders and had to do a restore. But I found some directions that are step-by-step. One question, Capt, when you say grant full permission permission to everyone, you mean "Users (Name of PC\Users)? And if you have a fail safe tutorial for this, I'd be grateful. Thanks.
0
 
LVL 30

Expert Comment

by:captain
ID: 39795144
The good thing about the Acrobat TA is that we don't chase points and we respect other people's hunches and ideas. Acrobat is a complex beast and quite often it is a very specific event in the past that may be unique to a system that causes symptoms that could have many solutions.

joe (thanks for the kind words by the way) is perfectly correct in trying to get you back operational and a quick way for this is to provide a workaround with an alternative software.

I am somewhat hesitant with this as it may cause other symptoms and then make it harder to fix the issue, albeit that is just my approach.

That being said, I think the order of the solution should be to pinpoint the source of the problem and diagnose from there.

My problem is that for health reasons I am not every day on the site here so will need to reacquaint myself first before I post back.
0
 

Author Comment

by:normanml
ID: 39795207
Thanks, Capt. I hope you're on the mend. Had some recent ortho setbacks myself. Just to add one more anomaly, when I open the Adobe printer in D&P and try to print a test page, that dialog box also freezes or begins to actually flicker. I'm not adverse to editing the registry (I back it up every AM with Tweaking's Registry Backup) and I'm sure with a little guidance I can tweak the permissions. I too thank Joe. His workaround program (simple, clean and quick -- thank you Joe) allows me to continue. I also agree with you, however -- to let such an underlying problem go unsolved undermines the system. I've been reading the Adobe product forums and there seems to be no one solution, or at least a solution that addresses different sets of symptoms. For one user, it was increasing the HungAppTimeout value in the registry, but his anomalous behavior was different than mine. At all events, I await your recovery and ideas. Feel better.
0
 
LVL 44

Expert Comment

by:Karl Heinz Kremer
ID: 39795218
Here is the problem with problems like your's: There are (at least) two systems that need to work together in order to produce a PDF file at the end: Adobe Acrobat _AND_ the operating system. If there is something wrong with Acrobat, then there are three levels of "fixing" you can do:

Use the repair function in he Help menu
Uninstall and Re-install Acrobat
Uninstall Acrobat and run Adobe's Cleaner tool before you re-install the application

These steps are ordered in the amount of time it takes to complete the task, but also in how likely it is that the process will fix a corrupt installation.

The problem with uninstalling and re-installing is that the uninstaller will only remove "things" that it did install in the first place. There are configuration settings on the file system and in the registry that the uninstaller will not touch. Sometimes that's a good thing, other times it causes more problems. If you for example upgrade from a previous version of Acrobat, it's a good thing that the previous serial number remains on the system so that the new version will not bug you for the old serial number and the upgrade serial number, it already knows the old one.

But, if you have a corrupt configuration, you can uninstall and re-install as often as you want, it will not fix a thing. This is where the Cleaner tool comes in. You can download it from here: http://labs.adobe.com/downloads/acrobatcleaner.html You will also find instructions about how to use it on that page.

Having said that, let me give you a few more things you can try to collect more information about what's going on.

You can try to log in as a different user and see if printing to the Adobe PDF printer works. This will give you some idea about if the problem is in your user account, or if it's system wide. If the 2nd user can print, you have a a chance to clean your account settings and end up with a working printer. If it's deeper, then this may be harder.

One thing I've used in the past to fix a broken Adobe PDF printer is to rename the original one and then run Repair again. It will not "see" the correct printer and will recreate it from scratch.

Now, everything we've done up to this point was concentrating on what could be wrong in Adobe Acrobat. There are things that could be corrupt in Windows. I would not be the expert on that however...
0
 
LVL 30

Expert Comment

by:captain
ID: 39795230
The spooling link that khk may be worth trying although I think that the symptoms only look similar but may related to a different underlying cause as the user does not provide any information about an access denied error.

The way the printer spools only affects the handling of the document by the printer, After last page is spooled usually allows the user to cancel the job without wastage whilst immediate printing commences once the printer receives the first page.

In case of the Adobe PDF printer this should not make a discernible difference as the file is spooled to a temp file in any case. However it would be interesting to see if it affects the length of time until the error message is displayed or if indeed it just bails without error...

As for the permissions:

I strongly suspect (said hunch) that the error is exactly what it says. Adobe Printer is trying to write the final PDF to disk from the TMP spool file. When it tries to do that it encounters a file or folder permission for the user account that uses the printer and bails with the error.

However the prompting of a file location and selection of that should prevent this. I am unclear why this is happening, but to diagnose it would be worth checking this in the Registry.

Startmenu => Run or Search type regedit using admin right account.
Go to the one iof these two:
    HKLM\Software\Adobe
    HKLM\Software\Wow6432Node\Adobe
that includes the Adobe tree containing Acrobat

Right click and select 'Permissions'
You should see the following
Adobe permissionsCheck that 'Everyone' has Full access, as above

Now go to HKLM\System\CurrentControlSet\Control\Print\Printers\Adobe PDF and repeat the same, only this time check that all accounts listed apart from Users, have full access. Users should have 'Read' access. See below.
Printer permissions
What is your login account type? And can you replicate this is you use a system admin or domain admin account?

I will re read everything again in the morning, I am in the UK and my eyes are tired this time of night.

capt.
0
 
LVL 30

Expert Comment

by:captain
ID: 39795239
I see khk has covered some of the ground already. And the renaming the printer is a great idea!
0
 

Author Comment

by:normanml
ID: 39795589
1. Tried the repair from both the help menu and from the programs applet in CP. No change.

2. I have both renamed the printer (twice) and run repair on each new name. Then I deleted the printer and ran repair again. No change.

3. I have only one account on the machine, the administrator (me). I do not use a password and have it set to login automatically. There are no other users.

4. Capt asks: "And can you replicate this is you use a system admin or domain admin account?" I'm not sure what you mean here (my ignorance.) I'm not on a domain, rather a home LAN.

5. The error message (Access denied) stays on screen until I X it out.

6. The other box above, "Creating Adobe PDF" appears only when I try to print from FF and it too stays on screen until I X it out. (NB: It's trying to print to "C:\Documents and Settings," a folder that does no exist after XP and I'm on a WIN7 box.

7. I originally had V10 then upgraded to V11, uninstalling V10 and running the Adobe cleanup utility between the two and restarting after every step. Yesterday I uninstalled V11 with the regular uninstaller, downloaded version 2 of the cleanup utility and ran that. Again, restarting between each step. [I'm sure you're going to ask if the PDF printer worked in V10. Truth is, I just can't remember. A lot of the pdfing I do is from the NYT and it was easy enough to hit their print button, which stripped everything off the page save the text, then use the Adobe Converter Plug-in, which worked fine. The Times Website just changed now and the only way to PDF a single article is from the File>Print>Adobe PDF. (Again, for the moment, I'm using the simple workaround Joe suggested.)

8. First thing in the AM, I'll change/check the permission in the registry entries. Thank you for the tutorial.
0
 

Author Comment

by:normanml
ID: 39795810
Addendum for CAPT: Went to the first two keys you listed:
HKLM\Software\Adobe
HKLM\Software\Wow6432Node\Adobe

Your instructions sounded as if you wanted only one changed. Tried it with one. Rebooted, no change. Then changed the second one too (BTW my list had "Users" in each key instead of "Everyone."

 HKLM\System\CurrentControlSet\Control\Print\Printers\Adobe PDF was already as you wanted it.

Rebooted. Tried to print a test page from Adobe printer properties and the whole dialog froze again. Returned first two keys to former permission settings.
0
 

Author Comment

by:normanml
ID: 39797152
Addendum II: When I tried to print a test page with the "new" Adobe printers created by either renaming and repairing or by deleting the printer and repairing, the dialog box asking for a file name froze, as usual. But checking Event Viewer this morning, I found the first entry that might be useful in trouble shooting_Event 372 Printing a document. Here's the general text:

"The document Test Page, owned by Michael, failed to print on printer Adobe PDF. Try to print the document again, or restart the print spooler.
Data type: NT EMF 1.008. Size of the spool file in bytes: 0. Number of bytes printed: 0. Total number of pages in the document: 0. Number of pages printed: 0. Client computer: \\xx-xx. Win32 error code returned by the print processor: 259. No more data is available."

And here's the XML:

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Microsoft-Windows-PrintService" Guid="{747EF6FD-E535-4D16-B510-42C90F6873A1}" />
  <EventID>372</EventID>
  <Version>0</Version>
  <Level>2</Level>
  <Task>26</Task>
  <Opcode>12</Opcode>
  <Keywords>0x8000000000000840</Keywords>
  <TimeCreated SystemTime="2014-01-21T00:45:51.826658800Z" />
  <EventRecordID>410</EventRecordID>
  <Correlation />
  <Execution ProcessID="1668" ThreadID="1988" />
  <Channel>Microsoft-Windows-PrintService/Admin</Channel>
  <Computer>MN-PC</Computer>
  <Security UserID="S-1-5-21-2987587682-1074968332-1067063631-1001" />
  </System>
- <UserData>
- <PrintOnProcFailedEd xmlns:auto-ns3="http://schemas.microsoft.com/win/2004/08/events" xmlns="http://manifests.microsoft.com/win/2005/08/windows/printing/spooler/core/events">
  <Param1>Test Page</Param1>
  <Param2>Michael</Param2>
  <Param3>Adobe PDF</Param3>
  <Param4>NT EMF 1.008</Param4>
  <Param5>0</Param5>
  <Param6>0</Param6>
  <Param7>0</Param7>
  <Param8>0</Param8>
  <Param9>\\MN-PC</Param9>
  <Param10>259</Param10>
  <Param11>No more data is available.</Param11>
  </PrintOnProcFailedEd>
  </UserData>
  </Event>

Thanks.
0
 
LVL 30

Expert Comment

by:captain
ID: 39798058
Thanks for clarifying the user accounts, as you are the Admin, the issue does not apply and you can ignore advice for multiple accounts :)

It's trying to print to "C:\Documents and Settings," a folder that does no exist after XP and I'm on a WIN7 box.

I think the key is in here somewhere.

I am not sure what the log file is telling maybe someone can have a look. But I wonder where this location is coming from..?

Can you go to the registry again, specifically key:
HKLM\System\CurrentControlSet\Control\Print\Printers\Adobe PDF

Can you check the Location entry and make sure it is empty? (See below)
Key: Location
0
 
LVL 30

Expert Comment

by:captain
ID: 39798119
After this we should be looking at Distiller.

Before we embark on this however, just the simple question. Did you install anything, like a graphic programme outside the Adobe family such as Corel Draw or anything else that could affect permissions or printing?

If not lets look at Distiller. This is the processing engine that converts your printer file into a PDF.

The Distiller produces the PDF and will need to have access to your systems Temp location as well as Application data folders, if it does not get access there it may bail.

Can you first check if there is a lg file that gives us more insight. Look in location:
C:\Users\yourusername\AppData\Roaming\Adobe\Acrobat\Distiller #
(# is for your Acrobat version)

There should be a 'messages.log' file. Can you check and post the file if possible? Delete any sensitive info first though..

Next thing is to check if there is a Distiller folder in your temp folder.
C:\Users\yourusername\AppData\Local\Temp

If there is one, can you either rename the folder or try and creat a new file (any kind, txt will do) in that folder?

I wonder if there is a permission issue there....

capt.
0
 

Author Comment

by:normanml
ID: 39798325
1. I'll start with the log files. I assume you mean the Widows logs in Event Viewer. I checked the application log for Acrobat errors and found this: Event 1000 application error --

"Faulting application name: Acrobat.exe, version: 11.0.6.70, time stamp: 0x52b52919
Faulting module name: ntdll.dll, version: 6.1.7601.18247, time stamp: 0x521ea8e7
Exception code: 0xc0000374
Fault offset: 0x000ce753
Faulting process id: 0x730
Faulting application start time: 0x01cf16c181d284c3
Faulting application path: C:\Program Files (x86)\Adobe\Acrobat 11.0\Acrobat\Acrobat.exe
Faulting module path: C:\Windows\SysWOW64\ntdll.dll
Report Id: 651edb11-82b5-11e3-a9bf-463500000031" (Quotes are mine)

Here's the short report on the details from the entry:

   Acrobat.exe
   11.0.6.70
   52b52919
   ntdll.dll
   6.1.7601.18247
   521ea8e7
   c0000374
   000ce753
   730
   01cf16c181d284c3
   C:\Program Files (x86)\Adobe\Acrobat 11.0\Acrobat\Acrobat.exe
   C:\Windows\SysWOW64\ntdll.dll
   651edb11-82b5-11e3-a9bf-463500000031

(If you need XML let me know).

2. Checked HKLM\System\CurrentControlSet\Control\Print\Printers\Adobe PDF location and it is indeed empty.

3. I do not have a graphics program installed outside Adobe. I have a screen capture program called Snagit and Snagit it has a separate editor called Snagit Editor which has a few drawing tools in it -- a pen, line drawer, cropping and cutting tool, that sort of thing -- for marking up a capture.  From this program, you can save-as to a pdf. However, I just tried to print to pdf from it and it too froze. I've embedded the dialog here. Note the port: It's Desktop\*pdf.
Snagit editor freezes when trying to print to Adobe pdf printer
And when I closed the program, it left behind the every-present "Adobe PDF Access is denied" dialog.

 4. I've attached the messages.log you wanted.

5. Found Acrobat Distiller 11 Folder in C:\Users\yourusername\AppData\Local\Temp and put a .txt file there generated by a plain text editor. (Folder was previously empty.)

6. Finally,  I think I got  c:\documents and settings target folder above when I tried to print to adobe from Firefox. I don't get that progress dialog with other programs. They just freeze.
messages.log
0
 
LVL 30

Expert Comment

by:captain
ID: 39798422
1. OK, interesting, lets come back to that.

2. Thought as much, thanks for confirming.

3. I don't think this affects Adobe in any way.

4. Hm, messages log shows nothing unusual.

5. That indicates no issues with writing to the folder

6. Maybe a registry search would be another idea. But lets look at ntdll.dll first...

So with my limited Windows knowledge I think ntdll.dll is the library dealing with the Kernel Layer of the OS. That sounds pretty much as generic as it can get.

I would start this as a troubleshooting exercise first and check that it is not another programme interfering.

Startmenu > Run or Search box > msconfig

Then deselect, 'Load startup items':
deselect LSI
Reboot.

This disables anything that starts with windows and does not run as a service.
You will get a warning message and some of your programmes may not work as you are used to. But this is just to test if something interferes.

Start FF or whatever programme else that gives you the issue and repeat the PDF printing process..

2 possible outcomes.

1) It works...
Then we need to isolate the offending one, which is needle and haystack, but twice as tedious.

You will then reselect the option and disabling one by one the items on the 'Startup; tab and reboot and try after each change. when you found the offending one we should either kill it in the registry or startup folder, or uninstall the programme.

2) It still doesn't work
Then we just put it back as it was.

capt.
0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:normanml
ID: 39798531
Alas, it wasn't a conflict with another program.  Tried twice. Same result. "Access denied."

I stopped testing the printer with software. It hangs all applications. Instead, I use the printer properties and try to print test pages. I set the properties to spool and to start printing after last page is spooled. Driver name: "Adobe PDF Converter." Port is set to "Desktop\*.pdf." If I go to preferences and set the output folder to ANY folder, I get a message that "a test page has been sent to your printer." And after checking, there, of course, is no test page pdf. If I set output folder to "prompt for Adobe Pdf file name," I get:
What it look like frozen
These dialog boxes are frozen and unresponsive, but I can close them out after Xing them in a certain order.

After I did that, I checked the admin app logs and found this:

Fault bucket , type 0
Event Name: AppHangXProcB1
Response: Not available
Cab Id: 0

Problem signature:
P1: explorer.exe
P2: 6.1.7601.17567
P3: 4d672ee4
P4: aeb1
P5: 548
P6: acrotray.exe
P7: 11.0.6.70
P8:
P9:
P10:

Attached files:

These files may be available here:
C:\Users\Michael\AppData\Local\Microsoft\Windows\WER\ReportArchive\AppHang_explorer.exe_5662937f8a4e13cd89b832e8113c29d49718b77_13246ec9

Analysis symbol:
Rechecking for solution: 0
Report Id: ed23bffd-8390-11e3-bcd9-463500000031
Report Status: 0


Note P6

Also found a printservice 372 error:

The document Test Page, owned by  failed to print on printer Adobe PDF. Try to print the document again, or restart the print spooler.
Data type: NT EMF 1.008. Size of the spool file in bytes: 0. Number of bytes printed: 0. Total number of pages in the document: 0. Number of pages printed: 0. Client computer: \\-PC. Win32 error code returned by the print processor: 259. No more data is available.


Meanwhile, reading from above  -- "These files may be available here:
C:\Users\Michael\AppData\Local\Microsoft\Windows\WER\ReportArchive\AppHang_explorer.exe_5662937f8a4e13cd89b832e8113c29d49718b77_13246ec9 -- I went to the folders to look for the files."

I found two files that may be useful. The first, "report.wer" refers to an explorer error, generated when I tried to print the test file and I tried to get the dialog to set the output file myself. The second file, "Report (Acrobat).wer comes from an event entry about adobe crashing (Note please I had to change the .wer extension to .txt to upload here.
Report.wer.txt
Report--Acrobat-.wer.txt
0
 
LVL 30

Expert Comment

by:captain
ID: 39800935
thanks for the response, one step closer but nowhere near there...

I cannot see much from the wer reports, maybe the hang codes mean something to someone, but that is beyond my Windows knowledge.

However the error code 259 relates to network or destination issues, so I looked again at the posts and maybe I missed this before hand but you are saying port is Desktop\*.pdf...

I checked on mine and it is Documents\*.pdf. The desktop option is there but deselected.

Could you go to Devices & Printers and rightclick on Adobe PDF > Printer Properties > Ports and uncheck Desktop and  check Documents?

Whilst your there verify that on the security tab 'Everyone' has print rights and there are no special permissions anywhere?

capt.
0
 

Author Comment

by:normanml
ID: 39800996
Port is now Documents\*.pdf; in security Everyone has only print rights. Tried to print test page. Same result.
0
 
LVL 51

Expert Comment

by:Joe Winograd, EE MVE
ID: 39801149
There have been numerous suggestions earlier for registry changes. Here's another one. I have Acrobat X, so for me it is these:

HKEY_LOCAL_MACHINE\SOFTWARE\Adobe\Acrobat Distiller\10.0
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Adobe\Acrobat Distiller\10.0

Since you have Acrobat XI, it's probably these for you:

HKEY_LOCAL_MACHINE\SOFTWARE\Adobe\Acrobat Distiller\11.0
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Adobe\Acrobat Distiller\11.0

But if it's not exactly those names, I'm sure you can find them. One of the values under both of those keys is called DefaultPDFOutput. Here's what mine looks like (it's the same in both keys):
DefaultPDFOutputI suggest changing the data directly there in the registry to

Documents\*.pdf

for both keys, assuming, of course, that they don't already have that in it. If they do already have "Documents\*.pdf", then you could try changing it to some other folder to see if writing to Documents is the problem. Try something simple, like making a temp folder called C:\tempPDFout and putting

C:\tempPDFout\*.pdf

in the DefaultPDFOutput value of both keys. Regards, Joe
0
 

Author Comment

by:normanml
ID: 39801532
Thanks Joe. Just went through the drill (they were indeed Documents\*.pdf) and changed them. Rebooted. No dice. Then it occurred to me to create a new port with the new name. That didn't help either. Returned keys to original values. What's stunning here is how many other users have encountered the same thing. Occasionally it's a simple fix like changing preferences, but most of the time no solution is found and companies like Nitro get the business. I've read ever case in the Adobe forums. Anyway, got two Admin Event errors:

1002: "The program Explorer.EXE version 6.1.7601.17567 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Action Center control panel.
 Process ID: bd4
 Start Time: 01cf17c604d1a17b
 Termination Time: 16
 Application Path: C:\Windows\Explorer.EXE
 Report Id: b676abe6-83b9-11e3-855d-463500000031"


Which I assume was the dialog box wherein you pick the folder and file name you want for the pdf (and it had ".pdf" in the naming box.

And 372, a Printservice error:

The document Test Page, owned by Michael, failed to print on printer Adobe PDF. Try to print the document again, or restart the print spooler.
Data type: NT EMF 1.008. Size of the spool file in bytes: 0. Number of bytes printed: 0. Total number of pages in the document: 0. Number of pages printed: 0. Client computer: \\-PC. Win32 error code returned by the print processor: 259. No more data is available.
0
 
LVL 51

Expert Comment

by:Joe Winograd, EE MVE
ID: 39801565
OK, another idea. Maybe Windows Firewall (or whatever firewall you're using) is the culprit. Try disabling the firewall and see what happens.
0
 

Author Comment

by:normanml
ID: 39803907
Joe. I use the firewalls in the router and access point. Windows firewall disabled.
0
 
LVL 51

Expert Comment

by:Joe Winograd, EE MVE
ID: 39804209
I'm running out of ideas – and I don't say that very often! At this point, I'm delighted that doPDF is working for you. :)
0
 

Author Comment

by:normanml
ID: 39804415
Thanks, Joe. Question for all: If I uninstalled, ran the cleanup, what would happen if I then scrubbed the registry of all adobe entries? Would it affect other programs or the OS?
0
 
LVL 51

Expert Comment

by:Joe Winograd, EE MVE
ID: 39804545
The Adobe Reader and Acrobat Cleaner Tool is all the registry scrubbing I would do! I am not a fan of registry cleaning tools, such as CCleaner, although many folks like them, including experts here at EE. But sometimes they are too aggressive and do more harm than good. For this reason, I don't use registry cleaners myself, but I have been called in many times by users about programs that no longer work after running a registry cleaner. I have confidence in the Adobe Cleaner tool (that it likely would not affect other programs or Windows), but I would not scrub the registry beyond that. Just one man's opinion, of course. Regards, Joe
0
 

Author Comment

by:normanml
ID: 39807619
Well, gents, not sure where this leaves us. Only new development is that when I use IE11 and try to print to Adobe pdf, I get the dialog box asking me what to name the file and where to save it. The program does not freeze, but when I fill it in and hit save, I get:

Access Denied
And when I X out of the dialog, I get, again,

No Progress box with C: Documents and Settings
Yup, we're back to "documents and settings," which does not exist on the machine. Perhaps that's why I'm getting access denied errors. Program can't access what does not exist.  I searched the registry for "C:\documents and settings\" and it was not there. Searched hard drive for files with that text in it. Couldn't find it.
0
 
LVL 51

Expert Comment

by:Joe Winograd, EE MVE
ID: 39808101
Although I can't explain why your Adobe PDF is using it on a W7 system, I don't think that the <C:\Documents and Settings> path is a problem, because in W7, it is a link to <C:\Users>, so it should get resolved fine. But I could be wrong about that – it may be a problem. And I certainly don't understand why an install on a W7 system would be using it.

In an earlier post, I suggested making a temp folder called <C:\tempPDFout> (or whatever you prefer) and putting it in a couple of registry keys. You said that didn't work. New idea – try putting it in the Adobe PDF Output Folder in the Printing Preferences dialog of the Adobe PDF printer. In a previous post (http:#a39783909) you showed that you set it to "Prompt for Adobe PDF Filename", which freezes and crashes. Maybe it will work with a fixed folder name in there. It should look something like this:

Adobe PDF Output FolderNow it should automatically write the file (without a prompt) to <C:\tempPDFout\> (or whatever you decided to call it – mine is <D:\0tempD>). I don't have high hopes for this, but at this point, I'm grasping at straws. Of course, it works perfectly here. :)  Regards, Joe
0
 
LVL 30

Expert Comment

by:captain
ID: 39808903
Well, I agree with pretty much everything that has been posted since my last post, grasping straws is what this feels like.

However I think it is staring us in the face somewhere and we are not seeing it.

I have never been a great fan of the Adobe forums as quite often threads just fizzle out and you are left with half information, again looking at these during my journey with this question only further cements that point.

Perhaps that's why I'm getting access denied errors. Program can't access what does not exist.
This is the straw to grab onto. I repeat again, "Access denied errors are usually exactly that."

Will look at trying to reproduce your symptoms.
0
 
LVL 30

Expert Comment

by:captain
ID: 39808912
I strongly believe that something is overriding the location that you specify. And that is what we need to find. All the advice here is golden, but if there is another aspect that plays into this, we can give the best advice and still be stumped, as it should work but it cannot....


OK, I think we need to exclude the registry from this.

Logic dictates that the registry will be able to over-ride any preference settings, but as it is a Win7 PC there also should not be an entry for C:\Documents and Settings...

Can you do a registry search (CTRL+F)  for C:\Documents and Settings in regedit?

Maybe if we find something, it gives us a clue...
0
 
LVL 30

Expert Comment

by:captain
ID: 39808949
Additionally, what I also want to check is your Adobe PDF Printer Properties> Advanced Tab (see below):
Printer Properties>Advanced
Can you post a screenshot of that (ALT+PrtSc)?

The next thing after all that will be to create a new user account with Admin rights. Then log in with that new account and try again. This should rule out any profile issues (or point to it as the case may be)

Apologies for the triple post but I just got my straw collection out :o)
0
 

Author Comment

by:normanml
ID: 39809278
Checked registry for c:\documents and settings and it was not there.

Here's three screen shots that may be useful from the printer.






"Everyone" has "print" and "manage" permissions.
Creator Owner has only "manage documents" permissions.
The other two have print, manage printer.

Note to Joe, gave your suggestions a try. No go.
0
 
LVL 51

Expert Comment

by:Joe Winograd, EE MVE
ID: 39809484
More grasping at straws. I know you've done uninstalls and reinstalls of the full product, but another thing to try is a manual install of just the print driver. I found the instructions below at the Adobe forums, although it's for v9, not XI (so notice my comments about XI). I haven't tried them. I'm just offering them for your consideration (I took the liberty of correcting some typos – otherwise it is verbatim). Regards, Joe

Try this to add Adobe PDF printer manually on Windows 7 and Windows Vista.

If Windows 7 is Enterprise or better edition: (Admin rights required)

Start>search for printmanagement.msc and open the print management module

Expand the print server and expand the computer name to see available printers, drivers and printer ports.

- from printers ensure there's no Adobe PDF printer, if there is delete it

- go to ports and delete the PDF ports (the ones ending in *.pdf)

- go to drivers and delete the PDF converter.

Take note if any errors occur, but continue with the following steps regardless.

If on Windows 7 home edition, just go to start>Devices and Printers and ensure PDF pritner is not listed.

Then open the registry (if any errors deleting these keys happen, see below)

1: go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Printers

delete any Adobe PDF printer subkey present

2: go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors

delete the PDF port monitor if present

3: go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Printers

again delete any pdf printer subkey

If any errors occur, you need to set the owner of the key to the currently logged in admin user, then ensure that user has full control.

Do this by right-clicking the key and selecting permissions, clicking on advanced, then the owner tab.

Once all that has been done, open a command line as administrator.

Copy and pate the following commands in order

1: net stop spooler

2: rundll32.exe setupapi.dll,InstallHinfSection AdobePDFPortMonitor 128 C:\Program Files (x86)\Adobe\Acrobat 9.0\Acrobat\Xtras\AdobePDF\AdobePDF.inf

*** Begin JW note

This is obviously for V9. For my Acrobat X, I found it here:

c:\Program Files (x86)\Adobe\Acrobat 10.0\Acrobat\Xtras\AdobePDF\AdobePDF.inf

For your Acrobat XI, it's probably here:

c:\Program Files (x86)\Adobe\Acrobat 11.0\Acrobat\Xtras\AdobePDF\AdobePDF.inf

But if it isn't, a search for <AdobePDF.inf> should find it.

*** End JW note

3: net start spooler

4:rundll32.exe printui.dll,PrintUIEntry /if /b "Adobe PDF" /f "C:\Program Files (x86)\Adobe\Acrobat 9.0\Acrobat\Xtras\AdobePDF\AdobePDF.inf" /r "Documents\*.pdf" /m "Adobe PDF Converter"

*** JW Note: same as my previous note.

That should set back the pdf printer.
0
 

Author Comment

by:normanml
ID: 39810254
I'll try it right now, Joe. Meanwhile, some more troubling shooting info. Found this when I ran the action center trouble shooter:

1. Action center report in three parts:
ActionCenterPart1ActionCenterPart2ActionCenterPart3
2. The only time I'm getting an "access denied" error is when I try to print with "prompt for Adobe PDF Filename," i.e. call the explorer.exe dialog to name the file and destination. Logically, does this suggest that the problem is communication between something in the pdf printer and explore.exe? When I put anything else in that settings box, any folder, nothing happens, no dilaogs...and of course no file is produced.
0
 
LVL 51

Expert Comment

by:Joe Winograd, EE MVE
ID: 39810465
Maybe there's an old, 32-bit version of the Adobe PDF print driver on your system. My experience is that print drivers are very sensitive to 32-bit vs. 64-bit. So even though Adobe Acrobat itself is a 32-bit program and runs on both 32-bit and 64-bit systems, my guess is that there's a different Adobe PDF print driver specifically for x64. I say "guess" in this case, because I don't know for sure, but I can tell you for a fact that this is true of PaperPort. There are many reports of earlier versions of PaperPort running fine on x64 systems, but not the PaperPort Image Printer. The latest version of PaperPort is, like Acrobat, a 32-bit program that runs fine on x64, but it has a specific PaperPort Image Printer for x64.

Btw, here's a related link:
http://blogs.adobe.com/dmcmahon/2012/06/04/acrobat-pdf-printer-missing-after-installation-on-windows-64-bit/

Just another straw. :)  Regards, Joe
0
 

Author Comment

by:normanml
ID: 39810975
Decided to try the other drivers in the list before the above and the now default settings and Adobe Security boxes are blank on drop down. Tired a repair and every driver in the list. I'll try the above in the morning. If I have to uninstall  yet again, I might just got with Nitro or some other full editor.
0
 
LVL 51

Expert Comment

by:Joe Winograd, EE MVE
ID: 39811136
> If I have to uninstall yet again, I might just got with Nitro or some other full editor.

I've heard nothing but good things about Nitro and there are plenty of other well-regarded full editors out there, but if the rest of Acrobat is working well for you, and the only problem is the Adobe PDF print driver, why not keep the rest of Acrobat and just continue to use doPDF as the PDF printer? Or if there's something you don't like about doPDF, experiment with one or more of the other five PDF print drivers in my http:#a39778255 post until you find something you really like. Regards, Joe
0
 

Author Comment

by:normanml
ID: 39812170
Good counsel and I've thought of doing so. I'm going to try the driver fix you found in ID: 39809484. If that fails, I'm going to try Bullzip. Dopdf, despite the highest resolution setting, does not produce a high quality pdf, at least on this rig. Text is a big raggedy. What are you using at the moment and how are the results? I need to think about all this. Also, I have Acrobat 10. Wonder if I should try an uninstall of 11 and see what happens with 10, though many of the posts on the adobe forum that deal with adobe printer problems also are about 10.
0
 
LVL 51

Assisted Solution

by:Joe Winograd, EE MVE
Joe Winograd, EE MVE earned 250 total points
ID: 39812227
I'm using Bullzip now and I'm happy with the quality. Re quality on doPDF, look at its Printing Preferences and you'll see a "Resolution (dpi) quality". Try cranking that up a little. I use 300 and am happy with the results but you may want to try 600 – I wouldn't go higher than that. Btw, Bullzip also has a DPI setting in its Printing Preferences, and I don't think that I ever changed it after the install – I just checked it and it is at 600 DPI. Btw2, I have Acrobat Standard X (10). Regards, Joe
0
 
LVL 30

Expert Comment

by:captain
ID: 39812338
normanml,

in respect to your comment, I cannot see any of the screenshots you posted.

Can you post a screenshot of that (ALT+PrtSc)?

The next thing after all that will be to create a new user account with Admin rights. Then log in with that new account and try again. This should rule out any profile issues (or point to it as the case may be)

Is there any update on this?
0
 

Author Comment

by:normanml
ID: 39812842
Sorry Capt. If these are not what you want, please give a yell and I'll get them posted ASAP123
Since you last posted I have:

1. uninstalled, run the cleanup, then hand deleted every Adobe Folder on the HD. Then I reinstalled from disk and I update with 11.0.6. Program runs fine; still no printing from Adobe printer. Easiest way to test is to try to print a test page. When I do, the Save as dialog freezes and I have to kill the process.4 and here's what left behind: 5. Plus a dialog that had "Windows Explorer" in the Title Bar with the three choices close program, check for solution, or wait. IEII is the only program that doesn't freeze and give me an active save-as dialog. But as soon as I fill it in and hit save, IE plus the dialog freeze and I get our unwanted guest 6. Again all MSOffice programs freeze immediately when I try to print to pdf. Clearly the driver is not talking to winExplorer.

Tried Joe's ID: 39809484. This nicely recreated the driver (and settings I had mangled by trying the find-a-new driver  option under "advanced"). But, alas, it's behavior is exactly the same. Security setting are Everyone/print; Creator Owner/manage documents; Michael (name of computer)/print-manage-manage; Administrators (name of my pc\Administrators) print, manage, manage.

I think that's about it.
0
 

Author Comment

by:normanml
ID: 39813333
I created a new user profile (admin) but when I went to log in, I got a message that the profile was missing and it blocked me. (Windows#@$%&*!) So I enabled the guest account, logged into that fine, ran MsWord, and it printed a file to the adobe printer.
0
 
LVL 30

Expert Comment

by:captain
ID: 39813425
I think we are dealing with some issue of corruption here, either your profile is corrupted or the Windows Security is having a problem.

The fact that a guest account can print and you cannot, and that an account you created as admin with full admin rights is somehow not working correctly suggests that we are dealing with something much wider than a PDF issue.

I think we can suspend fixing Acrobat for now.

The question is more how to get you back on track? I guess you have not noticed anything else unusual...?
0
 

Author Comment

by:normanml
ID: 39813500
Nothing other than a persistent 315 print spooler error for months. It was a network printer, and after many months looking at everything several times, I discovered I was sharing it, so it was trying to run the spooler service twice and that was causing the error. Stopped the sharing and the error was gone. Everything else seems to be working fine. I'll try again to set up a second admin account.

Meanwhile, I got a number of errors trying to create that admin account and log on. Perhaps you'll find some of the log material useful:

First winlogon error 6004: The winlogon notification subscriber <Profiles> failed a critical notification event.

Then a User Profile General 1509 warning: Windows cannot copy file C:\Users\Default\ntuser.dat to location C:\Users\Test Account\ntuser.dat. This error may be caused by network problems or insufficient security rights.  DETAIL - Access is denied.

Then a 1511 error, the one I got when I tried to logon to the new account: Windows cannot find the local profile and is logging you on with a temporary profile. Changes you make to this profile will be lost when you log off.

Then another 1509 with the same details.

Then a 1500 (I think this was part of the message I got when I tried to log on to the new account: Windows cannot log you on because your profile cannot be loaded. Check that you are connected to the network, and that your network is functioning correctly.  DETAIL - Only part of a ReadProcessMemory or WriteProcessMemory request was completed.

Finally this from the guest profile, three 10016 errors all saying: The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID {8BC3F05E-D86B-11D0-A075-00C04FB68820}  and APPID
{8BC3F05E-D86B-11D0-A075-00C04FB68820}
 to the user MN-PC\Guest SID (S-1-5-21-2987587682-1074968332-1067063631-501) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.
0
 

Author Comment

by:normanml
ID: 39813639
This might lead to an answer: http://support.microsoft.com/kb/947215 (Method 1). Or it's time for me to find a tech who knows the OS backwards and forwards to straighten this out.
0
 
LVL 30

Accepted Solution

by:
captain earned 250 total points
ID: 39817687
Well I think we have taking this as far as the Acrobat TA can support this.

I would conclude that you have a security layer issue with your machine. This may have been due to the print spooler but more likely is down to subsequent actions that may have compromised or corrupted your profile. The spooler may give the fundamental clue why you see this manifesting itself in a PDF print process.

I can see that your logs show more access denied messages similar to the Adobe PDF issue you have reported. As I said before the 'Access denied' is usually just that.

So I think your Adobe issue is a symptom of a much bigger underlying problem. You can probably fix this by asking this in the Windows 7 TA, but from experience this may  be a much longer process, as experts will either ask you to use a bottle of registry cleaner (Don't!) or will tread really carefully to not make the problem worse. Which will be a lengthy trial and error process.

You may want to have a look in 'Services' to see if there is anything peculiar about the entries on the 'Log on' tab for the Print Spooler service. It should be using the local system account, not a specified account of sorts....but I am not convinced it is...
Spooler rightsMy..., and I don't want to say advice, but my course of action would be to back up the machine and ensure any and all data/settings, bookmarks and files are safe. And then do a system restore before the time you had the spooler issue. But always with the view to do a flatten and reinstall if that fails to fix it.

You may find this a bit drastic, but in 20 years of dealing with users in domains and associated profile problems, I almost all of the time ended up either deleting the profile or doing a complete reinstall/re-ghost. And it is a lot quicker than an attempt to fix as you also won't know what else is affected.

capt.
0
 

Author Closing Comment

by:normanml
ID: 39817772
Capt-Joe. So many thanks for all your work and time and help. Capt was right -- there's a flaw in the Os setup and I had to call in an OS tech. They're going to try a sys repair here Thursday. As for Adobe, it was Nod32. In the normal course of trouble-shooting, we uninstall Nod32, replaced it with Microsoft Security Essentials, ran ComboFix (excellent tool that not only look for hidden badware but missing or corrupted system files, and low and behold, the damn printer driver worked. When we were finished for the day, I decided to reinstall Nod32, which has served me well for years, and bingo, down went Adobe again. I disable the AV, ran ComboFix again, and again Adobe printer worked...until I rebooted, which reset Nod32 back to its working state. Send off a ticked to ESET and within an hour they called, worked for 20 minutes and want to work again for a couple of hours remotely on Thursday. But I'm half tempted to dump the program, return to Microsoft Security Essentials (which seems to have no conflicts with my software). We'll see. Point is, you two have gone well beyond the call of EE duty and have my heartfelt thanks. Which I could give you both 100,000 points each.
0
 
LVL 30

Expert Comment

by:captain
ID: 39817859
Thanks much for the accept and your kind words.

I am glad there is light at the end of the tunnel.

Good luck with everything!
capt.
0
 
LVL 51

Expert Comment

by:Joe Winograd, EE MVE
ID: 39817983
You're welcome. And thanks to you for the nice words...and for that last post...very interesting! Too bad I didn't include turning off the anti-virus in my post on the 22nd where I suggested turning off the firewall – we have may have arrived here a week sooner! :)  In any case, thanks to you for being a responsive author during this thread (not all are)...made it a pleasure to try to help you. Regards, Joe
0
 

Author Comment

by:normanml
ID: 39819732
Footnote: Spent an hour on the phone with Adobe. Instead of a simple "repair," tech deleted a number of items from registry, then deleted several drivers, then did "a rebuild reinstall/repair," as he called it, from the msi. And he fixed it. Rebooted and worked fine. Wish I'd had a screen record on in case it happens again. Tech said he's dealt with problem before. He was clearly working from a script, but it was a script for printer hangs and freezes.
0
 
LVL 51

Expert Comment

by:Joe Winograd, EE MVE
ID: 39821596
Good stuff! So it's definitely a known issue to Adobe. I recommend calling back and asking them to email you the instructions...better to have it in your bag of tricks than relying on the next agent. Or, if the agent emailed you after the call that would be a great way to ask. In any case, thanks for the post – very good to know! Regards, Joe
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

PDF files have been in the limelight due to its unmatched features.  Personal documents, emails, business reports and eBooks are all converted into PDF files owing to peerless features provided by it. Adding watermark to a PDF file is a method to se…
Citrix XenApp, Internet Explorer 11 set to Enterprise Mode and using central hosted sites.xml file.
In this video, we show how to perform Bates Numbering/Stamping of PDF documents using Power PDF Advanced, the newest product from the Document Imaging division of Nuance Communications. There are two editions of Power PDF — Standard and Advanced. Th…
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

24 Experts available now in Live!

Get 1:1 Help Now