Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Configuring the ASA5510 to connect with the DSL Modem for Wan Connection and Switch for the Lan

Posted on 2014-01-14
2
745 Views
Last Modified: 2014-01-16
I currently have a DSL modem which is configured with static routing and connects to the switch where I have a number of device, till there everything is working fine, I have bought an asa 5510 so I can have remote sites connecting with it through VPNs. I want to configure the asa 5510 to receive WAN Connectivity from the DSL Modem which is Cisco EPC3925, This modem is currently configured with static IP routing. What I have tried to do is to set it as a bridge mode only and configured the following configurations on my ASA:  

ASA5510(config)# interface Ethernet0/0
ASA5510(config-if)# nameif outside
ASA5510(config-if)# security-level 0
ASA5510(config-if)# ip address 213.165.177.76 255.255.255.224 (My Static IP address provided from the ISP)
ASA5510(config-if)# no shut


ASA5510(config)# interface Ethernet0/1
ASA5510(config-if)# nameif inside
ASA5510(config-if)# security-level 100
ASA5510(config-if)# ip address 192.168.0.1 255.255.255.0
ASA5510(config-if)# no shut


ASA5510(config)# global (outside) 1 interface
ASA5510(config)# nat (inside) 1 0.0.0.0 0.0.0.0

ASA5510(config)# route outside 0.0.0.0 0.0.0.0 213.165.177.65 1 (ISP Default Gateway)

ASA5510(config)# dhcpd dns 212.56.128.132 (ISP DNS Server)
ASA5510(config)# dhcpd address 192.168.0.10-192.168.0.200 inside
ASA5510(config)# dhcpd enable inside

I have tried this but it haven't worked, I have another DNS Server I haven't used which is 212.56.128.132, if this can help. I have set the IP address of the internal switch to static  which is 192.168.0.205. Sorry I am quiet new to this field.

Thanks in advance for all your help.
0
Comment
Question by:bixkli
2 Comments
 
LVL 37

Accepted Solution

by:
ArneLovius earned 500 total points
ID: 39781215
What version is the ASA running?

Your config would be good for versions lower than 8.3

I don't configure firewalls to use external DNS, I always use an internal DNS server.

If you are not able to traceroute over the ASA to the Internet, you might need to specifically allow ICMP, or it could be an issue with your DSL modem in bridge mode.
0
 

Author Closing Comment

by:bixkli
ID: 39785107
The ICMP Worked but I have to add also the dns lookup server and enter specifically the dns. Thanks for all your help :)
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Cisco Pix/ASA hairpinning The term, hairpinning, comes from the fact that the traffic comes from one source into a router or similar device, makes a U-turn, and goes back the same way it came. Visualize this and you will see something that looks …
This past year has been one of great growth and performance for OnPage. We have added many features and integrations to the product, making 2016 an awesome year. We see these steps forward as the basis for future growth.
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question