SharePoint adds underscore character at the end of a new folder name

I am creating folder  with the name Index_File in SharePoint. SharePoint instead adds an underscore character in the name of the folder at the end of the name and it becomes Index_File_
I would like to use the specific name for the folder Index_File with no additions.
The environment is using  Windows Server 2008 and SharePoint 2010 with 300 users in Win 7 64 bit and 32 bit clients


Thanks
helnikAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jamie McAllister MVPCloud ExpertCommented:
This is known behavior, because you have the word File in your folder name;

http://sharepoint4newbie.blogspot.ch/2012/06/sharepoint-new-folder-end-with.html

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
helnikAuthor Commented:
Thanks
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.