?
Solved

SBS 2011 VPN issue

Posted on 2014-01-14
16
Medium Priority
?
578 Views
Last Modified: 2014-01-20
Hello,

 I have a SBS 2011 server, on which I configured the VPN via the console.  When I try to connect to the server, I receive the error - see the attached file. I forwarded 1723 port to the SBS, and no luck. The user is in VPN group.

Any ideas how to troubleshoot that?

The SBS is behind a Vingor 2920, to which I have connected a BT Hub.
0
Comment
Question by:goliveuk
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 7
16 Comments
 
LVL 22

Expert Comment

by:David Atkin
ID: 39779196
Hello,

Have you forwarded the ports on both the Draytek and the BT Hub?

Make sure that the Draytek VPN Settings are disabled.  This has caused me issues previously.
0
 

Author Comment

by:goliveuk
ID: 39779246
I forwarded 1723 from the BTHub to the Draytek, and from the Draytek to the SBS. canyouseeme.org show 1723 as opened :)
0
 
LVL 22

Expert Comment

by:David Atkin
ID: 39779258
Did you check that the Draytek VPN Settings where disabled in:

VPN and Remote Access> Remote Access Control.

All the options want to be unticked.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:goliveuk
ID: 39779283
All of them unticked.
0
 
LVL 22

Expert Comment

by:David Atkin
ID: 39779298
Can you upload the file attachment?  It didn't upload originally
0
 

Author Comment

by:goliveuk
ID: 39779308
Uuups, Here it is :)
sbs-vpn.png
0
 
LVL 22

Expert Comment

by:David Atkin
ID: 39779366
I've done a port test on 1723 to the location in your screenshot.  It shows it as closed.

Can you create the VPN to the IP Address instead of the name?
0
 

Author Comment

by:goliveuk
ID: 39779383
0
 
LVL 22

Expert Comment

by:David Atkin
ID: 39779393
Your remote.oppco.co.uk record is currently pointing to:
86.182.224.134

Can you try creating the VPN connection using the IP address rather than the name.
0
 

Author Comment

by:goliveuk
ID: 39779406
Yep, I tried directly to the IP, and it is the same.

P.S. I will fix the record later.
0
 
LVL 22

Expert Comment

by:David Atkin
ID: 39779418
No problem, just making sure we are on the same page (Y).

Can you log in using the Administrator credentials?

If possible, can you post a screen shot of the port rules in the BT Hub and Draytek - Sorry to be a pain!
0
 

Author Comment

by:goliveuk
ID: 39779449
Here both of them
Draytek.png
BTHub.png
0
 
LVL 22

Expert Comment

by:David Atkin
ID: 39779502
Does your OWA port mapping work?

Any particular reason why you're using the BT Router still and not the DrayTek direct?

Do you get any errors in the event logs relating the VPN Connection or does nothing show?
0
 

Author Comment

by:goliveuk
ID: 39779558
OWA works like a charm.

Here is what I got just now:

A connection between the VPN server and the VPN client <ip adress> has been established, but the VPN connection cannot be completed. The most common cause for this is that a firewall or router between the VPN server and the VPN client is not configured to allow Generic Routing Encapsulation (GRE) packets (protocol 47).
0
 
LVL 22

Accepted Solution

by:
David Atkin earned 2000 total points
ID: 39779648
I would probably pin this on the BT Router (Or at least start trouble shooting from there).

From researching it looks like others have also had issues with VPN's on the BT Routers.  

Any reason why you are using the BT Router and not direct to the Draytek?

The Draytek should auto forward the VPN Protocol (GRE 47) when doing a port mapping looking at this:
http://www.draytek.co.uk/archive/kb_vigor_passthrough.html
0
 
LVL 22

Expert Comment

by:Olaf De Ceuster
ID: 39780448
You need to allow GRE on the router.
(Or PPTP pass through as it is sometimes called).
Check your routers documentation.
Hope that helps,
Olaf
0

Featured Post

Ransomware Attacks Keeping You Up at Night?

Will your organization be ransomware's next victim?  The good news is that these attacks are predicable and therefore preventable. Learn more about how you can  stop a ransomware attacks before encryption takes place with our Ransomware Prevention Kit!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Let’s list some of the technologies that enable smooth teleworking. 
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question