Solved

IPv6 over OSPF Problem

Posted on 2014-01-14
20
375 Views
Last Modified: 2014-01-14
Hello,

I had problems setting up ipv6 over ospf

show ipv6 route ospf doesn't show any result.

here is my config:

R1#show run
Building configuration...

Current configuration : 1265 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
interface Loopback1
no ip address
ipv6 address FEC0:1::1/128
ipv6 enable
ipv6 ospf 1 area 0
!
interface FastEthernet0/0
ip address 1.1.1.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
shutdown
no fair-queue
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
!
ipv6 router ospf 1
router-id 1.1.1.1
log-adjacency-changes
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

R1#

-------------------------------------

R2#show run
Building configuration...

Current configuration : 1268 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
interface Loopback1
no ip address
ipv6 address FEC0:2::2/128
ipv6 enable
ipv6 ospf 1 area 10
!
interface FastEthernet0/0
ip address 1.1.1.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip address 2.2.2.1 255.255.255.252
no fair-queue
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
!
ipv6 router ospf 1
router-id 2.2.2.2
log-adjacency-changes
area 10 virtual-link 3.3.3.3
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

R2#

-----------------------------------------

R3#show run
Building configuration...

Current configuration : 1268 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
interface Loopback1
no ip address
ipv6 address FEC0:3::3/128
ipv6 enable
ipv6 ospf 1 area 10
!
interface FastEthernet0/0
ip address 3.3.3.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip address 2.2.2.2 255.255.255.252
no fair-queue
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
!
ipv6 router ospf 1
router-id 3.3.3.3
log-adjacency-changes
area 10 virtual-link 2.2.2.2
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

R3#

------------------------------------------------------

R4#show run
Building configuration...

Current configuration : 1227 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
interface Loopback1
no ip address
ipv6 address FEC0:4::4/128
ipv6 enable
ipv6 ospf 1 area 20
!
interface FastEthernet0/0
ip address 3.3.3.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
shutdown
no fair-queue
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
!
ipv6 router ospf 1
router-id 4.4.4.4
log-adjacency-changes
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

R4#
--------------------------------------
ipv6-over-ospf.png
0
Comment
Question by:tzak12525
  • 10
  • 7
  • 3
20 Comments
 
LVL 11

Expert Comment

by:Miftaul
Comment Utility
You have enabled IPv6 OSPF on loopback interfaces. Ipv6 is not configured on physical interfaces. You haven't configured physical interfaces for participating in ospf, where are we expecting adjacency, no ospf configurations on the interfaces.

 Please check.
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
In the future, please use the code feature when posting configs.

While you have IPv4 connections between some of the routers, you don't have any IPv6 addresses defined on those links nor do you have OSPFv3 configured on the links.

It also appears that you're doing multi-area OSPF so don't forget that all ABR's need to have a connection to the backbone area (area 0).  Or you could simplify things and just do single-area OSPF.
0
 

Author Comment

by:tzak12525
Comment Utility
Yes But I want to run IPv6 over IPv4

Links between routers should remain in IPv4

only Loopbacks have IPv6 ip addresses
0
 
LVL 11

Expert Comment

by:Miftaul
Comment Utility
To run, ipv6 over ipv4, we need to have the tunnel interface, right.
0
 

Author Comment

by:tzak12525
Comment Utility
how to do that
0
 
LVL 11

Expert Comment

by:Miftaul
Comment Utility
What exactly are we trying to achieve.

We can do GRE tunnel between r2 and r3 to make discontigous areas contigous, all areas must connect to area 0.

Virtual link will only work if its only ospfv2 or orly ospfv3. Not a mix of both.
0
 

Author Comment

by:tzak12525
Comment Utility
Ok,

here is the idea, everything was done in IPv4, OSPF adjecencies, virtual link etc...

then one day IPv6 came in to the picture and there must be the connectivity, for Labbing, i chose Loopbacks so we still need to keep the connectivity in all the network without removing IPv4 between routers...

you got me now?
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
Setup an IPv4 GRE tunnel between the routers and do IPv6 inside the tunnel for the OSPF traffic.

This should have everything you need.
0
 

Author Comment

by:tzak12525
Comment Utility
Do I have to setup IPv4 OSPF connectivity first then proceed with GRE?


Thanks
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
Yes.
0
VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

 

Author Comment

by:tzak12525
Comment Utility
I have a question just to make sure i'm doing the right thing:

Should I create a GRE tunnel between R1 and R2 then R1 and R3 then R1 and R4 and so on with the other routers?
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
I could answer that if I knew the topology.  So if you want to upload a topology diagram, I'd be happy to take a look.
0
 

Author Comment

by:tzak12525
Comment Utility
it is included with this question, i named it diagram
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
Then yes, you will have to create multiple tunnels since each router has a loopback with an IPv6 address that you're trying to advertise.
0
 

Author Comment

by:tzak12525
Comment Utility
I'm still having an issue:

I tried that GRE tunnel between R1 and R2 and vice versa

the ping fails when i try to ping R1's Loopback from R2 or vice versa

I attached a txt file where i have the current configuration.
configuration.rtf
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
Is the physical interface up?
Can you ping the other end of the link?
Is the tunnel up? (sho ip int brief)
Can you ping the other end of the tunnel?
0
 

Author Comment

by:tzak12525
Comment Utility
On R1:

R1#ping 172.16.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/20/24 ms
R1#


Tunnel1                    172.16.1.1      YES manual up                    up

R1#show ip int tunnel1
Tunnel1 is up, line protocol is up
  Internet address is 172.16.1.1/30
  Broadcast address is 255.255.255.255
  Address determined by setup command
  MTU is 1400 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Outgoing access list is not set
  Inbound  access list is not set
  Proxy ARP is enabled
  Local Proxy ARP is disabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP fast switching on the same interface is disabled
  IP Flow switching is disabled
  IP CEF switching is enabled
  IP CEF Feature Fast switching turbo vector
  IP multicast fast switching is enabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast, CEF
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Policy routing is disabled
  Network address translation is disabled
  WCCP Redirect outbound is disabled
  WCCP Redirect inbound is disabled
  WCCP Redirect exclude is disabled
  BGP Policy Mapping is disabled
R1#
------


R2:

R2#ping 172.16.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/20/24 ms
R2#


Tunnel1                    172.16.1.2      YES manual up                    up

R2#show ip int tunnel1
Tunnel1 is up, line protocol is up
  Internet address is 172.16.1.2/30
  Broadcast address is 255.255.255.255
  Address determined by setup command
  MTU is 1400 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Outgoing access list is not set
  Inbound  access list is not set
  Proxy ARP is enabled
  Local Proxy ARP is disabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP fast switching on the same interface is disabled
  IP Flow switching is disabled
  IP CEF switching is enabled
  IP CEF Feature Fast switching turbo vector
  IP multicast fast switching is enabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast, CEF
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Policy routing is disabled
  Network address translation is disabled
  WCCP Redirect outbound is disabled
  WCCP Redirect inbound is disabled
  WCCP Redirect exclude is disabled
  BGP Policy Mapping is disabled
R2#
0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 500 total points
Comment Utility
Your tunnel is an IPv4 tunnel. You need an IPv6 tunnel.
0
 

Author Comment

by:tzak12525
Comment Utility
Ok, let me retry that
0
 

Author Comment

by:tzak12525
Comment Utility
worked
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
Data center, now-a-days, is referred as the home of all the advanced technologies. In-fact, most of the businesses are now establishing their entire organizational structure around the IT capabilities.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now