Solved

Command for MPIO

Posted on 2014-01-14
12
1,639 Views
Last Modified: 2014-02-21
I am looking for a command or a script to find the version of MPIO for a list of servers (Win2k8 and Win2k3)
0
Comment
Question by:jmohan0302
  • 7
  • 5
12 Comments
 
LVL 6

Expert Comment

by:Sasa Kranjac
Comment Utility
You can manage MPIO using PowerShell but MultiPath I/O is available on Windows Server 2012 only.

Here are the cmdlets for MPIO on Microsoft TechNet: MultiPath I/O (MPIO) Cmdlets in Windows PowerShell

Another nice article can be found here: Managing MPIO with Windows PowerShell on Windows Server 2012
0
 

Author Comment

by:jmohan0302
Comment Utility
Thnx.  I would like to know can this be used to find the version of MPIO. It will be helpful if I get a script to find this
0
 
LVL 6

Expert Comment

by:Sasa Kranjac
Comment Utility
During the MPIO install on Windows Server 2008 R2 corresponding registry subkeys are created. You could write a script to query remote computers if such registry subkeys exist.
For example, to find MPIO driver version on remote computer type:

C:\Windows\system32>reg query \\Machine\HKLM\SYSTEM\CurrentControlSet\Control\Class\{4D36E97B-E325-11CE-BFC1-08002BE10318}\0004 /s

where Machine is the name of the computer you are querying. If the command is run locally, \\Machine\ is omitted.
0
 

Author Comment

by:jmohan0302
Comment Utility
I tried this command but I am getting the below error:

ERROR: The system was unable to find the specified registry key or value.

whats next
0
 
LVL 6

Expert Comment

by:Sasa Kranjac
Comment Utility
Try first searching if MPIO specific registry entry exist, and if it does query the key to find driver version. Examples below perform search on local server.

1. search for entries

reg query HKLM\SYSTEM\CurrentControlSet\Control\Class /s /f "Microsoft Multi-Path Bus Driver"

2. query the key you got as a result to find driver version. It should be listed under DriverVersion
(I am using the key I got from one of my servers as an example)

reg query HKLM\SYSTEM\CurrentControlSet\Control\Class\{4D36E97B-E325-11CE-BFC1-08002BE10318}\0004
0
 

Author Comment

by:jmohan0302
Comment Utility
I got the following output from one of my machine, in this where can I find the MPIO version, also the powershell command let is not found for MPIO, do I need to install any powershell module for MPIO


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E97B-E325-11CE-BF
C1-08002BE10318}
    LegacyAdapterDetection    REG_DWORD    0x0
    Class    REG_SZ    SCSIAdapter
    ClassDesc    REG_SZ    @%SystemRoot%\System32\SysClass.Dll,-3005
    (Default)    REG_SZ    Storage controllers
    IconPath    REG_MULTI_SZ    %SystemRoot%\System32\setupapi.dll,-10
    Installer32    REG_SZ    SysClass.Dll,ScsiClassInstaller

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E97B-E325-11CE-BF
C1-08002BE10318}\0000
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E97B-E325-11CE-BF
C1-08002BE10318}\Properties
0
Why do Marketing keep bothering you?

Is your marketing department constantly asking for new email signature updates? Are they requesting a different design for every department? Do they need yet another banner added? Don’t let it get you down! There is an easy way to manage all of these requests...

 
LVL 6

Expert Comment

by:Sasa Kranjac
Comment Utility
I omitted to say that I have typed these commands in cmd.exe.

This command in PowerShell lists Microsoft MPIO driver version:

Get-ItemProperty -Path c:\windows\system32\drivers\mpio.sys | Format-List -Property *

To check if module is installed, type:

Get-WindowsOptionalFeature –Online –FeatureName MultiPathIO

If you have another version MPIO solution modify path to list specific drivers properties.
0
 
LVL 6

Expert Comment

by:Sasa Kranjac
Comment Utility
Have you tried yet the PowerShell commands from the last comment?
0
 

Author Comment

by:jmohan0302
Comment Utility
multipath IO has been installed, but none of the MPIO commands in the powershell is working......
0
 
LVL 6

Accepted Solution

by:
Sasa Kranjac earned 500 total points
Comment Utility
Hmm...

Usually the MPIO driver in Windows is mpio.sys. Regardless of the file and its vendor the point is to find the version of the file/driver.

Try this command:

driverquery /S system /U domain\username /P password /FO CSV > driverlist.csv
where system is the remote computer you are querying; domain and username are credentials you use to connect to query the remote computer. If /P password is omitted then you will be asked for password; /FO CSV > directs output to driverlist.csv file in the working folder.

What is even better, PowerShell can do this and a lot more:

driverquery.exe /v /fo csv | ConvertFrom-CSV
will get you a list and properties of installed drivers. To make it more readable and choose what do display (for example) type:

driverquery.exe /v /fo csv | ConvertFrom-CSV | Select-Object "Display Name", "State", "Status", Path
Finally, to find out a version of the file (shell32.dll is used as an example) type either:

(Get-Command c:\windows\system32\shell32.dll).FileVersionInfo
or

[System.Diagnostics.FileVersionInfo]::GetVersionInfo("c:\windows\system32\shell32.dll").FileVersion
I prefer the first one instead of calling .NET class because it has more readable output.
0
 

Author Closing Comment

by:jmohan0302
Comment Utility
thnx
0
 
LVL 6

Expert Comment

by:Sasa Kranjac
Comment Utility
You're welcome!
0

Featured Post

Want to promote your upcoming event?

Are you going to an event? Are you going to be exhibiting at a tradeshow? Talking at a conference? Using a promotional banner in your email signature ensures that your organization’s most important contacts stay in the know and can potentially spread the word about the event.

Join & Write a Comment

Our Group Policy work started with Small Business Server in 2000. Microsoft gave us an excellent OU and GPO model in subsequent SBS editions that utilized WMI filters, OU linking, and VBS scripts. These are some of experiences plus our spending a lo…
Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now