Solved

opensuse 13.1 remote desktop is black

Posted on 2014-01-14
20
3,258 Views
Last Modified: 2014-01-29
I have upgraded from Opensuse 12.3 to Opensuse 13.1. I have a problem with Remote Desktop. when I connect from my home PC all i get is a black screen. it worked great on 12.3,

When I try to see if Vino-server is loaded I get the message "screen sharing is not enabled". I checked and screen sharing is indeed enabled.

i have been reading the documentation and i cannot find any details about the settings. I did find that /etc/xinetd.d/vnc has a line that disables by default the communication. i edited and restarted...that is when i get a black screen.

Any ideas?
0
Comment
Question by:czarubah
  • 9
  • 8
  • 3
20 Comments
 
LVL 21

Expert Comment

by:Mazdajai
Comment Utility
Do you have ipv6 enabled? Try commenting out the ipv6 line in /etc/hosts -

# special IPv6 addresses
#::1             localhost ipv6-localhost ipv6-loopback

Open in new window

0
 

Author Comment

by:czarubah
Comment Utility
Same as before. i did restart xinetd and the Xvnc server. Sorry for the long delay.
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
Do you need to see the screen ot just run graphics programs?
0
 
LVL 21

Expert Comment

by:Mazdajai
Comment Utility
Have you restart networking or the box?
0
 

Author Comment

by:czarubah
Comment Utility
1. I need to see the screens.
2. I have restarted the network and the box.
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
Aparently your video card got good hardware acceleration that GNOME-2 vinoserver does not dig.
Use krfb instead
0
 
LVL 21

Expert Comment

by:Mazdajai
Comment Utility
This seems to be known bug for 13.1.

is it possible for you to roll back to 12.3 and file a bug report?
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
It is more like a simple misconfguration

You need to choose you run vino or xvnc on same port..... Otherwise one will fail and you connect to other.

And you should not call vino-server directly.
0
 

Author Comment

by:czarubah
Comment Utility
1. ok, kill Xvnc, which is the current default. (according to the documentation). Make sure Vino is running and test...but I cannot find where to set up vino-settings? i like vino-server better than Xvnc.
2. I rolled back to 12.3 and re-loaded 13.1...so there really is a bug...i have read a few entries about similar issues as mine, but no solutions.

I am still working on this problem; it is not a high priority as I spend enough time at the workstation, but I need to solve the remote issue for the times when I'm on the road.
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
patching system changes order of program startup
you do not need xvnc for vino to work
also if you kill program are you sure you clean all the remaining resources after?
for example if i start Xvnc i cannot get krfb to do anything, and cak keep hopelessly connecting to black Xvnc....
0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 

Author Comment

by:czarubah
Comment Utility
I'm not used to Xvnc so I will have to check for "remaining resources".
- I thought that I could disable Xvnc by disabling it from the services so it will not start after booting?
Are other resources loaded if Xvnc is not loaded at boot?
I will test tomorrow.
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
you can always uninstall unused system components for performance and security
(or "chkconfig vnc off")
0
 

Author Comment

by:czarubah
Comment Utility
I un-installed Xvnc...checked vino, running and listening on 5900...checked vino-passwd...

still not working. vino-server message "(vino-server:29035): WARNING **: The desktop sharing service is not enabled, so it should not be run."

Can't find anywhere the desktop sharing settings...I have set .AllSettings>Sharing>Screen Sharing> all options on and password... and remote login.

I'm not sure where else to look.
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
Search for options in order:
vino-config (~~~ control panel)
or
dconf-editor (~~~ regedit)
0
 

Author Comment

by:czarubah
Comment Utility
none of the options suggested work...I'm assuming dconf is for desktop configuration. I have tried that. Currently my settings are set for sharing.

I think it is time to abandon this issue and roll back to 12.3. I will need to document all my issues to submit a bug to opensuse.
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
You said it is a known bug...
I cannot find it in novell bugzilla.

Did you enable sharing in vino-config and verified with dconf-editor that it is enabled?

Not yak yak yak i do vino with dconf, please follow exact steps.
0
 

Author Comment

by:czarubah
Comment Utility
I don't know if it is a known bug. I have found several references to the same problem, but no solutions. that is why i started this question.

As stated before, i cannot find vino-config or dconf-editor. my O/s is Openssue13.1. in the past there was vino-preferences...i cannot find that either. i remove vino and reinstalled, assuming that it was just incomplete, But no, i still cannot find anythign but vino-server.
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
I suspect you need to install them
zypper wp vino-config
zypper wp dconf-editor
(I use KDE, and have little knowledge why people stick to gnome)
0
 
LVL 61

Accepted Solution

by:
gheist earned 500 total points
Comment Utility
To submit a bug report you will be directed to novell bugzilla, and there to attachmate login, dont get scared, just get through it. They are friendly once you get there ;) good luck
0
 

Author Closing Comment

by:czarubah
Comment Utility
thanks for the help...although it did not solve the problem, since it seems to be a bug.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
SIP Trunk provider 20 92
Oracle Finace 3 43
SQUD PROXY SERVER, UNIX, SLL/HTTPS 5 45
Help needed with BIND9 DNS on Ubuntu. 22 65
Java performance on Solaris - Managing CPUs There are various resource controls in operating system which directly/indirectly influence the performance of application. one of the most important resource controls is "CPU".   In a multithreaded…
Linux users are sometimes dumbfounded by the severe lack of documentation on a topic. Sometimes, the documentation is copious, but other times, you end up with some obscure "it varies depending on your distribution" over and over when searching for …
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now