Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

opensuse 13.1 remote desktop is black

Posted on 2014-01-14
20
Medium Priority
?
3,510 Views
Last Modified: 2014-01-29
I have upgraded from Opensuse 12.3 to Opensuse 13.1. I have a problem with Remote Desktop. when I connect from my home PC all i get is a black screen. it worked great on 12.3,

When I try to see if Vino-server is loaded I get the message "screen sharing is not enabled". I checked and screen sharing is indeed enabled.

i have been reading the documentation and i cannot find any details about the settings. I did find that /etc/xinetd.d/vnc has a line that disables by default the communication. i edited and restarted...that is when i get a black screen.

Any ideas?
0
Comment
Question by:czarubah
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 8
  • 3
20 Comments
 
LVL 21

Expert Comment

by:Mazdajai
ID: 39780916
Do you have ipv6 enabled? Try commenting out the ipv6 line in /etc/hosts -

# special IPv6 addresses
#::1             localhost ipv6-localhost ipv6-loopback

Open in new window

0
 

Author Comment

by:czarubah
ID: 39786853
Same as before. i did restart xinetd and the Xvnc server. Sorry for the long delay.
0
 
LVL 62

Expert Comment

by:gheist
ID: 39788977
Do you need to see the screen ot just run graphics programs?
0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 
LVL 21

Expert Comment

by:Mazdajai
ID: 39789406
Have you restart networking or the box?
0
 

Author Comment

by:czarubah
ID: 39789447
1. I need to see the screens.
2. I have restarted the network and the box.
0
 
LVL 62

Expert Comment

by:gheist
ID: 39789745
Aparently your video card got good hardware acceleration that GNOME-2 vinoserver does not dig.
Use krfb instead
0
 
LVL 21

Expert Comment

by:Mazdajai
ID: 39789983
This seems to be known bug for 13.1.

is it possible for you to roll back to 12.3 and file a bug report?
0
 
LVL 62

Expert Comment

by:gheist
ID: 39790377
It is more like a simple misconfguration

You need to choose you run vino or xvnc on same port..... Otherwise one will fail and you connect to other.

And you should not call vino-server directly.
0
 

Author Comment

by:czarubah
ID: 39795286
1. ok, kill Xvnc, which is the current default. (according to the documentation). Make sure Vino is running and test...but I cannot find where to set up vino-settings? i like vino-server better than Xvnc.
2. I rolled back to 12.3 and re-loaded 13.1...so there really is a bug...i have read a few entries about similar issues as mine, but no solutions.

I am still working on this problem; it is not a high priority as I spend enough time at the workstation, but I need to solve the remote issue for the times when I'm on the road.
0
 
LVL 62

Expert Comment

by:gheist
ID: 39795454
patching system changes order of program startup
you do not need xvnc for vino to work
also if you kill program are you sure you clean all the remaining resources after?
for example if i start Xvnc i cannot get krfb to do anything, and cak keep hopelessly connecting to black Xvnc....
0
 

Author Comment

by:czarubah
ID: 39795713
I'm not used to Xvnc so I will have to check for "remaining resources".
- I thought that I could disable Xvnc by disabling it from the services so it will not start after booting?
Are other resources loaded if Xvnc is not loaded at boot?
I will test tomorrow.
0
 
LVL 62

Expert Comment

by:gheist
ID: 39796192
you can always uninstall unused system components for performance and security
(or "chkconfig vnc off")
0
 

Author Comment

by:czarubah
ID: 39798612
I un-installed Xvnc...checked vino, running and listening on 5900...checked vino-passwd...

still not working. vino-server message "(vino-server:29035): WARNING **: The desktop sharing service is not enabled, so it should not be run."

Can't find anywhere the desktop sharing settings...I have set .AllSettings>Sharing>Screen Sharing> all options on and password... and remote login.

I'm not sure where else to look.
0
 
LVL 62

Expert Comment

by:gheist
ID: 39799230
Search for options in order:
vino-config (~~~ control panel)
or
dconf-editor (~~~ regedit)
0
 

Author Comment

by:czarubah
ID: 39812560
none of the options suggested work...I'm assuming dconf is for desktop configuration. I have tried that. Currently my settings are set for sharing.

I think it is time to abandon this issue and roll back to 12.3. I will need to document all my issues to submit a bug to opensuse.
0
 
LVL 62

Expert Comment

by:gheist
ID: 39813219
You said it is a known bug...
I cannot find it in novell bugzilla.

Did you enable sharing in vino-config and verified with dconf-editor that it is enabled?

Not yak yak yak i do vino with dconf, please follow exact steps.
0
 

Author Comment

by:czarubah
ID: 39813365
I don't know if it is a known bug. I have found several references to the same problem, but no solutions. that is why i started this question.

As stated before, i cannot find vino-config or dconf-editor. my O/s is Openssue13.1. in the past there was vino-preferences...i cannot find that either. i remove vino and reinstalled, assuming that it was just incomplete, But no, i still cannot find anythign but vino-server.
0
 
LVL 62

Expert Comment

by:gheist
ID: 39814922
I suspect you need to install them
zypper wp vino-config
zypper wp dconf-editor
(I use KDE, and have little knowledge why people stick to gnome)
0
 
LVL 62

Accepted Solution

by:
gheist earned 2000 total points
ID: 39814926
To submit a bug report you will be directed to novell bugzilla, and there to attachmate login, dont get scared, just get through it. They are friendly once you get there ;) good luck
0
 

Author Closing Comment

by:czarubah
ID: 39818177
thanks for the help...although it did not solve the problem, since it seems to be a bug.
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Fine Tune your automatic Updates for Ubuntu / Debian
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Suggested Courses

604 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question