New messages won't mark as read after reading until changing folders and unread message count incorrect.

I have a terminal server with about 30 users.  1 user has reported this issue and I have not been able to reproduce this with another user but admit I have not created a new account and all users currently have profiles.  This user also had a profile for a long time too however.

Office 2010 Pro is installed and the users inbox messages do not unbold after opening or previewing and clicking off.  They stay flagged as unread.  If user clicks another folder and goes back then the view is corrected.  The unread message count on the inbox also gets skewed during this.

I have deleted the windows profile multiple times verifying that the folders are deleted. I have tried a local only profile as well as a roaming profile.  Cached exchange mode is OFF.  The issue returns immediately after outlook profile is created.  I can however run a variety of switches like /resetfolders /cleanviews /cleanrules etc and the problem goes away... for a few hours and then it starts back up again.  I want to try and narrow this down more to find which of these switches is helping temporarily.

This issue makes no sense to me.  I am still looking for a pattern but this has me stumped.  I want to blame it on something the user is doing but the issue presents itself immediately after creating a new windows and outlook profile when I know I cleaned the profile folders thoroughly.
Who is Participating?
NBFConnect With a Mentor Author Commented:
Ok we narrowed this down.  The behavior only occurs when the user sorts his inbox by category.  If sorted by date it functions fine.   I think this was due to a recent microsoft patch and is only appear with this user because of the unique way his sorts his mailbox.  Be on the lookout for this as I don't believe it is acknowledged by microsoft yet.
Test in Outlook Safe Mode if the problem still occurs and post the results

1. Click Start | Run.
2. In the Open box, type: "Outlook /safe" (without the quotation marks)
Notes: There is a space character between Outlook and the forward slash (/).
3. Click OK.

The above will tell us if an Outlook add-in is causing the problem

Also, how many emails do you have in the Inbox?
Did you select the option to show the unread email count or the total email count?

Right click on Inbox > click on Properties > in the General tab, check which option is selected.

If that does not help, create a new folder in the web-mail and move all the e-mails from Inbox to the new folder, and check if the issue still persists in Outlook. This is to check if any damaged or corrupt emails on the server is causing the issue.
NBFAuthor Commented:
We don't run any plugins other than the very basic default ones to hook to exchange.  Everything else is disabled.
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

NBFAuthor Commented:
Found cause but not solution.  MS bug.
I have the same exact problem with an end user using Outlook 2010.  I am sorting by "received" and the problem still persists.

We are using Outlook 2010 on a Win 7 workstation connected to Exchange 2010.  We are not using exchange cached mode or any .pst/.ost files.

I can reproduce this on any workstation by sorting Outlook by the categories column and then clicking on an unread message.  It will not mark as read until you click a sub folder and then return to the inbox.

Has anybody found a solution to this issue yet?


Ran into this today, anybody find a solution?
Francesco FinucciCommented:
Same problem as of October 2016. Using Outlook online :/
Joe ShaverCommented:
"Ok we narrowed this down.  The behavior only occurs when the user sorts his inbox by category. "

This isn't true. The problem persists regardless of how the inbox is sorted.
Joe ShaverCommented:
We just fixed this issue (Outlook 2016, various versions) by disabling the TeamViewer Outlook add-in.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.