Cannot download files from secure sites using IE

One of my users has run into an issue when she has to download files from any secure website (https).  When she tried to download the file she gets an error message that "file cannot be downloaded."  This happens regardless of the file type (pdf, doc, txt, etc...)  She can download files from non-secure websites (oh joy).

Steps I've taken troubleshooting

1. Reset IE
2. Ensure that "Do not save encrypted pages to disk check box." was unchecked in IE options.
3. Created registry key BypassSSLNoCacheCheck with value of 1 under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

Still no go.  Very frustrating for me and her.

Any other suggestions other than another browser since some of these sites will only work with IE?

Thanks!
LVL 2
jmerullaAsked:
Who is Participating?
 
Mahesh BhutkarConnect With a Mentor Commented:
Please send complete exception along with screenshot for better clarity.
0
 
Dave BaldwinFixer of ProblemsCommented:
Turn off In-Private Browsing.
0
 
jmerullaAuthor Commented:
Hi Dave,

InPrivate browsing is not turned on.  Switching between Protected mode and non-Protected mode also did not help.  Thanks for the suggestion!
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
Mahesh BhutkarCommented:
Checkout 'Security' setting inside your Tools -> Internet Options -> Advanced.

You can even add the site as a TRUSTED site inside your Tools -> Internet Options -> Security Tab -> Click on Trusted Sites

For downloading it may expecting to set up SSL certificate inside your browser setting at  Tools -> Internet Options -> Content Tab
0
 
jmerullaAuthor Commented:
It happens with all secure sites even if I individually add them to the Trusted Sites.  Even with Outlook Web Apps.
0
 
BillDLCommented:
Just curious, is there any difference in results if the user Right-Clicks on a link and chooses either of the following options rather than just Left-clicking a link?:
1. "Open In New Tab"
2. "Save Target As"
0
 
Mahesh BhutkarCommented:
Check your IE -> Tools -> Internet Options -> Advanced Tab
 Select Checkbox Use SSL 1.0, 2.0, 3.0
0
 
jmerullaAuthor Commented:
Hi bonzermahesh,

SSL 1.0 and 3.0 were checked off but 2.0 was not.  All 3 have been checked and still no dice...
0
 
Mahesh BhutkarCommented:
After doing the changes are you restarting IE browser?
0
 
jmerullaAuthor Commented:
Yes I've restarted IE as well as the computer and still no luck :-/
0
 
jmerullaAuthor Commented:
Could not get it work under another profile either.  Reformatted computer.
0
 
jmerullaAuthor Commented:
Reformatted computer as it did not work under another profile which means it was something that would affect any user on that machine and the IE reset under the affected user's profile did not fix the issue.
0
All Courses

From novice to tech pro — start learning today.