Solved

DKIM not working, getting error in mail log

Posted on 2014-01-15
3
591 Views
Last Modified: 2014-01-21
I'm having some trouble configuring opendkim on my linux server (Ubuntu 13.10).

It looks like DKIM is not passing to postfix via an error I'm getting in the log.  Is there a fix for this or do I need to restart with 12.04 LTS because of the backport issue?

Here are the logs:
Jan 15 15:41:14 localhostname postfix/smtpd[6845]: connect from localhost[127.0.0.1]
Jan 15 15:41:14 localhostname postfix/smtpd[6845]: warning: milter inet:localhost:8891: bad protocol information: #(
Jan 15 15:41:14 localhostname postfix/smtpd[6845]: warning: milter inet:localhost:8892: bad protocol information: #(
Jan 15 15:41:48 localhostname postfix/smtpd[6845]: disconnect from localhost[127.0.0.1]
Jan 15 15:52:44 localhostname postfix/pickup[6057]: 552FF128073D: uid=0 from=<arch@mydomain.com>
Jan 15 15:52:44 localhostname postfix/cleanup[7035]: warning: milter inet:localhost:8891: bad protocol information: #(
Jan 15 15:52:44 localhostname postfix/cleanup[7035]: warning: milter inet:localhost:8892: bad protocol information: #(
Jan 15 15:52:44 localhostname postfix/cleanup[7035]: 552FF128073D: message-id=<1389826364.7010@mydomain.com>
Jan 15 15:52:44 localhostname postfix/qmgr[3878]: 552FF128073D: from=<arch@mydomain.com>, size=409, nrcpt=1 (queue active)
Jan 15 15:52:45 localhostname postfix/smtp[7037]: 552FF128073D: to=<GS0HuFWY5H@www.brandonchecketts.com>, relay=www.brandonchecketts.com[66.135.56.251]:25, delay=0.95, delays=0.07/0/0.77/0.11, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 0B05553300A0)
0
Comment
Question by:gwarcher
  • 2
3 Comments
 
LVL 13

Expert Comment

by:Sandy
ID: 39784879
DKIM milter is not visible to postfix hence it is throwing messages. Please check the DKIM config and check port 8191 from netstat...

Then you have to configure the same in postfix

TY/SA
0
 

Author Comment

by:gwarcher
ID: 39785973
Do you think that is a problem with config or a problem with the backports not working correctly in 13.10 (I saw there was an issue wtih 12.04 and having to download precise-backports with openDKIM, there was no corresponding file for saucy).

Thanks for the help.
0
 
LVL 13

Accepted Solution

by:
Sandy earned 500 total points
ID: 39788102
To me it seems config error.
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Import PST to Exchange using Power Shell new-mailboximportrequest command, you can simply import the PST file into Exchange mailbox or archived. To know How to import PST into Exchange  2013 read the complete article.
Workplace bullying has increased with the use of email and social media. Retain evidence of this with email archiving to protect your employees.
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

25 Experts available now in Live!

Get 1:1 Help Now