Solved

Move VM on Hyper-V 2012 Server Core

Posted on 2014-01-16
6
3,936 Views
Last Modified: 2014-11-12
Hi,

I am  trying to move one virtual machine to other location.

Through the Move wizard, I choose 'Move the virtual machine's storage' -> 'move all of the virtual machine's data to a single location'  -> Choose Destination -> Finish

but I am getting error saying that:

"Storage migration for virtual machine is failed. Operation not allowed because the replication state is not initialized.

Storage migration for virtual machine failed with error 'The device is not ready'. (0x80070015).

Operation not allowed for virtual machine because Hyper-V state is yet to be initialized from the virtual machine configuration. Try again in a few minutes."

Please advise me to fix this issue.

Thank you!
0
Comment
Question by:computit
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 58

Expert Comment

by:Cliff Galiher
ID: 39784966
Since you are running core, i'm guessing you are trying the move remotely. That requires setting up constrained delegation with Kerberos. Make sure you follow all of the steps here including the Kerberos steps, NOT the CredSSP steps.

http://technet.microsoft.com/en-us/library/jj134199.aspx
0
 
LVL 14

Expert Comment

by:Shabarinath Ramadasan
ID: 39817387
0
 

Expert Comment

by:i486dx266
ID: 39861394
I'm having the same issue. Any solution here? Btw, im using smb-multichannel to the remote storage.
0
Space-Age Communications Transitions to DevOps

ViaSat, a global provider of satellite and wireless communications, securely connects businesses, governments, and organizations to the Internet. Learn how ViaSat’s Network Solutions Engineer, drove the transition from a traditional network support to a DevOps-centric model.

 

Accepted Solution

by:
computit earned 0 total points
ID: 39875769
I just waited for 2 days and somehow, it worked again. very strange though..
0
 

Expert Comment

by:i486dx266
ID: 39876044
Btw, i did a complete shutdown of the hosts and storage, then powered back on. Problem solved. For me this happened after loosing DNS resolution to my storage box. Always make sure to have at least one physical DC on the LAN.
0
 

Author Closing Comment

by:computit
ID: 39885081
It's not a real solution.
0

Featured Post

Edgartown IT Case Study

Learn about Edgartown's quest to ensure the safety and security of the entire town's employee and citizen data. Read the case study!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Sometimes drives fill up and we don't know why.  If you don't understand the best way to use the tools available, you may end up being stumped as to why your drive says it's not full when you have no space left!  Here's how you can find out...
The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
In this Micro Tutorial viewers will learn how they can get their files copied out from their unbootable system without need to use recovery services. As an example non-bootable Windows 2012R2 installation is used which has boot problems.
This tutorial will walk an individual through the process of installing of Data Protection Manager on a server running Windows Server 2012 R2, including the prerequisites. Microsoft .Net 3.5 is required. To install this feature, go to Server Manager…

732 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question