Filemaker script send mail ATT00001.bin attached

Hello
I created a script on filemaker that define a variable $NomFichier with the path where I want to save an .xlsx export
Then I export the record to $NomFichier.
The file is OK and the size is 18ko
Then I send a mail with attached $NomFichier
But on my exchange server I receive the attached file with the name ATT00001.bin (the size is 18ko)
How could I get my original file name in the attachment of the mail ? and with the correct extension
Tanks
mdmmpAsked:
Who is Participating?
 
slinkygnConnect With a Mentor PresidentCommented:
Is there any text in the email, or just the attachment?

If there is no text, you may want to add some, that is likely to be an issue -- this is a known issue with MS Exchange, not actually a FileMaker issue.

http://kb.mit.edu/confluence/pages/viewpage.action?pageId=4981187
0
 
Will LovingPresidentCommented:
I don't have any expert knowledge about Exchange, but this sounds like something that the Exchange Server is doing to the attachment rather than something that is happening in FileMaker. To confirm this, try using a different SMTP server such the one for gmail or yahoo if you have accounts for those.
0
 
Peter LoobuyckCommented:
If not, try sending through an email client. It is something the exchange server does in combination with filemaker. Just letting your mail client send the mail may solve it.
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
mdmmpAuthor Commented:
Tanks but it's a server script, so it can't open a mail client.

This is a smtp relay that relay to our exchange online server.
0
 
Peter LoobuyckCommented:
OK, can you paste the fm script here?
0
 
Will LovingPresidentCommented:
Well, as I said, for testing purposes try changing the SMTP server setting to not relay and to use another server to see if you get the same results. I'm also wondering if it's the relay that's causing the issue but I'm guessing it's the Exchange server.
0
 
Peter LoobuyckCommented:
You can also check the exchange configuration:

Organisation Configuration > Hub Transport > Remote Domains > right click the object Default > click on Properties
screenshotMake sure that “Never use” is selected under Exchange rich-text format.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.