Solved

Cisco 2960 switch  -  switchport access vlan

Posted on 2014-01-16
3
1,432 Views
Last Modified: 2014-01-17
Hi there,
My Cisco 2960 switch (PORT 48 ) is connected to my router cisco 2911. My Cisco 2960 switch has the following line 'switchport access vlan 801 on each and every interface; like:

interface GigabitEthernet0/43
 switchport access vlan 801
 no cdp enable
!
interface GigabitEthernet0/44
 description source port
 switchport access vlan 801
 no cdp enable
!
interface GigabitEthernet0/45
 switchport access vlan 801
 no cdp enable
!
interface GigabitEthernet0/46
 switchport access vlan 801
 no cdp enable
!
interface GigabitEthernet0/47
 description SessnMntrPort48
 switchport access vlan 801
 speed 1000
 duplex full
 no cdp enable
!
interface GigabitEthernet0/48
 description source port
 switchport access vlan 801
 speed 1000
 duplex full
 no cdp enable

Do I need this line 'switchport access vlan 801' on each and every interface except port 48?   Need to understand.  Will it cause vlan loop issues? (not sure) .Help is appreciated
0
Comment
Question by:amanzoor
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 6

Accepted Solution

by:
Jordan Medlen earned 300 total points
ID: 39786257
You will want to have this VLAN on each port that connects to a device that must communicate with other devices in this same VLAN/subnet. If port 48 is your uplink to your router, then I would recommend configuring port 48 as a trunk, and configure a sub-interface for VLAN 801 on your router. This way, as you need to add other subnets/network segments, you can do so and control traffic between VLANs at your router.
0
 
LVL 12

Assisted Solution

by:Infamus
Infamus earned 100 total points
ID: 39786265
can you do "sh vlan" and also sh run int vlan 801 the post?

It looks like you are using vlan 801 as your default vlan so the statement has to be there.

Since port 48 is an access port need the same statement as well.
0
 
LVL 26

Assisted Solution

by:Soulja
Soulja earned 100 total points
ID: 39788585
If vlan 801 is your only vlan, than you should be fine. No trunk is needed to the router if the router's inside interface is on the same subnet.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
How to set-up an On Demand, IPSec, Site to SIte, VPN from a Draytek Vigor Router to a Cyberoam UTM Appliance. A concise guide to the settings required on both devices
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

756 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question