• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 343
  • Last Modified:

Screen saver with password protection not kicking in


We are running a few Terminal Servers - 2 Windows 2003 Terminal Servers, and 2 Windows 2008R2 Terminal Servers.

In Control Panel, I've set the screen saver to kick in after 15 minutes of idle time, and to prompt for password in order to log back in to the desktop.  I have noticed however when I've tested from client workstations that the screen saver is not kicking in.  

Does this need to be set from a different location for client users' desktops in the Terminal Server?  Alternately is there a group policy that should or can be set to force this?

What am I missing?

Thanks in advance.


1 Solution
Patrick BogersDatacenter platform engineer LindowsCommented:

I would configure a GPO in

User configuration->Administrative Templates->Control Panel->Personalisation

Password protect the screen saver
Screen Saver timeout  900 seconds
realtimerAuthor Commented:
Thanks - I do see this option for Windows 2008.  Where is the similar setting for Windows 2003 - I don't see it there.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now