[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

How to disable the Adobe Reader Check Out & Open Message in SharePoint?

Posted on 2014-01-16
14
Medium Priority
?
11,849 Views
Last Modified: 2014-01-20
Hello,

I have a SharePoint 2013 site and uses are opening PDF files.  They get a:

You are about to open ... Check Out & Open, Open, Cancel

Message.  How can I prevent this from being displayed.  Users just want to open the PDF file and not see this message.
0
Comment
Question by:PBIT
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 3
  • 2
  • +1
14 Comments
 
LVL 50
ID: 39786556
Hello,

you need to add the mime type for PDF to the web application. That can be done with Powershell.

A very detailed description and the required Powershell statements are in this Microsoft Technet article:  SharePoint: Browser File Handling Deep Dive

cheers, teylyn
0
 
LVL 29

Expert Comment

by:QPR
ID: 39786646
Not sure this is right teylyn - but I wish it were because we have the same issue and wish I knew of a cure so happy to be proved wrong!

PDF is fully trusted and all operations work as normal but the adobe reader (not sharepoint) now has a "feature" whereby if a pdf is opened from a sharepoint library it offers the user the option to check the document out of the library prior to opening.
If the user takes the time to read the dialogue they will select "open" and all is well.
Unfortunately that is not always the case and often they will click "check out and open" which displays the doc they read it and then move on thinking all is well.
Unfortunately this means that the document remains checked out behind.
Not a massive issue as normally PDF documents are the finished article and don't require editing... others can still read the pdf if checked out.
But it looks confusing to users and reports on checked out files (records management purposes) will paint a false picture
0
 

Author Comment

by:PBIT
ID: 39786651
Do you have steps in Central Admin on the SharePoint server?
0
Fill in the form and get your FREE NFR key NOW!

Veeam® is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

 
LVL 29

Expert Comment

by:QPR
ID: 39786655
I've googled this for my own needs prior and the only solution I could get (from adobe's own support) was to uninstall adobe reader, install an older version and block any future updates.
Hopefully someone, sometime will create an update that allows this option to be toggled as an option or in the registry
0
 
LVL 20

Expert Comment

by:Walter Curtis
ID: 39786956
Here is another possibility - from central admin, go to the Web Application management level.

From there, go to General settings in the ribbon, then general settings again.  from that dialog scroll down to "Browser File Handling" and read very carefully the description because it has security implications. The setting to have files open in the browser is "Permissive". I have never had any problems setting it to permissive, but I can't speak to every security situation there is out there. Once set to permissive, PDF's should open in the browser with no prompts.

Hope that helps,
0
 
LVL 29

Expert Comment

by:QPR
ID: 39787090
The changing from strict to permissive is the way to allow opening of PDF and other file types, yes.

But the original poster is specifically trying to get rid of the annoying splash screen which gives the user the option to check out a file before athe document is opened.
This is an adobe acrobat thing not a sharepoint thing and interacts directly with the libraries check out document function.

A (fairly) new and very irritating "feature" from Adobe.
0
 
LVL 29

Accepted Solution

by:
QPR earned 2000 total points
ID: 39787094
I've googled again (last time I looked into this was mid 2013) and have found this adobe article.

I'm about to try it myself.
I really hope it removes this feature. Will report back

http://www.adobe.com/devnet-docs/acrobatetk/tools/PrefRef/Windows/FeatureLockdown.html?zoom_highlight=disable+sharepoint+integration#idkeyname_1_6704
0
 
LVL 20

Expert Comment

by:Walter Curtis
ID: 39787104
Thanks for the clarification.
0
 
LVL 29

Expert Comment

by:QPR
ID: 39787141
Well I have acrobat reader v11 on my client and v9.5 on the server (I have tried to run an update on the server but it says 9.5 is the latest... must be due to windows server not client OS)

The reg key mentioned in the adobe article says it applies to v10.0 or higher.
So I went (on my client) to the registry and looked at the default key. It was already set to 0.
I created a new DWORD and gave it the name mentioned in the article, set it's value to decimal 0 and rebooted.

Went to a pdf in a sharepoint library, clicked to open it and the checkout option still came up :(
0
 
LVL 29

Assisted Solution

by:QPR
QPR earned 2000 total points
ID: 39787204
Eureka!!
The adobe forum mistakenly say to set the value to 0.
This site says to set it to 1
I did and it works!!!!
http://community.spiceworks.com/how_to/show/2414-disabling-sharepoint-integration-in-adobe-acrobat-and-reader-x-version-10-1

Now to give the network admins the good news that he needs to roll this out to 250 clients :)
1
 
LVL 50
ID: 39787637
J, you rock!

That will come in useful.
0
 

Author Comment

by:PBIT
ID: 39788922
Thanks, but do I have to do this for every client?  Is this a server side setting?  Seems like a client setting,
0
 
LVL 29

Expert Comment

by:QPR
ID: 39789229
I'm afraid it's a client side settings. It's an adobe thing (not SharePoint) and Adobe lives on the client.
If you are in a networked environment you can roll out the reg entry via group policy or logon scripts or similar
0
 

Author Closing Comment

by:PBIT
ID: 39794782
I set the registry key setting and that work.

I did the Permissive setting in Central Admin and that did not work.  This is for SharePoint 2013 and Adobe Reader/Acrobat 11.  However, I have SharePoint 2010 sites and I have that same setting and it seem to work there.
0

Featured Post

Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Summary In SharePoint 2010 it is easy to create custom color themes to jazz up a site. Theme colors can also be created in PowerPoint 2010 with a few clicks. But how do the chosen colors actually look in the SharePoint site? The attached PowerPoint…
I thought I'd write this up for anyone who has a request to create an anonymous whistle-blower-type submission form created using SharePoint 2010 (this would probably work the same for 2013). It's not 100% fool-proof but it's as close as you can get…
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…
In this video, Percona Solution Engineer Dimitri Vanoverbeke discusses why you want to use at least three nodes in a database cluster. To discuss how Percona Consulting can help with your design and architecture needs for your database and infras…

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question