Intel Network Adapter connectivity problem

Since I updated my NIC Intel drivers to support the latest Dell Lalitude, we have problems with autonegotiation and connectivity.

For compatibility reason, all our Dell switched ports are force to be 100 MB/Full Duplex.

With the latest PROWIN64 driver installed on the laptop without the PROSET installed:

- The driver set to 100MB/Full duplex and switch port set 100 FD = the real speed duplex is 100 MB/Half-Duplex
- The driver set to auto duplex and switch port set to auto = 100MB/Full Duplex

We can't set all the ports to autonegotiation because we have IP phone connected to the network.

I tried an older version of the driver. The negotiation is working fine, but when I shutdown the computer and turn on the computer again, the network card doesn't see any connection until I pull out the wire and put it back.

I could not find any solution for those 2 problems.

Thanks for helping.
LVL 1
Stephan BourgeoisIT SpecialistAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Stephan BourgeoisConnect With a Mentor IT SpecialistAuthor Commented:
The solution is to install the latest driver version and change a registry key


[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\0007]
"LinkNegotiationProcess"="2"
0
 
InfamusCommented:
You should always configure each ends the same.

If you set one end to auto and the other to manual speed/duplex, then you will run into some issues soon or later.
0
 
remmett70Commented:
How does the new driver work when set to autonegotiation while the switch is left set at 100 Full?
0
Building an Effective Phishing Protection Program

Join Director of Product Management Todd OBoyle on April 26th as he covers the key elements of a phishing protection program. Whether you’re an old hat at phishing education or considering starting a program -- we'll discuss critical components that should be in any program.

 
Stephan BourgeoisIT SpecialistAuthor Commented:
Both end are always the same setting.

With the latest version PROWIN64 18.7
When both end are set to 100FD, the real connection is 100HD and copying files on the network is extremely slow.

I did not tried the pc autonegotiation with the switch left to 100FD. When both end are autonegotiation, it seems to work fine, but this is not an option for us since the IP phone are set to 100FD
0
 
InfamusCommented:
Are the PCs connected to IP phone (daisy chained)?

If not you can make all the ports that are connected by PCs and make them auto/auto on both sides.

Would this be an option or no?
0
 
Stephan BourgeoisIT SpecialistAuthor Commented:
Yes, they are daisy chain and the IP phone is set by script to 100FD.

I am just currious to know why suddenly, after updating the cabs on my deployement server to support new Dell PC, the NIC card just start to behave like that.

Is there a version of the PROWIN64 that support I217-LM prior version 18.4 somewhere?

I would be curious to try an older version of the driver since before the import of the latest cabs, everything was working fine.
0
 
InfamusCommented:
So basically the link between the phone and the PC is not working properly.

In this case you can change PC to auto and see what happens.

There might be an option in advance property that is causing this but I'm not sure.
0
 
Raymond PengSystems EngineerCommented:
I've seen issues with the Latitude E40 and E420s.  The built in NIC can't handle full duplex on Gigabit switches.  Not sure what model you're running.

Our workaround was to install a PnP USB Nic adapter instead.  From the sound of it, it's more of a hardware issue.
0
 
Stephan BourgeoisIT SpecialistAuthor Commented:
We are experiencing the same problem even when we bypass the phone, connected directly to the wall.

It is not an hardware problem, because we are not experiencing the same problem depending of the driver version installed.

Older versions are connecting at the right speed, but after a restart the wire status remain not connected until the wire is pull out/pull in.

Even older hardware reimage are experiencing the same behaviors.
0
 
InfamusCommented:
Is there a reason that you need this new driver? If not I would uninstall and use the older driver that was working.
0
 
Stephan BourgeoisIT SpecialistAuthor Commented:
Actually, the I217-LM NIC card is a new hardware and there is no older version off the driver. The 100MB full duplex with fix setting on the switch and the NIC do not work.

For older hardware models, the latest version of the Intel driver works fine.

I also ask the question on the Intel community: https://communities.intel.com/message/220768
0
 
Stephan BourgeoisIT SpecialistAuthor Commented:
I found the solution
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.