Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 11256
  • Last Modified:

UEFI PXE Boot SCCM 2012 R2 + Server 2012 DHCP Boot Options

HI,
I have a problem with SCCM 2012 R2 server. Server 2012 R2
UEFI PXE boot is not working.

I am not sure what to specify in Option 67
DHCP Option 67 :  \smsboot\x64\wdsnbp.com

i have also tried \smsboot\x64\wdsmgfw.efi

but neither options are working for UEFI.

\smsboot\x64\wdsnbp.com Works if I switch the client BIOS to BIOS (Not UEFI) Non uEFI clients are working. able the receive the boot file.

I have also got Option 60 = PXEClient
Otpion 66 : ipaddress of SCCM server
0
mspsupport
Asked:
mspsupport
  • 3
  • 3
1 Solution
 
Netman66Commented:
Try to remove the PXE role from SCCM.  Wait for 20 minutes and add it back.

What switches are you using for the infrastructure?
Are you using vLans?
Are your WDS and DHCP servers on the same subnet?

If using iphelpers to DHCP and bootp relay to WDS, then you don't need to provide any DHCP options to clients.  Using a combination of iphelper and DHCP options is sure to cause havoc.

The client booting will select the correct bootfile (or it should anyway).
0
 
mspsupportAuthor Commented:
Using HP Switches.
No vlans Client and WDS/SCCM and DHCP server are in the same Vlan.
Client is a Vmware esxi VM
SCCM/WDS is a VMware esxi VM
DHCP/DC is a Vmware Esxi VM

I don't thing there are and Ip-helper address on the switches.

What is the recommended best practice ?

This setup should work as Client and Server are in the same Vlan/Broadcast domain.
but when the client trys to boot it gets PXE-E21.
I will try to remove PXE role from SCCM and wait 20 mins and add it back
0
 
Netman66Commented:
You would be right, everything on ESXi - are they on the same vSwitches?  Same Hosts?


I can't say I've seen a scenario where all the servers and clients are in VMs, but I would think it will become more common now.

I would try option 60 and 66, but leave out 67 for now - if correct, the client should pick it's own bootfile.

Let me know how the PXE role repair works out.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
mspsupportAuthor Commented:
PXE role repair did nothing...

I also removed option 67 to test . Still nothing
I am getting PXE-E21 still..

nothing in the PXE log either.
0
 
Netman66Commented:
Is there any option on your HP switches for something similar to portfast in Cisco?
0
 
vivigattCommented:
If this works with BIOS and not UEFI this is not a PXE problem!I would say that yiu have to update the UEFI firmware. In your case this means updating ESXi.
Report the issue to vmware...
 As far I know there is no real PXE implementation in UEFI, it works in BIOS emulation mode.
Regarding the options, you should never specify dhcp 66 nor 67 if a real pxe server is there. Only 60 has to be specified and only if dhcp and pxe services run on the same host.
The pxe service will select with nbp name to send ( 64 or 32 bits) in your case . if you specify it manually, you can't have mixed architectures on the same pxe server, specifying option 66 is not a good thing either, since thias could very well prevent the client from getting the nbp name from the pxe server.
0
 
mspsupportAuthor Commented:
THATS IT!!!!
Solution was to completely remove Option 60,66,67 and It started working.
Now i just need to setup ip-helpers.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now