Solved

OSPF Redistribution

Posted on 2014-01-17
4
302 Views
Last Modified: 2014-01-17
How do I get a route to redistribute into OSPF 100 from OSPF 1?  And how to I create a route-map?
0
Comment
Question by:Evolutionzz
  • 2
  • 2
4 Comments
 
LVL 26

Expert Comment

by:Soulja
ID: 39789491
On the ASBR that has both OSPF processes

conf t

router ospf 100
redistribute ospf 1 subnets

router ospf 1
redistribute ospf 100 subnets


For the route-map


access-list 1 permit x.x.x.x 0.0.0.x

route-map Filter permit 10
match ip address 1     ***matches the network or host you put in the above ACL.

You can add this to the redistribute to determine what you want to filter.


Example:

router ospf 100
redistribute ospf 1 subnets router-map Filter
0
 

Author Comment

by:Evolutionzz
ID: 39789674
how can I set up the access list using extended access list?
0
 

Author Comment

by:Evolutionzz
ID: 39789677
this is what I had.  Where's the mistake?

router ospf 100
 redistribute ospf 1 subnets route-map ospf1-to-ospf100
^Z
wr mem

conf t
route-map ospf1-to-ospf100
route-map ospf1-to-ospf100 permit    (not sure what goes here)

WA2-DATA-CORE-1#
conf t
ip access-list extended ospf1-to-ospf100
permit ip 10.0.0.0 0.255.255.255 any
permit ip 172.16.24.0 0.0.7.255 any                          
permit ip 172.16.128.0 0.0.7.255 any
deny ip any any
0
 
LVL 26

Accepted Solution

by:
Soulja earned 500 total points
ID: 39789702
route-map ospf1-to-ospf100
route-map ospf1-to-ospf100 permit    (not sure what goes here)

should be

route-map ospf1-to-ospf100 permit 10
match ip address ospf1-to-ospf100

I believe your acl needs to be a standard acl not extended.
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hello , This is a short article on how would you go about enabling traceoptions on a Juniper router . Traceoptions are similar to Cisco debug commands but these traceoptions are implemented in Juniper networks router . The following demonstr…
The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

829 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question