Solved

Certain HTTPS sites will not load - no errors - company wide

Posted on 2014-01-17
5
324 Views
Last Modified: 2014-01-22
Environment:
Servers: Windows 2008 R2 Enterprise, Hyper-V, one virtual machine is office domain controller, another slice is Exchange.

Back Story:
On Monday, on of our techs performed a driver update on the Hyper-V's NICs.  Starting then, mail would not flow inbound.  About the same time (not entirely sure), IE stopped working properly.  Tuesday evening, we found that, if we modified the MTU on the network to 1464, we could get mail flowing.  The change was made on the firewall, not the server.

Wed/Thu: IE was working except for some HTTPS sites (ex: https://orders.dominos.com).  Others worked fine (https://secure.experts-exchange.com).  Lots of stuff was done to fix this - including replacing the firewall - EXCEPT removing the updated NIC driver.

Friday:  Still happening on all systems on the network (not just the servers).

Does anyone have a clue?  Could it be the NIC driver on the Hyper-V?  How would that cause other workstations to fail?  I am going to look into removing the driver update but I am not yet convinced it is the problem (not this one anyway).

The NIC is an HP NC382i and the driver is 7.8.21.0.

Help?
0
Comment
Question by:crapshooter
  • 3
  • 2
5 Comments
 

Author Comment

by:crapshooter
ID: 39789733
FYI: I just rolled back to the previous driver.  No change in behavior.
0
 
LVL 45

Accepted Solution

by:
Craig Beck earned 500 total points
ID: 39790421
Can you try setting the MTU back to 1500 on the firewall, then see what you get when you use the following command on the mail server...

ping www.google.com -f -l 1472
0
 

Author Comment

by:crapshooter
ID: 39791315
OK, it seems to have worked.  Still waiting for confirmation from the client.  Why did you choose that specific packet size?
0
 
LVL 45

Expert Comment

by:Craig Beck
ID: 39791330
1472 is the maximum packet size which will pass through a standard Ethernet port (before overheads are applied)

If you can pass a packet with a size of 1472 bytes at the ping command it will tell you that MTU is fine across the network.

Now that you've set the MTU back to 1500 are you still seeing the problem?
0
 

Author Comment

by:crapshooter
ID: 39795317
Nope.  At 1500, all is well.  I wonder if the systems were trying to send SSL packets that were larger than what the firewall would handle and the firewall dropped them.  Still, it only happened for some SSL sites.  And it was consistent across all systems on the network.  So it is still pretty weird.
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

To effectively work with Diskpart on a Server Core, it is necessary to write some small batch script's, because you can't execute diskpart in a remote powershell session. To get startet, place the Diskpart batch script's into a share on your loca…
The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
This tutorial will give a an overview on how to deploy remote agents in Backup Exec 2012 to new servers. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as connecting to a remote Back…
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now