Exchange 2010 Cannot Receive Large Emails

Hello,

I am having issues receiving emails from the Internet larger than 15-20MB even though I have a 50MB limit set on Exchange 2010.  So far I have configured the following with a 50MB limit:

Get-TransportConfig | ft name, MaxSendSize, MaxReceiveSize
Get-ReceiveConnector | ft name, MaxMessageSize
Get-SendConnector | ft name, MaxMessageSize

but when I try to send an email with only 20MB in size I will receive the following NDR error:

#554 5.2.0 STOREDRV.Deliver.Exception:MessageSubmissionExceededException.MapiExceptionMaxSubmissionExceeded; Failed to process message due to a permanent exception with message Cannot complete delivery-time processing. 16.55847:92260000, 17.43559:00000000A6020000000000000B00000000000000, 255.23226:00000000, 255.27962:0A000000, 255.27962:0E000000, 255.27962:0A000000, 255.27962:9E000000, 255.17082:DA040000, 0.18273:00000000, 4.21921:DA040000, 255.27962:FA000000, 255.1494:43000000, 255.1238:13800000, 6.8660:0F010480020151000B000658, 0.18658:0F010480, 6.11956:0F010480020151000F010480, 6.15604:0F010480020151000B001F0E, 6.21970:0F010480B084EC810F010480, 6.21970:0F010480B08485810F010480, 6.21970:0F010480B0841F81B0846680, 6.21970:0F010480020113100F010480, 1.64319:003C0000, 1.39743:78520000, 4.45016:DA040000, 0.57304:0F010480, 4.5041:DA040000, 4.4465:DA040000, 4.6833:DA040000, 0.50217:40001900, 4.5093:DA040000, 4.5318:DA040000, 4.10104:DA040000, 0.57449:0F010480, 4.6025:05000780, 4.5257:05000780, 4.4606:DA040000, 255.1750:00000000, 0.26849:00000000, 255.21817:DA040000 ##

Why would it be failing even though there is a 50MB limit set on everything?  This error almost seems more like a timeout rather than a message size limit issue.  Is there a receive timeout setting in Exchange 2010 that should also be changed?  I am at a loss with this right now.

Any help is appreciated.
ColumbiaMarketingAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Patrick BogersConnect With a Mentor Datacenter platform engineer LindowsCommented:
Hi

There are more options to specify this

a) Organization Config-> Hub Transport -> transport settings
b) Organization Config-> Hub Transport -> SendConnector (can be multiple General Max Message
c) Server Config -> Hub transport -> Client connectors
50MB would look like 50240 KB

Just find out where the 20MB limit is left forgotten, to enforce directly restart Microsoft Information Store services.
0
 
MaheshConnect With a Mentor ArchitectCommented:
if there are SMTP gateways that accept messages for your domain other than Exchange, ensure they are using the same limits as well.

Mahesh
0
 
Olaf De CeusterConnect With a Mentor Commented:
Just double check limits with:

http://www.nogeekleftbehind.com/2011/12/09/show-exchange-message-size-limits-in-sbs-20082011/

Could be your ISP or router too.
Hope that helps,
Olaf
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
ColumbiaMarketingAuthor Commented:
Thank you for the replies, although it seems it may have been impatience on my part because now I am able to receive the large emails just fine without changing anything else.  

From my testing it took roughly 20 minutes for the message size limit changes I made on the Exchange server to fully take effect without restarting any services.  Is this behavior by design by chance?
0
 
ColumbiaMarketingAuthor Commented:
I am awarding points to all of you because all those settings need to be considered for this scenario.  

Thank you
0
 
Patrick BogersDatacenter platform engineer LindowsCommented:
Thnx for the points and glad we could help.
Yes, per my posting, changes need a replation period which you can enforce.

Cheers
1
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.