• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 357
  • Last Modified:

Exchange Server 2010 - Cant receive external emails

Hi Everyone

I have a Server 2008 R2 Exchange Server running 2010. I am having issues receiving emails form external. I can send and receive fine internally and I can send fine externally. I have setup receive connectors and also my MX records are correct and I have forwarded ports 25, 80 and 443 to the server. However I am still not receiving external emails.

Please help

Thanks
0
tiemannitservices
Asked:
tiemannitservices
2 Solutions
 
bigeven2002Commented:
Hello,

I found a couple relevant articles that may help.

http://community.spiceworks.com/topic/211873-exchange-2010-is-not-recieving-external-emails

http://www.petri.co.il/forums/showthread.php?t=42794

Test exchange connectivity here: https://testconnectivity.microsoft.com/

Also, check the services on the server to make sure the appropriate exchange related services are started, notably for hub (or edge) transport.
0
 
Alan HardistyCo-OwnerCommented:
Are you running low (less than 10% free) on any volumes?

Please have a read of my article to see if you are suffering from Backpressure which will cause inbound mailflow to stop:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_4259-Exchange-2007-2010-Backpressure-Quick-Fix.html

Alan
0
 
tiemannitservicesAuthor Commented:
Problem solved

Required ports were being blocked by ISP
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now