Solved

Configuring a new postfix server

Posted on 2014-01-18
6
538 Views
Last Modified: 2014-03-20
HI,

I´m deploying a new postfix server  hosted at Amazon with a ubuntu server distribution.

After following some guides, I installed the software opened the ports and tried yo send from gmail and hotmail to my server.


I can telnet to the server but impossible to get email or also connect to the server using outlook express.

Software  installed:
Postfix  2.9.6
Amavis
SpamAssassin versión 3.3.2

what is wrong?

any idea?

Regards
spamassassin.rtf
main.rtf
0
Comment
Question by:heze54
  • 3
  • 2
6 Comments
 
LVL 7

Expert Comment

by:expert1010
ID: 39793605
Hi,

check the parameter mydestination. You have:
mydestination = mydomain.org, localhost.mydomain.org, , localhost

Get rid of  mydomain.org, localhost.mydomain.org and put in $mydomain and  localhost.$mydomain

And check http://www.postfix.org/BASIC_CONFIGURATION_README.html#mydestination

RTF might not be the best format to send config files in. Just send plain ascii.

cheers,
0
 

Author Comment

by:heze54
ID: 39797793
Hi,


Right now I´getting some emails from amavis like that:

bayes: expire_old_tokens: locker: safe_lock: cannot create tmp lockfile /var/spool/MailScanner/spamassassin/bayes.lock.webmail.hezesoft.org.16750
for /var/spool/MailScanner/spamassassin/bayes.lock: Permission denied

Open in new window



Any idea?

Regards
0
 
LVL 7

Expert Comment

by:expert1010
ID: 39799425
Hi,

Mailscanner isn't really my turf but I found a reference that might help you. Mailscanner seems to need -U in it's start. -U in perl means use some "unsafe" operations.

ref. (see last comment Jerry Benton | 18 Apr 22:15 2013)
http://comments.gmane.org/gmane.mail.virus.mailscanner/79411
0
U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

 

Author Comment

by:heze54
ID: 39846894
Same problem
0
 
LVL 13

Accepted Solution

by:
Sandy earned 500 total points
ID: 39852567
is locally your server working fine ?

#telnet localhost 25
helo localhost
mail from: a@a.com
rcpt to:a@a.com
data
Subject: hello
hi
.

quit

Paste output of mail logs here

TY/SA
0
 

Author Closing Comment

by:heze54
ID: 39942793
Hi, bad configured.. now is working
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Fine Tune your automatic Updates for Ubuntu / Debian
The new Gmail Phishing Scam going around is surprising even the savviest of users with its sophisticated techniques.
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
Established in 1997, Technology Architects has become one of the most reputable technology solutions companies in the country. TA have been providing businesses with cost effective state-of-the-art solutions and unparalleled service that is designed…

685 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question