Configuring a new postfix server

HI,

I´m deploying a new postfix server  hosted at Amazon with a ubuntu server distribution.

After following some guides, I installed the software opened the ports and tried yo send from gmail and hotmail to my server.


I can telnet to the server but impossible to get email or also connect to the server using outlook express.

Software  installed:
Postfix  2.9.6
Amavis
SpamAssassin versión 3.3.2

what is wrong?

any idea?

Regards
spamassassin.rtf
main.rtf
heze54Asked:
Who is Participating?
 
SandyConnect With a Mentor Commented:
is locally your server working fine ?

#telnet localhost 25
helo localhost
mail from: a@a.com
rcpt to:a@a.com
data
Subject: hello
hi
.

quit

Paste output of mail logs here

TY/SA
0
 
expert1010Commented:
Hi,

check the parameter mydestination. You have:
mydestination = mydomain.org, localhost.mydomain.org, , localhost

Get rid of  mydomain.org, localhost.mydomain.org and put in $mydomain and  localhost.$mydomain

And check http://www.postfix.org/BASIC_CONFIGURATION_README.html#mydestination

RTF might not be the best format to send config files in. Just send plain ascii.

cheers,
0
 
heze54Author Commented:
Hi,


Right now I´getting some emails from amavis like that:

bayes: expire_old_tokens: locker: safe_lock: cannot create tmp lockfile /var/spool/MailScanner/spamassassin/bayes.lock.webmail.hezesoft.org.16750
for /var/spool/MailScanner/spamassassin/bayes.lock: Permission denied

Open in new window



Any idea?

Regards
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
expert1010Commented:
Hi,

Mailscanner isn't really my turf but I found a reference that might help you. Mailscanner seems to need -U in it's start. -U in perl means use some "unsafe" operations.

ref. (see last comment Jerry Benton | 18 Apr 22:15 2013)
http://comments.gmane.org/gmane.mail.virus.mailscanner/79411
0
 
heze54Author Commented:
Same problem
0
 
heze54Author Commented:
Hi, bad configured.. now is working
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.