sbs 2003 to 20011 Migration

Trying to complete an SBS 2003 to 2011 migration but I cannot uninstall Exchange 2003 Error encountered
he error says "You must be a member of the Domain Admins, Schema Admins, and Enterprise Admins groups" but I have tried with 2 admin account both of which are members of all required account.
HELP!!! I need to sort this quick as I only have 1 day remaining ins SMS migration.
gogsckAsked:
Who is Participating?
 
Jeffrey Kane - TechSoEasyConnect With a Mentor Principal ConsultantCommented:
This is a pretty common problem if you don't allow Public Folders to fully migrate.

You will need to manually remove Exchange 2003 from your domain.  Check out this article for how to do that:  

http://blog.mpecsinc.ca/2011/07/sbs-2003-to-sbs-2011-migration-exchange.html

Jeff
TechSoEasy
0
 
mijaredCommented:
By default the administator account has some deny permission in exchange. Try and copy the administrator account in AD and log in as this new user.

Give this user full permission on the server in the exchange management console.

Michael
0
 
gogsckAuthor Commented:
Sorry No difference. created a copy of the Administrator account in AD logged in but didn't make any difference. still the same error.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
ktaczalaCommented:
In SBS 2003 the built-in admin account is 'administrator', have you disabled this account and setup your own admin accounts?
You must log in with the domain\administrator login.
When sbs 2003 was initially setup it automatically creates the 'administrator' account.
0
 
gogsckAuthor Commented:
Administrator is still active. I logged in with domain\administrator but it won't allow me to uninstall.
When I try to force AD replication (in AD Sites and Services) I get a message saying the SBS2011 box is currently rejecting replication requests! I have restarted it but still the same message.
So I can't create a new network administrator as it doesn't replicate to the SBS 2003 box.
Looks like it may be a replication issue.
0
 
hecgomrecCommented:
The 2003 must still be a DC on the AD so you can be authenticated on the AD.

Then follow the steps "Demote and remove the Source Server from the network"  here.
0
 
gogsckAuthor Commented:
Ran this on both servers & repl,acation worked - temporarily!

repadmin /options servername +DISABLE_OUTBOUND_REPL  
repadmin /options servername -DISABLE_OUTBOUND_REPL
repadmin /options servername +DISABLE_INBOUND_REPL
repadmin /options servername -DISABLE_INBOUND_REPL

Tried to remove exchange again but it finished with an error.
Ended up removing Exchange  with ADSIedit.
Now I can't demote the old server.
When I run DCpromo on the old server it fails.DCpromo Error
any ideas
0
 
gogsckAuthor Commented:
I'm still not sure how to remove the old SBS 2003 as DCprom fails to demote the server. This migration is about to collapse  in a few hours. I'm getting desperate.
0
 
hecgomrecCommented:
If you are using the Active Directory Installation Wizard and you getting this error then in an elevated command window run dcpromo /forceremoval.  If you already have try just using your dcpromo.exe then add the above option.

- At the Welcome to the Active Directory Installation Wizard page, click Next.
- At the Force the Removal of Active Directory page, click Next.
- In Administrator Password, type the password and confirmed password that you want to assign to the Administrator account of the local SAM database, and then click Next.
- In Summary, click Next.

Perform a metadata cleanup for the demoted domain controller on a surviving domain controller in the forest.
0
 
gogsckAuthor Commented:
I eventually changed the replication policy in the registry on both servers. That allowed them to replicate.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NTDS\Parameters

2.Click Add Value on the Edit menu.
3.Add the following value:
Value Name:
Strict Replication Consistency

 Data type: REG_DWORD
 Value data: If the value is
1
, change it to
0

I took hold of the FSO roles from the new server then DCPROMO worked on the old server.
I imagine that there will be a lot of cleaning up to do yet tho.

Thanks for everyone's help
0
 
hecgomrecCommented:
So you did not follow the steps for the migration as it is clear that you should transfers FSMO before removing the old server.... well at least your environment is OK now...
0
 
gogsckAuthor Commented:
I did transfer the FSMOs before removing the old server.
0
 
hecgomrecCommented:
Sorry bro... but if you had to "hold" the FSMO from the new server.... you did not transfer them to new server as requested....
0
 
gogsckAuthor Commented:
I didn't have to hold the  FSMO from the new server. AD Replication had stopped because there was errors in AD - an obsolete server I think that had been partially removed previously.
0
 
gogsckAuthor Commented:
Unfortunately after trying to get the final Public Folder to Migrate for 2 weeks (all other folders migrated ok),  I was forced to carry on with the migration. I copied the data and recreated the folder on the new server.
I have now performed a clean up and all appears to be ok.
Thanks to all for your help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.