Unable to delete datastore due to slots file there in datastore

i have migrated all my vms to other datastore to remove the existing datatsore,but when m trying to delete ..can see one slots file is showing under folder and not allowing me to delete: getting msg: error occured

tried to disable storage I/O ..no luck after that

please advice what that slots file is ?

 and how can we make sure if datastore is not in use by any process,before removing it ?

Please advice to resolve this problem
LVL 1
patronAsked:
Who is Participating?
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Correct, that's the solution.
0
 
patronAuthor Commented:
Getting error: Ressource is in use

and error caused by a file : slots file in datastore
0
 
AbhilashBloggerCommented:
Its because of Storage I/O control being enabled on the datastore. Disable it and then delete it.
To disable it

    Select a datastore in the vSphere Client inventory and click the Configuration tab.
    Click Properties.
    Under Storage I/O Control, deselect Enabled.
    Click Close.
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

 
patronAuthor Commented:
Thanks for sharing this info..already tried that option .. but no luck

anyone please advice what that slot file is showing there on datatsore while i have migrated  all vms form that datstore to others in cluster ?
 m able to rename that file..but when trying to delete..:error caused by file

after file rename i can see another file by name slosfile is automatically created there in datastore

please advice best way to check if we can check if perticuler datatsoe is not in use by any file/objcet there in clsuter/host..so that can be removed safely?
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Does it say it's BUSY? (also check the logs /var/log/vmkernel.log)

I have seen this issues, only this week, and it is very difficult to resolve.

It can be Storage I/O, or another process using the datastore, and this needs to be DISABLED ON ALL Hosts access the datastore.

see here

Cannot remove datastore - VMware Knowledge Base

Deleting a datastore from the Datastore inventory results in the error

What we have seen, is you will be able to unmount this LUN, from the majority of hosts in your cluster escept one.

I would recommend, that your esclate a support request with VMware, to resolve this issue.
0
 
AbhilashBloggerCommented:
Slotsfile is created when you enable SIOC.
http://infrastructureguy.wordpress.com/2012/05/10/vmware-datastore-files/

Try renaming the datastore and then deleting it.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Also have a look at this article

VMware KB: Unmounting a LUN or detaching a datastore/storage

http://yuridejager.wordpress.com/2012/05/11/deleting-the-undeletable-datastore-the-resource-is-in-use-call-hostdatastoresystem-removedatastore-for-object-ha-datastoresystem-on-esxi-failed/

you can also see what files are in use

 #lsof

or

#vmkvsitools lsof

Are you using any SAN Vendor software or plugins, which manage your LUNs?

e.g. NetApp, EMC or Dell Equallogic ?

you can also use this, to see if files are in use....

esxcli storage core device world list -d <device>

we have found we have lots of helpers, after the VMs have been removed!
0
 
patronAuthor Commented:
using one IBM Plugin named VSC [image attached]on vc 4.1 and this should not be issue here..as we have removed multiple datastore earlier in same way ..?

can we locate where that file in use..bcoz erro m getting is..
error-while-removing-datastore.jpg
plugin.jpg
0
 
patronAuthor Commented:
To locate where this file in use ?
0
 
patronAuthor Commented:
issue is as same as we can see there in url...

http://yuridejager.wordpress.com/2012/05/11/deleting-the-undeletable-datastore-the-resource-is-in-use-call-hostdatastoresystem-removedatastore-for-object-ha-datastoresystem-on-esxi-failed/

but unable to find solution..even vmware saying to reboot the host only ..!!
0
 
patronAuthor Commented:
Thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.