Solved

cannot download microsoft updates

Posted on 2014-01-20
11
426 Views
Last Modified: 2014-01-23
in Dec I was still able to download and detect Microsoft updates as usual using my
virgin media superhub 1/vmdg480 router.

but as I had updated my virgin media package to include a basic tv package, they also updated my router to: superhub 2/vmdg485 and since then I no longer receive anymore updates from Microsoft as described below:

note: prior to installing 'isa 2006' I do receive internet, but still cannot download anything from 'windows update' as described above, but after installing 'isa 2006' and adding the usual: dns, dhcp & http & web listener for detect wsus updates as usual, I cannot even receive internet access, even though I can ping for example: ping www.yahoo.co.uk - successfully.

I have spoken with other techies and they said windows 2003 should still download as does not stop until about 'apr 2014' this year.

note:  however, xp detects and downloads as usual as a standalone.

when I install windows 2003 I can receive internet access as usual.

when I logon to 'windows update' I can select either 'express or custom' but nothing is detected.

when I install isa 2006 as usual for: dns, dhcp & http to allow internet access as usual, I cannot now receive internet access at all and when I check the eventviewer their are no errors.

after installing isa 2006 and configuring as above I then 'attempt to download windows updates as above by choosing 'express or custom' but nothing is detected and when I open eventviewer it eventually shows: application hang.

totally lost!
0
Comment
Question by:mikey250
  • 8
  • 3
11 Comments
 
LVL 11

Accepted Solution

by:
Manjunath Sullad earned 500 total points
Comment Utility
1. Try Disabling firewall.

2. Try disabling Antivirus.

3. Try to install any Windows hotfix and check, whether you are getting any error on not.

4. Check in safemode.

5. Try updating Windows update agent, (https://support.microsoft.com/kb/949104/en-us)

6. If possible restore to earlier backup.
0
 

Author Comment

by:mikey250
Comment Utility
hi when I connected to 'windows update' it already detected and installed the 'windows update'.  I have completed many clean installs on same machine and never had this problem.

1. yes I have disabled all 'isa firewall services.
1a.  as I also run a gpo for internet access - I removed this from 'internet options' & left 'auto detect' this returned internet access as usual.

2.  currently not running any antivirus, just isa 2006.

3.  if you are referring to step 5 below then it only shows fix for win 8/8.1/win 7 & xp not windows 2003
4.  not sure what to check in safemode
5.  which fix do I use for windows 2003
6.  I have done backup but due to virgin media switching from vmdg/480 to vmdg485, problem has occurred after I completed a clean install on my fileserver & isa 2006 server

however I am repeating your instructions now, but regarding (step 5) above, it does not show a fix for windows 2003 as when I compare the version numbers they are completely different ie my isa is:

- wuaueng.dll - dated: 02/06/2012 7.6.7600.256

when I open 'services.msc' on my isa 2006 it does not show 'windows update'
0
 
LVL 11

Assisted Solution

by:Manjunath Sullad
Manjunath Sullad earned 500 total points
Comment Utility
0
 

Author Comment

by:mikey250
Comment Utility
hi manjunath,

I did the following:

REGSVR32 %SYSTEMROOT%\SYSTEM32\WUAUENG.DLL - successfully

after stopping the isa 2006 I was able to detect updates via 'windows updates' and download quite a few.

after rebooting and logging back on I also checked the 'services.msc' and the 'windows update' has still not appeared.

I also did:

net stop wuauserv - successfully
net start wuauserv - successfully

in the regedit edit is still shows as the same:

description - reg_sz - enables the download and install of windows updates
displayname - reg_sz - auto updates
errorcontrol - reg_dword - 0x0000000(1)
imagepath - reg_expand_sz - %systemroot%system32\svchost.exe -k netsvcs
objectname - reg_sz - localsystem
start - reg-dword - 0x00000002(2)
type - reg_dword - 0x00000020(32)

I also run: gpupdate /force - successfully & restarted machine, which put back my gpo\userconfiguration\proxy connections - but still no internet.

I then removed the 'proxy' details via internet options manually and internet comes back successfully.

still same issue presumably because the 'windows update' has not appeared in the 'services.msc'

I attempted to install the fix via:

http://support.microsoft.com/kb/949104  - but it stated was not correct version so did not install as I tried both the win 8 & xp/win 7 fix.

I then followed the instructions via below starting at step 2 but 'wuauserv' was not started so I continued onto step 3 but it would not work so I continued at step 5 but a few of the (dll) were not found & I have also rebooted.

http://support.microsoft.com/kb/971058/en-us
0
 

Author Comment

by:mikey250
Comment Utility
morning, manjunath sullad,

also the 'services.msc' - does not show 'windows update' either.

what confuses me is that my 'isa 2006 & my master dc/ad/dns/dhcp server' have had partitions deleted and re-created and then installed clean.

note:  I have checked the 'eventviewer' in 'safemode' and no issue around my issues are showing except those that appear not to work due to going in 'safe mode' but nothing to do with the issue I have from what I can see.

after logging out of 'safemode' and the server reboots, it has not prompted a message:

"windows could not start because the following file is missing or corrupt:
system32\drivers\isapnp.sys"

you can attempt to repair this file by starting windows setup using the original setup cd-rom.  select 'r' at the first screen to start repair.
0
Integrate social media with email signatures

Is your company active on social media? Do you also use email signatures? Including social media icons in your email signature is a great way to get fans for free. Let all your email users know you’re on social media quickly and easily, in a single click.

 
LVL 11

Expert Comment

by:Manjunath Sullad
Comment Utility
Sorry, I didn't understand, Can you please explain briefly on

" what confuses me is that my 'isa 2006 & my master dc/ad/dns/dhcp server' have had partitions deleted and re-created and then installed clean"
0
 

Author Comment

by:mikey250
Comment Utility
the below link provided earlier mentioned about the 'conflicker virus', I had also changed one of my nic cards and was not sure if something could affect my bios or something:

http://social.technet.microsoft.com/Forums/windows/en-US/5a8bf018-c522-4a8e-a857-ac73f5e706ee/windows-update-service-missing-in-servicesmsc?forum=w7itprogeneral

do you have the following registry key info below ?  it is very likely that your computer/network is infected with a variant of the (conficker virus).  one of it's first attack actions is to cripple the windows update service to prevent itself being removed by thngs like Windows Defender or the malicious software removal tool.  even though win7 does not have any vulnerabilities conficker can attack, it also attacks accounts with weak or blank passwords.

due to seeing the missing possible corrupted: 'isapnp.sys' & as there might be a problem on my machine I thought I would do the below also although the 'isapnp.sys' still shows - I have accessed the recovery console and followed instructions for xp repeating same process for windows 2003:

http://www.youtube.com/watch?v=rVZe8YYkH4E

md tmp
copied corrupted registry files to 'tmp'
deleted all corrupted files
now just copied a brand new registry back to its original location

note: I only have sp2 & isa for: dns, dhcp & http configured on the isa so thought it made sense to do the below.

I am thinking I could located the 'isapnp.sys' from the windows cd and manually copy back to its original location but also delete the corrupted file if it is there.

I used the below 'video' to try and rename the 'isapnp.sys to isapnp.old, but it stated:

the rename operation failed

I then tried copying the 'isapnp.sys' from the cdrom but that stated:

copy d:\i386\isapnp.sys c:\windows\system32\drivers - enter

http://www.youtube.com/watch?v=Cr6lo3tJWHk

I am not sure now, although maybe the 'isapnp' is located on the isa.exe but if so how would I get that  ?

note: when I attempt to access: safemode it - does not now allow me access and just shows the original error:

corrupt file: system32\drivers\isapnp.sys

I wonder if this is because I deleted the complete registry and copied back fresh files....so next time I will not touch the registry as I originally had no issues with the registry according to my 'eventviewer'.  I moved to quickly.
0
 

Author Comment

by:mikey250
Comment Utility
hi, manjunath sullad,

I know you are probably busy but if you have any suggestions about my steps followed on last 2 previous threads above I would appreciate if you could comments as i am not doing anything else except trying to resolve this problem and considering doing the below again:

reset bios to default settings
resetting bios to detect: cdrom
delete partition and create a new partition - as usual
installing win 2003 clean
install sp2
check 'services.msc' for 'windows update
follow your instructions to ensure 'windows update' re-appears in 'services.msc.
then join domain and continue as normal

note: my concern I have is that I have installed clean 3/4 times except for resetting bios default settings and on each and every occasion have this windows update problem.  what I would do is the following:

install win 2003/sp2
join domain
open internet browser for 'windows update' which would prompt to install the 'windows updates' software and enable me to select either:
express or custom - but it would not detect anything.

note:

usually I would do the following:

install win 2003/sp2
join domain which would be configured via my gpo pointing towards my: wsus domain member server & locate updates that way.  so whether it is in the method I am not sure.
0
 

Author Comment

by:mikey250
Comment Utility
morning,

- I have reset bios back to default settings
- I have re-installed win 2003
- I checked 'services.msc' and there is still no 'windows update' in view
- I installed sp2 & checked 'services.msc' and there is still no 'windows update' in view
- I have successfully detected via 'windows update' 140 updates which were also detected via windows update as usual and are currently updating now which is a good sign
- after installing the '140' updates I checked the 'services.msc' and still 'no windows update' shows, so it appears as though that is normal
- once done I will then join domain and install & configure isa in the hope the internet is allowed via the isa.

- the c:\windows\system32\wuaueng.dll - version is upto date

note:

my xp/sp3 - (does not) show 'windows update' in 'services.msc' either

note:

so it must be normal for win 2003 & xp not to show 'windows update via services.msc'

note:

when I check my 'win 7' laptop randomly it (does) show 'windows update' in the 'services.msc' - so I assume not so in 'windows 2003'....!
0
 

Author Comment

by:mikey250
Comment Utility
I realised the problem of why I was not able to detect for any windows updates!

it was because I had installed isa2006sp1' 1st, when I should have installed the following in that order:

1 - isa2k6evls_en
2 - isa2006sp1-enu-ee-eval

I cannot believe that I forgot about that as it happened before but I probably did not realise.

the good thing that has come out of this is the excellent advice I received.

much appreciated.
0
 

Author Closing Comment

by:mikey250
Comment Utility
sound advice!  much appreciated.
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Join & Write a Comment

To effectively work with Diskpart on a Server Core, it is necessary to write some small batch script's, because you can't execute diskpart in a remote powershell session. To get startet, place the Diskpart batch script's into a share on your loca…
New Windows 7 Installations take days for Windows-Updates to show up and install. This can easily be fixed. I have finally decided to write an article because this seems to get asked several times a day lately. This Article and the Links apply to…
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now