Solved

Autodiscover broken internally-- Exchange 2010

Posted on 2014-01-20
12
574 Views
Last Modified: 2014-01-21
We had a crash on our SBS 2011 regarding Exchange. After trying to upgrade to Exchange SP2 it failed and Exchange was not working. Microsoft stepped in to help and we were able to get Exchange back up and running.
Only problem now is that Autodiscover is not working internally. Users cannot set Automatic Replies internally. Externally it works fine and users can set Automatic replies from OWA.
We need to get the Autodiscover working internally. Any ideas?
Thanks
0
Comment
Question by:electricdad
  • 5
  • 3
  • 2
  • +2
12 Comments
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39794167
Run the fix my network wizard in the SBS management console. That will usually resolve most things. The main probably is probably around URLs or SSL certificates, which the wizard should correct.

Simon.
0
 
LVL 16

Expert Comment

by:Carol Chisholm
ID: 39794411
Check your DNS. Make sure that the autodiscover URL resolves to the internal IP on the workstations.
0
 

Author Comment

by:electricdad
ID: 39794743
Well,
there is no autodiscover entry in DNS. Only the external DNS site has the entry for the public IP. Would I have to create a new zone? Thanks
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 16

Assisted Solution

by:Carol Chisholm
Carol Chisholm earned 200 total points
ID: 39794780
you need the internal workstations to be able to find the internal IP of the exchange server.
If they try to go to the external address they will get confused.

Here is the Microsoft reference

http://technet.microsoft.com/en-us/library/jj591328(v=exchg.141).aspx

And petri.com
http://www.petri.co.il/autodiscover-configuration-exchange-2010.htm
0
 

Author Comment

by:electricdad
ID: 39795356
Thanks guys,
I will try your suggestions and be back with you a little later.
0
 
LVL 3

Expert Comment

by:Krishna Patil
ID: 39796278
0
 
LVL 11

Accepted Solution

by:
hecgomrec earned 300 total points
ID: 39796759
Just replace the address in your DNS for the public IP with the Internal.


You can't give a resource and external IP (internet facing - public IP) as the firewall won't allow the package to pass.

This is a normal procedure when you have the same internal and external name for a server.
0
 

Author Comment

by:electricdad
ID: 39798232
OK Hecgomrec and carolchi, I have created a DNS record and the autodiscover service appears to be working. I can setup an email account automatically now internally. But Automatic Replies still give an error-- Your automatic reply settings cannot be displayed because the server is currently unavailable. Try again Later __
Outlook was restarted-- should I reboot the server? I restarted Information Store with no luck.
thanks
And Automatic Replies works fine externally for my account-- but a user is calling saying it is not working for hers remotely. ??
0
 
LVL 11

Assisted Solution

by:hecgomrec
hecgomrec earned 300 total points
ID: 39798375
Make sure you don't have any other DNS record pointing to another IP.  DNS records are replicated among servers and a copy is store on the clients, you must run on clients on an elevated CMD, ipconfig /flushdns and then ipconfig /registerdns.  If this is not possible clients should reboot and try back.

If you are using outlook anywhere, this mean the client can't access the proxy (CAS) server with the previous settings.  First recommendation will be to re-create the profile.

In case you need more on info check this or here.
0
 

Author Comment

by:electricdad
ID: 39798443
I had just created a new profile and still not working. Cant see any other DNS records that are a problem. Autodiscover appears to be working since I can setup an email account automatically. But the Automatic Replies still gives this error internally??
0
 

Author Comment

by:electricdad
ID: 39798560
Uh Oh
Found a zone for Remote.domain.com in DNS and it referenced the Public IP. I changed it to the internal Exchange IP and it seems to be working-- I think my firewall was blocking the service from coming back in somehow or it did not know what to do with the public IP instead of the internal exchange IP. Seems to be working now!
Thanks for you help
0
 
LVL 16

Expert Comment

by:Carol Chisholm
ID: 39799198
Well done. You had to find that external IP.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Lotus Notes – formerly IBM Notes – is an email client application, while IBM Domino (earlier Lotus Domino) is an email server. The client possesses a set of features that are even more advanced as compared to that of Outlook. Likewise, IBM Domino is…
Follow this checklist to learn more about the 15 things you should never include in an email signature from personal quotes, animated gifs and out-of-date marketing content.
In this video we show how to create a Distribution Group in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >>…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…

803 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question