?
Solved

Exchange 2010 Activesync. Unable to download attachments on mobile devices.

Posted on 2014-01-20
6
Medium Priority
?
7,008 Views
1 Endorsement
Last Modified: 2014-02-03
Hi Team,

We have recently configured a few android phones to use activesync in an exchange 2010 environment. I'm currently using the default active sync policy with no attachment limit specified. I've checked that the users who have these phones have the default activesync policy assigned to their mailbox.
Every time these users try to download an attachment on the phone they receive an error that says: "Attachment Size Exceeds Limit Allowed By Policy". We have tried with multiple Samsung Note 3 and HTC one phones. These are 8MB attachments and it works fine using regular outlook and owa.

I also ran a test-activesyncconnectivity command and everything came back OK.

I've been breaking my head during the past 3 days trying to figure this out, any ideas what this could be or what else I should check?

Thank you.
1
Comment
Question by:exTechnology
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
6 Comments
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 39796385
Was the limit ever set on the policy and then changed?

If so - is the Policy Refresh Interval set or not set?  If it is set, was it set when the devices connecting that are having problems setup their Exchange accounts?

Alan
0
 
LVL 2

Author Comment

by:exTechnology
ID: 39796913
Hi Alan,

Currently there's no Policy Refresh Interval specified. There was never a limit set on the policy, I have tried setting a very high limit and without it just for testing and no luck.

Thx
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 39797025
The problem is - if the Refresh interval isn't / wasn't set before the accounts were configured on the devices, then any changes to the Policy won't be updated on the devices.

Please set the Refresh interval Set (which I think it should be by default) to 24 hours or so, then delete the account(s) from the devices, then re-add the accounts and they will pick up the current policy which should allow the larger (unlimited) attachments.
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 2

Author Comment

by:exTechnology
ID: 39800508
I just set the Refresh Interval to (1) and re-programmed the account in the phone, I'm still getting the same error message,
The attachment I'm trying to download is 16MB, the exchange limit is 30MB and I set the active sync limit to 2050MB just for testing.
The attachment can be download just fine in OWA and regular outlook.
On the Galaxy Note 3's i get the following error: Attachment too large for download
On the HTC One i get: Attachment Size Exceeds Limit Allowed By Policy

When I try to download the attachment on the iphones I also receive an error message but if i select "Download Full Message" then I'm able to download the attachment.

I need to resolve this issue for all Android users.
0
 
LVL 2

Accepted Solution

by:
exTechnology earned 0 total points
ID: 39818829
SOLUTION (Using Microsoft Support)
Modify the web.config file under the Microsoft-Server-ActiveSync site in IIS for all CAS server.  This modification changes the following:
MaxDocumentDataSize = 51200000
maxRequestLength = 51200

After those changes have been made, run the command prompt as an Administrator:
>C:\Windows\System32\inetsrv
>appcmd.exe set config -section:system.webServer/serverRuntime /uploadReadAheadSize:"10485760" /commit:apphost

Open the Default Web Site in IIS and select "Advance Settings"
Expand Connection Limits and increase the value to "240"

Under command propmt run and IISRESET

Go to Application Pools on the IIS Manager and right click on DefaultAppPool and select "Recycle", do the same with MSExchangeSyncAppPool.

Thats it!
This will increase the default limits in exchange for email size using ActiveSync, it is not recommended by Microsoft to make this any bigger as it can cause a bottle neck in the backbone.
0
 
LVL 2

Author Closing Comment

by:exTechnology
ID: 39829080
No solution found, contacted Microsoft support
0

Featured Post

Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
In this video we show how to create a Shared Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Sha…
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
Suggested Courses

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question