Windows 7 problem with drive mappings from Windows Server 2008

Hi Guys,

We have a VB mapping script in Windows Server 2008 that maps drives for users through group policy.

The one user on Windows 7 professional experienced a problem with one of his drives (P:) that did not map.  We added a short-cut to the VB-script on his desktop.

This worked for a couple of weeks, with him manually clicking the short-cut on his desktop.

Now, not even the manual backup script maps the P: drive first time round.  After a restart and retry, the P: drive suddenly appears.

Something on his machine is preventing P: drive from mapping correctly.  Drives before P: drive, such as drive N: and O: map successfully, without any problem.

Will appreciate any ideas?
Rupert EghardtProgrammerAsked:
Who is Participating?
Will SzymkowskiConnect With a Mentor Senior Solution ArchitectCommented:
On the machine in question do the following...
- Open cmd
- type net use
- check and see if the drive mapping for P: is present
- run the command  net use /delete P:
- Press enter
- Try remapping your P: drive

Also have you considered using Group Policy Preferences to map your network drives? Using scripts is really the old way of doing things and because you have 2008 AD you can use Group Policy Preferences.

You have loads of flexability like mapping drives based on the following criteria's
-user group membership
- user name
- IP address
- computer type
- Active Directory User or Computer OU

Check the below link on how to setup Drive Mappings using GP Preferences...

Group Policy Preferences Drive Mappings

Manjunath SulladTechnical ConsultantCommented:
Open Command prompt and run below commands,

wmic server get ErrorsAccessPermissions
wmic server get ErrorsGrantedAccess
wmic server get ErrorsLogon
wmic server get ErrorsSystem

If you are getting any error for these commands, Act based on error message.

Also install Process Monitor from Sysinternals site (below link)

And you can track the Boot time logging of all operations
Miguel Angel Perez MuñozCommented:
Ensure any kind of external unit (hard drive, pendrive, DVD) or virtual driver is not using this letter
Rupert EghardtProgrammerAuthor Commented:
Group Policy Preferences to map your network drives
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.