Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 252
  • Last Modified:

Formula Check box keeps reverting to 4 processors

http://www.howtogeek.com/162219/how-to-change-the-automatic-calculation-and-multi-threading-features-in-excel-2013/

Using Excel 2013. If you go to the very last picture of this other forum this is basically what I'm trying to accomplish. However when I close the work book and go back in it revert back. I've tried logging in with an administrator domain account with same results. Has any experienced this?
0
chadfran
Asked:
chadfran
  • 4
  • 3
1 Solution
 
zorvek (Kevin Jones)ConsultantCommented:
What are you changing it from and to?

Kevin
0
 
chadfranAuthor Commented:
From 4 to 1.  I even tried un-checking Enable multi-threaded calculation and it greys out everything but next time I go back in it has it checked and using all processors.
0
 
zorvek (Kevin Jones)ConsultantCommented:
I've been able to reproduce the behavior. I'm reaching out to Microsoft and the Microsoft MVPs to see if anyone else can shed any light on this.

Some additional discovery:

- This is not a problem in 2010.

- If I use 2013 to open a workbook created in 2010 then any changes to these settings made in 2013 do seem to stick.

Kevin
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
chadfranAuthor Commented:
We are running 2010 and still have the problem.
0
 
zorvek (Kevin Jones)ConsultantCommented:
I've figured it out. The settings behave the same way that the Calculation mode setting behaves. It's a little convoluted but does make sense.

The calculation mode option is set and stored with the workbook but exactly how that happens is not always the most logical. And it is ignored when opening a workbook into an existing Excel instance with one or more workbooks already open. Every Excel application instance starts with the calculation mode set as defined in the first workbook opened. All other workbooks opened assume the currently set calculation mode.

So, to use the threading settings, you have to ensure that the workbook with the desired settings is opened before any other workbook.

The reason I was not able to reproduce the "problem" in 2010 is that, as my system is configured, I was always opening the workbook with the custom threading settings before any other workbook. In 2013 I was not.

Kevin
0
 
zorvek (Kevin Jones)ConsultantCommented:
You can force Excel to use one processor whenever your workbook is opened regardless of what other workbooks are open by putting this VBA code in the ThisWorkbook code module:

Private Sub Workbook_Open()
    Application.MultiThreadedCalculation.ThreadCount = 1
End Sub

Kevin
0
 
chadfranAuthor Commented:
That worked. Thanks!!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now