Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Website changes not working

Posted on 2014-01-21
14
Medium Priority
?
271 Views
Last Modified: 2014-01-22
Recently the contractors who do our website completely rebuilt it and made changes. So when I go to the website I see the flash intro and then after a few seconds it says "403-Forbidden: Access is denied"

But If i go to our website from an outside network the website works and I can see all the changes.

Any ideas?
0
Comment
Question by:IT_Fanatic
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
  • 3
  • +1
14 Comments
 
LVL 44

Accepted Solution

by:
Chris Stanyon earned 1000 total points
ID: 39797183
Speak to your contractors!!

Sounds like you may have a caching issue, but it's such an open-ended question, you'd be much better off speaking to the people you're already using.
0
 

Expert Comment

by:lrbrister
ID: 39797278
I agree with Chris Stanyon

We had exactly the same thing.
Turned out to be a caching issue on our business network.

They changed the cache recycle and cleaned everything up.

But you paid these guys so they should clean it up.
0
 

Author Comment

by:IT_Fanatic
ID: 39797300
Ok heres more info.

I can go next door to another client and when i go to
www.abc.com and abc.com the new website works fine.

I come to my internal network and go to
www.abc.com and abc.com the new flash intro loads but then says ""403-Forbidden: Access is denied"

On both networks internal and outside I ping www.abc.com and I get the IP. Both networks get the same IP. I log into network solutions and it is the correct ip.

So I type the IP address on the url bar on both locations and it says website under contruction. Which makes no sense if I can see the website and I know its good which I verified out of the network.

I go to my network and go to DNS Manager>Forward Lookup Zones. I have an A record thats been created a long time ago for our website. Its a www A record. It has the same IP that pings back when I ping www.abc.com.

Any ideas?

Oh I also did a ipconfig /flushdns on the DNS server and still same issue
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 44

Expert Comment

by:Chris Stanyon
ID: 39797313
Caching - speak to your contractors!

Good luck with it.
0
 

Author Comment

by:IT_Fanatic
ID: 39797320
Meaning its an issue with the people who created the website or an issue with my internal servers?
0
 

Assisted Solution

by:lrbrister
lrbrister earned 1000 total points
ID: 39797352
IT Fanatic

For us it was an internal network issue.
However...

When the third party developers set these things up, they're supposed to ensure it's visible everywhere.

Have them all check the "a" record on the domain settings.
0
 
LVL 44

Expert Comment

by:Chris Stanyon
ID: 39797353
If they've changed your website and it's no longer working for you, then you really need to speak to them - you contracted them to do a job, which it appears they've not completed properly.

If you can access  your site from outside of your own network, then it seems like the problem is with your network - if it was with the site, then I guess no-one would be able to access it.

It could be browser cache or network cache.
0
 

Author Comment

by:IT_Fanatic
ID: 39797418
Both my www A records have the IP of the website.

I did ipconfig /flushdns on my PC and the DNS severs with the A record and same results. Only sees the flash intro and poof the 403 error comes out.

I went to network solutions under Edit Advanced DNS Records>IP Address (A Records)

I see the host www with the correct IP as the www A Records on my servers and the correct IP when i ping www.abc.com. The thing I noticed is the TTL on the www in network soultions is 7200. The TTL on the www A Records on the server is 1HR.

They just did the changes last night. Could it be that since the TTL from network solutions hasnt taken place hence the reason why we cant see it in the internal network yet? The server www A Record is set to static.
0
 

Expert Comment

by:lrbrister
ID: 39797437
Could be.

Again I echo Chris Stanyon.

Your contractors have to clean this up
0
 
LVL 44

Expert Comment

by:Chris Stanyon
ID: 39797451
If the changes only took place last night, then you need to give it 24 hours for propagation. This will only be an issue if while rebuilding your website they actually put it on a new server. If it's on the same server (host), then DNS, A records etc. won't make a difference.
0
 
LVL 18

Expert Comment

by:bruno
ID: 39798949
Agreed, sounds like a DNS issue. Can you have your internet provider flush your DNS cache?

Also, your website is abc.com?
0
 

Author Comment

by:IT_Fanatic
ID: 39800244
Ok we are going on Day 2 of this issue. We gave it about 24Hours after the outsorced WEB Developers made the change and still on the internal LAN we see the new flash intro and than the error. It works only outside of the LAN.

I attached 2 images.

Image 1 = I went to IE on our 2010 Exchange server and tried to go to the website. This server is DNS server 2. The A record for www is the same its been for years and the same IP of the current website. No changes have been made to this environment other than just windows updates.

Image 2 = I went to IE on our main server. DNS server1 and DHCP. The A record for www is the same its been for years and the same IP of the current website. No changes have been made to this environment other than just windows updates. This is the same error that appears on all user PC's

Image 3 = This is the A Record we have and its been the same since day 1 (which has always worked). The same info is on an www A Record on both DNS1 and DNS2 which has worked since day 1.
0
 

Author Comment

by:IT_Fanatic
ID: 39800596
This now works. The WEB Team fixed it. This was the issue they said.

"The flash intro had an action script which redirects the url to home page after completion of the animation. In this case, it somehow did not work, may be because of some restriction in the internal firewall / network. I have removed the action script and added the redirection code in the splash.htm page."
0
 

Author Closing Comment

by:IT_Fanatic
ID: 39800600
I checked everything as provided by these experts and verified that I had it all right. They pointed out the issue had to be the Web Devs which they were correct.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When it comes to write a Context Sensitive Help (an online help that is obtained from a specific point in state of software to provide help with that state) ,  first we need to make the file that contains all topics, which are given exclusive IDs. …
Originally, this post was published on Monitis Blog, you can check it here . In business circles, we sometimes hear that today is the “age of the customer.” And so it is. Thanks to the enormous advances over the past few years in consumer techno…
Any person in technology especially those working for big companies should at least know about the basics of web accessibility. Believe it or not there are even laws in place that require businesses to provide such means for the disabled and aging p…
Video by: Mark
This lesson goes over how to construct ordered and unordered lists and how to create hyperlinks.

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question