[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1712
  • Last Modified:

Why is my green arrow missing in SSMS "Registered Servers" and "Object Explorer"?

This is more of an annoyance then a real problem but I have been looking at this for a long time and I really would like to fix this.  The problem is that when I open SSMS and navigate to my registered SQL servers, I see that some of my registered servers are missing the green arrow.  

Despite the little green arrow not showing up it has posed no connection problems to the SQL instances.  I am still able to click on the server and navigate to all the objects within the instance with no problem.

I have sysadmin on all of these SQL servers so it is not a permissions issue.  Also, this problem is not discriminating between the SQL servers in the DMZ or on the trusted network, it is happening on both.

So why is the little green arrow not showing up?
0
RayManAaa
Asked:
RayManAaa
  • 4
  • 3
1 Solution
 
Patrick BogersDatacenter platform engineer LindowsCommented:
Hi

IMHO it is a firewall thing, enabling an exception for WMI should solve the problem.
0
 
RayManAaaAuthor Commented:
Hello

I think you are talking about giving the AD account permission to the WMI control.  I already did this by following the steps below from another link which I found on this issue, unfortunately it did not work.

1. On the target server, go to Administrative Tools -> Computer Management.
2. Expand 'Services and Applications'
3. Right click for Properties on 'WMI Control'.
4. Select the Security tab.
5. Press the Security button.
6. Add the AD account, and select check Remote Enable for the user requesting WMI data.
0
 
Patrick BogersDatacenter platform engineer LindowsCommented:
Hi again,

No, i really mean WMI in the firewall.
0
NEW Veeam Backup for Microsoft Office 365 1.5

With Office 365, it’s your data and your responsibility to protect it. NEW Veeam Backup for Microsoft Office 365 eliminates the risk of losing access to your Office 365 data.

 
RayManAaaAuthor Commented:
Hmmm,

No, I don't think that is the problem.  

Some of the SQL servers that have this problem are in the trusted network.
0
 
Patrick BogersDatacenter platform engineer LindowsCommented:
Hi again, if you don't think so i cannot help you any further. Maybe you trust MS SQL pro's?
0
 
RayManAaaAuthor Commented:
Please explain how this can be a firewall issue when the SQL server is in the trusted network?
0
 
Patrick BogersDatacenter platform engineer LindowsCommented:
Hi,
You have multiple levels (home, company, public) for the Windows Firewall, so even the internal network (trusted) has rules in place if enabled and WMI is one of those features that is not enabled by default.
I know because i need to add this exception to every workstation and server i deploy because i want to manage all licences with a Volume Activation Management Tool... pretty sure if you enable WMI on you internal firewall the green Arrow will appear. Just try it... if not happy disable it again.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now