Solved

Opening documents over VPN with Office 2013 is very slow

Posted on 2014-01-21
11
4,763 Views
Last Modified: 2014-02-06
When we try to open any Word documents with Word 2013 over a site-to-site VPN connection, it takes 10 times longer than opening the same document with Word 2010. We have several computers in the office and it is very consistent that the computers with Office 2013 are slow when opening and closing documents while the ones with Office 2010 are much faster.

For example a small 15k Word file will take maybe 5-10 seconds to open with Word 2010 but it will take 5-7 minutes to open with Office 2013. Has anyone else experienced this issue? Is there a difference in the way Office 2013 handles file access?

Closing the file also takes 5-7 minutes. It happens with any Word file. I haven't test Excel.

Any suggestions would be helpful.

Thanks
Kent
0
Comment
Question by:fkoyer
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
11 Comments
 
LVL 57

Assisted Solution

by:Jim Dettman (Microsoft MVP/ EE MVE)
Jim Dettman (Microsoft MVP/ EE MVE) earned 500 total points
ID: 39799687
Kent,

  Haven't experienced this directly, but anytime your working over a VPN, odd things can happen.

  One of the things that's often not obvious is that with VPN connections, the MTU (Maximum Transmission Unit) can be too large.   It's supposed to be self tuning, but a router not setup properly can stop that from happening.

 As a result, the default MTU of 1500 bytes may be too large, causing packets to fragement.

 Depending on the pattern of transmission and the size of the packets, a lot of packets can get dropped, which adds a lot of overhead.

 Not sure if this is your problem or not, but it's something you may be tripping over just by the way 2013 is working.    

 I would think though that you'd find problems else where if this was the case, but not sure what your doing over the VPN and it was worth mentioning.

 The other thing to look out for; any add-ins, such as anti-virus scanners, label formatters etc.   I would try starting in safe mode and see if that changes anything.

Click start, run, and then:

  winword /safe

 If that makes things fast, then use file > options > add-ins and disable them one at a time off the manage list.  Also check for COM add-ins as well.

Jim.
0
 
LVL 1

Author Comment

by:fkoyer
ID: 39803454
I don't think it's a problem with the VPN because I can copy a file over the VPN in about 5 seconds. It's actually faster to copy the file to desktop, open it, save it, and copy it back to the network than it is to open the file directly from the network. Also, we do not have any problem with Word 2010, it's just Word 2013.

Turning off the antivirus protection shaves off about 10 seconds.

Running Word in safe mode doesn't have any effect.

I don't know what Word is doing in the background that takes so long. When you double click a Word document you get the blue splash screen with a little status message in the bottom that goes through the following series:

Processing...
Contacting \\server\share...
Contacting T:\path\to\file...
Downloading T:\path\to\file...
Processing...
Contacting \\server\share...
Contacting T:\path\to\file...
Processing...
etc..

Not sure if I got all those in the right order but it's doing a lot of processing and contacting. The downloading part doesn't take very long. It's all the processing and contacting that takes the time.

The server is Server 2003 if that makes a difference.

Thanks
Kent
0
 
LVL 57
ID: 39803508
<<I don't think it's a problem with the VPN because I can copy a file over the VPN in about 5 seconds. It's actually faster to copy the file to desktop, open it, save it, and copy it back to the network than it is to open the file directly from the network. Also, we do not have any problem with Word 2010, it's just Word 2013. >>

  You would not think so, but it still could be.  It boils down to the packet sizes that the operations are using.

 << Also, we do not have any problem with Word 2010, it's just Word 2013. >>

 They may operate differently when dealing with documents, but it does sound like the problem is with Word 2013.

<<It's actually faster to copy the file to desktop, open it, save it,>>

 If you copy it to the desktop and open, is the open normal?

 And we are talking about Office installed locally correct, not Office 365?

Jim.
0
Simple, centralized multimedia control

Watch and learn to see how ATEN provided an easy and effective way for three jointly-owned pubs to control the 60 televisions located across their three venues utilizing the ATEN Control System, Modular Matrix Switch and HDBaseT extenders.

 
LVL 1

Author Comment

by:fkoyer
ID: 39803578
Yes this is Office installed locally. It was pre-installed by Dell.

It opens very quickly from the desktop.

We have SonicWall routers. I will check the MTU setting.
0
 
LVL 57

Accepted Solution

by:
Jim Dettman (Microsoft MVP/ EE MVE) earned 500 total points
ID: 39803720
If your using Windows 7, do the following:

1. Open a elevated command prompt and type:

netsh interface ipv-4 show subinterfaces

The display will show each of your interfaces and the MTU in use for that interface.  Most likely, it will be 1500.

2. Now ping something on the other end of the VPN with the following command:

ping xxx.xxx.xxx.xxx -f -l 1500

which says to use a packet size of 1500.     If you get back a repsonse that says:

"Packet needs to be fragemented by DF set"

 then the MTU is too high for that connection.

3. Keep reducing the packet size on the ping until you get back sucessful replies (try 1450, then 1425, then 1410, 1415 etc to narrow it down).

 Once you have the largest value that works, use that + 28 when setting the max MTU.  So if 1409 was the largest, then your new MTU is 1437

4. Set it in windows by issuing the command:

netsh interface ipv4 set subinterface "<name of interface>" mtu=<new mtu value> store=persistent

The connection names were displayed when you did the first command.  So if it was "Local Area Connection", then:

netsh interface ipv4 set subinterface "Local Area Connection" mtu=1437 store=persistent

5. Reboot the PC.    You can verify the MTU is set by doing the first command again.

By following this, the link will be using the most efficent packet size possible.

There is by the way no harm it doing this.  At worst if you did it wrong, you'd slow things down.    But you can easily set it back if you want.

 Also, I would test a spreadsheet (local vs remote) with Excel and see if you have the same type of delay.  if so, it's most likely the nework.  If not, then it is something in Word.

Jim.
0
 
LVL 1

Author Comment

by:fkoyer
ID: 39804154
Hi Jim,

I did this command:

netsh interface ipv4 show subinterfaces

and it reports the MTU is 1500.

I did this:

ping server -f -l 1500

and it reports:

Packet needs to be fragmented by DF set

Through trial and error I determined that the largest ping that will go through is 1472. However, 1472 + 28 is 1500 which is what the MTU is currently set at.
0
 
LVL 1

Author Comment

by:fkoyer
ID: 39804203
Just for kicks I tried setting the MTU to 1400 but there was no change. I still haven't had time to check the MTU in the routers
0
 
LVL 57
ID: 39804304
<<Through trial and error I determined that the largest ping that will go through is 1472. However, 1472 + 28 is 1500 which is what the MTU is currently set at. >>

 Then your MTU is correct at 1500, packets are not fragmenting, and that is not the problem.

Jim.
0
 
LVL 1

Author Comment

by:fkoyer
ID: 39836996
We haven't really gotten anywhere with this. The time to open documents in Word 2013 has gone down to around 30 seconds but it's still a lot longer than opening them in Word 2010. I guess we are just going to live with it for now. I appreciate all the helpful suggestions though. Is there a way I can assign points without marking the question solved?
0
 
LVL 57
ID: 39838766
umm...probably best to accept your own last comment as answer, then possibly assist points as you feel appropriate.

With that said, since there's no real solution, EE really would like to see the question deleted.   In this case though, there is some good information here for someone with the same problem....at least they'll know what not to try.

Jim.
0
 
LVL 1

Author Comment

by:fkoyer
ID: 39838999
I've requested that this question be closed as follows:

Accepted answer: 0 points for fkoyer's comment #a39836996

for the following reason:

Problem was not really solved but there was good advice given.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This is an article about my experiences with remote access to my clients (so that I may serve them) and eventually to my home office system via Radmin Remote Control. I have been using remote access for over 10 years and have been improving my metho…
If you use NetMotion Mobility on your PC and plan to upgrade to Windows 10, it may not work unless you take these steps.
Learn how to create and modify your own paragraph styles in Microsoft Word. This can be helpful when wanting to make consistently referenced styles throughout a document or template.
This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question