• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1916
  • Last Modified:

Red Hat 6.5 install issue

this is my first experience with the installation of Red Hat Server so I'm a bit lost.  I created a virtual machine and connected to my rhel-server 6.5 ISO.  I went through the install and everything seemed to go great.  At the end it asked for a restart.  Upon restart I am prompted for a user and pw.  After providing the credentials I am left with:


What happened to the GUI login?  did I install with an incorrect iso?
  • 3
  • 2
1 Solution
NytroZAuthor Commented:
Is there an iso that will install the OS with the gui?
Depends, Do you want the server edition, or do you want desktop?  What are you needing it for, is it just personal use?  If so, install Fedora?

Otherwise, i believe during setup you can tell it to install the GUI, but honestly, if you look at that guide i linked, it's very easy to install the GUI, you are already logged in as root!

All you would do is run...

yum groupinstall "X Window System" Desktop


vi /etc/inittab

Which will open an editor and do these steps...

Press the I key to enter insert mode.
Find the line that includes the text initdefault. Change the numeral 3 to 5.
Press ESC Type :wq and press the Enter key to save the file and exit the vi text editor.

You will be back at command line, then type reboot.  You should reboot into a GUI..
Build your data science skills into a career

Are you ready to take your data science career to the next step, or break into data science? With Springboard’s Data Science Career Track, you’ll master data science topics, have personalized career guidance, weekly calls with a data science expert, and a job guarantee.

NytroZAuthor Commented:
I want to use the server version so I will try your solution later.

Thank you
GUI works fine with RHEL.  Did you customize your package selection at the install time?

What is your runlevel?

Issue command
who -r

Did you try run level 5?
Issue command

init 5

As a matter of fact, I am using RHEL 6.5 right now, with beautiful GUI.  There are multiple GUI selections at the install time.  You can select any one or more than one and then switch between them if you like

Also you can check what you installed by seeing install logs

cat /root/anaconda-ks.cfg

Looking at my logs, I find I installed Gnome desktop.
NytroZAuthor Commented:
After I chose the option to install the KDE desktop I thought it was going to resolve my issue but upon reboot I still boot into a command line and not a desktop.  What id I miss?
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now