Solved

One-to-one Nat configuration in Sonicwall Pro 2040 Standard for Terminal Services

Posted on 2014-01-21
5
663 Views
Last Modified: 2014-02-10
Good afternoon-

I'm trying to configure my Sonicwall Pro 2040 Standard for one-to-one NAT to my internal Server. I was provided an additional public IP address from my ISP. I believe I configured the settings on the Sonicwall correctly but I still cannot connect to my server via home using the Public IP Address in MSTSC (RDP).

Please assist if possible.

Thanks.
0
Comment
Question by:rbonds
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
5 Comments
 
LVL 8

Accepted Solution

by:
amatson78 earned 500 total points
ID: 39808957
There are two important things to remember when configuring. One is to setup the NAT, two is to setup the firewall access for the zone. After configuring the NAT and the firewall rule you should be able to access it. Have you checked the logs for your public IP when testing? Sounds like there may be something miss-configured, I would also run a Wireshark Capture on the box you are trying to RDP too and see if by chance the traffic is getting there but blocked by the host OS.

http://www.sonicwall.com/app/projects/file_downloader/document_lib.php?t=TN&id=57
http://help.mysonicwall.com/sw/eng/general/ui1/6600/Advanced/One_to_One_NAT.htm
0
 
LVL 25

Expert Comment

by:Diverse IT
ID: 39811574
Hi rbonds,

Run the Public Server Wizard. It is setup as one of the options for Terminal Server. Select that and follow the onscreen guide. This will setup all the necessary configuration needed. It's located at the top right hand side of the GUI once you login to the SonicWALL.


Let me know how it goes!
0
 

Author Closing Comment

by:rbonds
ID: 39826234
Thank you, It seems as though the host was blocking the connection due to the default gateway. I had to change the default gateway on the host to reflect the sonicwall internal IP Address.
0
 
LVL 8

Expert Comment

by:amatson78
ID: 39826623
Glad to hear its all working now. And thank you for the points. ;)
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Guacamole cut and paste issue 3 120
How to configure this in fortinet firewall 2 94
Printing issues after RDC session 3 44
Cisco ASA 5510 Question 3 10
For some reason Google Apps has decided to reserve 'www' for your new domain which results in an error when trying to map the web address 'www' to a certain site in your Google Sites. The error is 'this address is already being used' and after some …
At the beginning of the year, the IT world was taken hostage by the shareholders of LogMeIn. Their free product, which had been free for ten years, all of the sudden became a "pay" product. Now, I am the first person who will say that software maker…
The purpose of this video is to demonstrate how to set up the WordPress backend so that each page automatically generates a Mailchimp signup form in the sidebar. This will be demonstrated using a Windows 8 PC. Tools Used are Photoshop, Awesome…
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question