Trouble setting SSD drive as default bootup disk on ASUS motherboard

I need to set up my SSD drive as the default bootup drive, so i don't need to select it everytime y start my computer after presssing F3 and changing it on my BIOS

Im using an ASUS motherboard, model: PBH67

I have another hard drive without an OS on it, and several other devices. Please see captures attached of the basic and advanced option menus,

I cant set the SSD as the primary boot up drive, neither in the simple nor in the advanced mode.

what am i doing wrong?
20140122-024603.jpg
20140122-024638.jpg
20140122-024651.jpg
20140122-024937.jpg
20140122-024709.jpg
LVL 1
celticianAsked:
Who is Participating?
 
Gary CaseRetiredCommented:
I suspect "Hard Drive BBS Priorities" is the menu you need -- just put the SSD first in that list and it should then boot fine.

Once that works, then you can enable AHCI as follows:

(1)  Run Regedit and go to HKLM/System/CurrentControlSet/Services
(2)  Open msahci
(3)  On the right side, right-click on Start and select Modify
(4)  Change it to a 0
(5)  Close Regedit

Now change the SATA mode in the BIOS to AHCI and it will boot fine.    If for any reason it does not, you can, as you noted, just change it back and it will be fine -- but there won't be a problem if you change that key first.
0
 
tmx84Commented:
In the picture that ends with 38, you have your SATA Mode Selection set to IDE, I believe this needs to be changed to AHCI for you to be able to choose the SSD for boot.  Only issue is, is more then likely you will need to reinstall the OS after changing this... Hopefully it's already a fresh install where it won't be a big deal! Test it to see first! Hope this helps..
0
 
Gary CaseRetiredCommented:
r.e. the comment on AHCI above ...

It's possible -- but not likely -- that the SATA mode may alter the available choices ... but I don't think that's likely to be the problem.    It is, however, true, that AHCI is a preferable mode for SATA operation.    Do NOT, however, change that unless you're running Windows 7 AND have changed the registry to support AHCI BEFORE you make the change ... otherwise the system won't boot when you modify the setting in the BIOS.

But first, get your boot selection fixed.   In the screen shown in your first picture, there's an elevator control on the right side.   If you drop this down a bit, is there a "Hard Drive Priority" submenu?    If so, you simply need to set the SSD as the first drive.
0
 
celticianAuthor Commented:
I user Windows 7 Professional edition, and i can't afford formatting right as it is fully loaded and not set a recent back up.


What if i change that setting and if it happens to occur that i cant load windows, i switch the setting back to its previous value? Will it work?

garycase: Please see the picture attached for the remaining options that you couldn't see, after i scroll down... it seems they are direct boot override options, but not to set it as default on the BIOS.
20140122-122345.jpg
0
 
celticianAuthor Commented:
I hope i can check tomorrow, i haven't been at home lately :)

Ill be back with the answer.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.