Solved

postfix configuration on centos

Posted on 2014-01-21
5
406 Views
Last Modified: 2014-01-31
Hi:

I have configured a postfix linux server. I can get mail from root to outside email accounts.
My mails from outside world, I don't receive. I have followed the steps from the following links which does not seem to work.

http://www.linux.com/learn/tutorials/308917-install-and-configure-a-postfix-mail-server

  iptables -I INPUT 2 -p tcp --dport 587 -j ACCEPT
  iptables -I INPUT 3 -p tcp --dport 110 -j ACCEPT
  iptables -I INPUT 4 -p tcp --dport 143 -j ACCEPT
  iptables -I INPUT 5 -p tcp --dport 993 -j ACCEPT
  iptables -I INPUT 6 -p tcp --dport 995 -j ACCEPT
  /etc/init.d/iptables save
  /etc/init.d/iptables restart
Also please point me to appropriate mailbox setup. I have a setup of info@mydomain.com

then I don't receive any email for user info from root user or outside world.

Look forward to your comments.

Best Regards,

-Sunnybrad
0
Comment
Question by:sunnybrad
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 33

Accepted Solution

by:
Dave Howe earned 500 total points
ID: 39799412
That is just the firewall settings.
fastest way to discover if you are actually using those ports is the netstat command.

AS ROOT, type at the command prompt "netstat -nap" and look for the keyword LISTEN

that will show you lines like this:
~# netstat -nap | grep LISTEN
tcp        0      0 127.0.0.1:3306          0.0.0.0:*               LISTEN      944/mysqld
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      1317/apache2
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      812/sshd

Open in new window


taking the second output line as an example, that is apache2 (webserver), process id 1317, listening on the universal ip address (0.0.0.0) port 80

ensure you have lines for each of the ports of interest - given normally postfix won't be handling imap etc itself, you would be expecting to see a different process for those (for instance, my imap (143) line is supplied by 816/couriertcpd )
0
 

Author Comment

by:sunnybrad
ID: 39807728
Hi:

I corrected all my firewall settings. I can send mail to outside world but I cannot receive mail from other domains or outside world.

Please let me know any thoughts.

Best Regards,

-Sunnybrad
0
 
LVL 33

Expert Comment

by:Dave Howe
ID: 39807743
Did you check that there is a process listening on port 25? Is there a DNS record or other record pointing at this server?
0
 

Author Comment

by:sunnybrad
ID: 39812669
Hi:

Firewall issue was resolved but I was not seeing the right result.

There was an small configuration issue where all mail to account info was forwarded to postmaster.

Once resolved things worked properly.

Thanks for all your comments.

Best Regards,

Sunnybrad
0
 
LVL 33

Expert Comment

by:Dave Howe
ID: 39813216
odd. about the only way I can think of for that to happen "accidentally" is if there was an alias defined, and I am sure you would have mentioned that :)
0

Featured Post

Online Training Solution

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action. Forget about retraining and skyrocket knowledge retention rates.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Email signatures have numerous marketing benefits. Here are 8 top reasons to turn your email signature into a marketing channel.
Ransomware continues to be a growing problem for both personal and business users alike and Antivirus companies are still struggling to find a reliable way to protect you from this dangerous threat.
This tutorial gives a high-level tour of the interface of Marketo (a marketing automation tool to help businesses track and engage prospective customers and drive them to purchase). You will see the main areas including Marketing Activities, Design …
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …
Suggested Courses

627 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question