NPS SSL Certificate Issue for Windows 7 Wireless Clients

Brand new Windows 7 Enterprise laptops will not connect to 802.1x internal wifi.
I have a GPO that creates the connection profile for the laptops.

I have a DigiCert SSL certificate installed on my NPS server (2008 R2 Enterprise) which is valid until 12/10/2014.  It's selected in the Network Policy under the PEAP (with EAP-MSCHAP v2) configuration.

The certificate was issued by the DigiCert Secure Server CA which is in the Trusted Root Certification Authorities store on the local computer.

As a troubleshooting step I exported the certificate from the NPS server and imported it directly into the Trusted Root CA on one laptop and still was unable to connect.

The event log on the client shows two schannel errors:
Error      1/22/2014 2:37:33 PM      Schannel      36888      The following fatal alert was generated: 45. The internal error state is 552.

Error      1/22/2014 2:37:33 PM      Schannel      36881      The certificate received from the remote server has either expired or is not yet valid. The SSL connection request has failed. The attached data contains the server certificate.

I'm at a complete loss because as far as I can tell the certificate should be trusted.  And as a note the client will not accept clearing the checkbox in the GPO to not check the certificate.

Any ideas?
sovranAsked:
Who is Participating?
 
sovranConnect With a Mentor Author Commented:
I was able to determine root cause of the RADIUS issues with the new Windows 7 machines.  It relates to these MS KB's (http://support.microsoft.com/kb/295663) & (http://support.microsoft.com/kb/2518158) which both show that the builtin Windows wifi supplicant does not automatically trust public CA's for NT authentication.

By running the following command (certutil -dspublish -f C:\digi_global_root_ca.cer NTAuthCA) I was able to set AD to publish the Digicert Root CA as a trusted CA for NT authentication and the three laptops that I've been testing with have connected successfully ever since.
0
 
footechCommented:
Check out the certification path of the certificate.  Perhaps there is an intermediate certificate that needs to be deployed.
Also, if the event contains the cert, can you verify that it is the cert that you think it is?
0
 
Craig BeckCommented:
I think you need to uncheck the 'Validate Server Certificate' option in the PEAP properties page.  You'll find this in the GPO you configured.
0
 
footechCommented:
Thanks for posting back the solution you found.
0
 
sovranAuthor Commented:
Because this fixed the issue without turning off certificate validation.
0
All Courses

From novice to tech pro — start learning today.