[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1639
  • Last Modified:

Protected EAP properties - uncheck validate server certificate

Hello Experts!

Environment:  Windows 7 Enterprise, 64-bit
802.1x authenticated network

Question:

On a client PC, when the Wired AutoConfig (DOT3SVC) service is started, the Authentication tab is added to Local Area Connection properties for 802.1x authentication configuration.

IEEE 802.1X authentication is Enabled.
Authentication Method:  Microsoft: Protected EAP (PEAP) > Settings > Validate Server Certificate is checked.

I would like a command line command that will UNcheck the 'Validate Server Certificate' on a client PC.  I need to do this accross an environment of 10k+ systems, so once I have the command I will deploy the command via SCCM.

What is the command line command to UNcheck this setting?


Thank you!
0
Irrylyn
Asked:
Irrylyn
  • 3
  • 2
1 Solution
 
footechCommented:
If there is one, I'm unaware of it, though you could probably script a change to the registry for this.  This is in effect what a Group Policy setting does, which is what I would recommend to use.  Create a Wired Policy under Computer Configuration > Policies > Windows Settings > Security Settings > Wired Network (IEEE 802.3) Policies, and configure it with the settings you want your clients to have.

However, with proper certificates in place, this wouldn't be necessary.
0
 
IrrylynAuthor Commented:
Shouldn't be necessary.  We switched to computer authentication only and have found lots of machines cant connect if the validate certs is checked.  We don't have our own CA but all of our root certs are on the image and good, so not sure why this is an issue.  Once we uncheck the validate certs, there's no problem connecting.

Probably a config in ACS or something but I'm in desktop, not networking so I just try to do what I can.

I'll take a look at GPO tomorrow and let you know.  Thank you.
0
 
footechCommented:
I'm not familiar enough with switches config to speculate on why some might work and others wouldn't.  But given that unchecking the validate option resolves the issue, really the only reason I can think of that some would work and others wouldn't in this context is that they don't all have the same certificates for the certification path (like missing an intermediate certificate).  That's not to say there might not be other possibilities, I just can't think of them.
0
 
IrrylynAuthor Commented:
Well I've been trying to find a way.  Silly that there isn't one... a reg key or SOMETHING.  Haven't had a chance to look at GPO yet though.  Our place is backa$$words when it comes to managing via GPO.  They hate doing it.  They think we should manage everything through SCCM.  I personally think GPO should be used more, but I'm not the boss  :)

Thanks for the suggestion and I may start pushing for it.  For now, to please the paycheck, I'm exporting a LAN profile that's set the way I want it then going to push a .bat file that imports it into each client via SCCM.
0
 
footechCommented:
Only way that I can think of to find the actual registry location would be to look at the .ADMX files and trace it back from there.  But if you have a solution with an exported LAN profile then it's probably not worth the effort for you.
0

Featured Post

The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now