Solved

Added Cisco ASA 5505 ipsec vpn - connects but one allow access to network behind the firewall.

Posted on 2014-01-22
4
705 Views
Last Modified: 2014-02-05
I installed a cisco asa 5505, I was able to create a ipsec vpn and can connect to the vpn using the cisco client. I am not however able to access the network behind the firewall once I am connected. I am have tried connecting from two different remote locations. I have tried adding NAT rules and ACLs, and am not making any headway. Here is the show run from the device. Thanks in advance for anyone who can help me.

Result of the command: "show run"

: Saved
:
ASA Version 8.4(2)
!
hostname DMRTR2
domain-name dm.local
enable password hu6uTeAce/s09pLk encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 172.30.21.2 255.255.0.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 74.94.154.129 255.255.255.0
!
interface Vlan5
 shutdown
 no nameif
 security-level 50
 ip address 172.16.1.15 255.255.255.0
!
boot system disk0:/asa842-k8.bin
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns domain-lookup outside
dns server-group DefaultDNS
 name-server 172.30.20.10
 name-server 172.30.20.11
 name-server 8.8.8.8
 name-server 8.8.4.4
 name-server 4.2.2.2
 domain-name dm.local
object network obj_any
 subnet 0.0.0.0 0.0.0.0
object network NETWORK_OBJ_172.30.0.0_16
 subnet 172.30.0.0 255.255.0.0
object network NETWORK_OBJ_192.168.126.0_24
 subnet 192.168.126.0 255.255.255.0
access-list DATAMANN_splitTunnelAcl standard permit 172.30.0.0 255.255.0.0
access-list inside_access_in extended permit ip object NETWORK_OBJ_192.168.126.0_24 any
pager lines 24
logging enable
logging asdm informational
logging from-address Monitoring@datamann.com
logging recipient-address Monitoring@datamann.com level alerts
mtu inside 1500
mtu outside 1500
ip local pool VPNPOOL 192.168.126.1-192.168.126.254 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
asdm image disk0:/asdm-645-204.bin
no asdm history enable
arp timeout 14400
nat (inside,outside) source static NETWORK_OBJ_172.30.0.0_16 NETWORK_OBJ_172.30.0.0_16 destination static NETWORK_OBJ_192.168.126.0_24 NETWORK_OBJ_192.168.126.0_24 no-proxy-arp route-lookup
!
object network obj_any
 nat (inside,outside) dynamic interface
!
nat (inside,outside) after-auto source dynamic any interface
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 74.94.154.134 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 172.30.0.0 255.255.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto ikev1 enable outside
crypto ikev1 policy 10
 authentication crack
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 20
 authentication rsa-sig
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 30
 authentication pre-share
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 40
 authentication crack
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 50
 authentication rsa-sig
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 60
 authentication pre-share
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 70
 authentication crack
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 80
 authentication rsa-sig
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 90
 authentication pre-share
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 100
 authentication crack
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 110
 authentication rsa-sig
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 120
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 130
 authentication crack
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 140
 authentication rsa-sig
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 150
 authentication pre-share
 encryption des
 hash sha
 group 2
 lifetime 86400
telnet timeout 30
ssh 172.30.0.0 255.255.0.0 inside
ssh 172.30.7.39 255.255.255.255 inside
ssh timeout 30
console timeout 30

dhcpd auto_config outside
!
dhcpd address 172.30.72.100-172.30.72.110 inside
!
no threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy DATAMANN internal
group-policy DATAMANN attributes
 wins-server value 172.30.20.10 172.30.20.11
 dns-server value 172.30.20.10 172.30.20.11
 vpn-tunnel-protocol ikev1
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value DATAMANN_splitTunnelAcl
 default-domain value dm.local
username admin password bADVrF8mvIY1x7FM encrypted privilege 15
username datamann password YSM5wQ2GqdH3dHQg encrypted privilege 15
tunnel-group DATAMANN type remote-access
tunnel-group DATAMANN general-attributes
 address-pool VPNPOOL
 default-group-policy DATAMANN
tunnel-group DATAMANN ipsec-attributes
 ikev1 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
smtp-server 172.30.20.96
prompt hostname context
no call-home reporting anonymous
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:6523e4730cb71724186f164a1234ab2e
: end
Cisco.ASA.Config.txt
0
Comment
Question by:Captjack5169
  • 3
4 Comments
 
LVL 28

Expert Comment

by:asavener
ID: 39824323
Try this:

no nat (inside,outside) source static NETWORK_OBJ_172.30.0.0_16 NETWORK_OBJ_172.30.0.0_16 destination static NETWORK_OBJ_192.168.126.0_24 NETWORK_OBJ_192.168.126.0_24

nat (inside,outside) 1 source static any any destination static NETWORK_OBJ_192.168.126.0_24 NETWORK_OBJ_192.168.126.0_24

Reference:  https://supportforums.cisco.com/docs/DOC-11639
0
 

Author Comment

by:Captjack5169
ID: 39836767
I recently rebuilt the configuration hoping to come out on top. I spoke with another CCNA at another business who seems to believe having us having mulitple gateways on the same subnet is the issue. Let me lay it out. We have three comcast lines coming in plus one T1 line. Two of the comcast and the T1 are on Sonic Wall Firewalls. I tried using a different subnet and natting my self into the network. Same thing happened I can't talk to anything on the network.
0
 
LVL 28

Accepted Solution

by:
asavener earned 500 total points
ID: 39836842
Forgot to mention running clear xlate after you make the change above.


Any device on the 172.16.0.0/16 subnet has to have a route to the 192.168.126.0/24 subnet, using your ASA as the next hop.

Usually, this occurs by default, because the ASA is the default gateway for the subnet.  If the ASA is not the default gateway, you either have to add a route on each node, or add a route on the default gateway router.  

(Note:  If the default gateway is another firewall, and not a router, you may encounter other issues.)
0
 
LVL 28

Expert Comment

by:asavener
ID: 39836846
If you can find an unused range in the 172.16.0.0/24 subnet, then you can use that as your VPN pool.  Then the routing issues go away.
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

As you can read I recycle all my old hardware and the time has come that my power supply of 200 Watt cannot provide enough power for my backup server. I have lots of Compaq power supply's laying around, so I figured to use one of these PSU's. I t…
Envision that you are chipping away at another e-business site with a team of pundit developers and designers. Everything seems, by all accounts, to be going easily.
This video discusses moving either the default database or any database to a new volume.
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now