How to avoid frequent paging on a Red Hat Linux System

Hi,

We have a 2TB RAM Machine running Red Hat Linux 6.3 and we are seeing lots of pagefaults. Please see below

Now I am wondering how to avoid this as we are currently using at Max 1TB of RAM on any day.

How can we avoid excessive paging, page faults etc. The machine also has 2.1TB of SSDs in there

The main process we run on the machine is MSTRSvr and that't the only major application running on this host. The machine is dedicated for MSTRSvr

putty_output

sar_output_paging
anshumaEngineeringAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
gheistConnect With a Mentor Commented:
Page fault is not paging

Page fault means that TLB was re-programmed
You can reduce load on TLB by religiously using hugepages/superpages/largepages in all places where supported. Anonhugepages are already on in your kernel

You can even do this in situations where it is not supported http://oss.linbit.com/hugetlb/

Cgroups can swap runaway processes out...
0
 
Duncan RoeSoftware DeveloperCommented:
Please re-run sar with the addition of -b option. The reported page faults may not be resulting in real disk i/o
0
 
anshumaEngineeringAuthor Commented:
here it is

output with -b switch
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
Seth SimmonsConnect With a Mentor Sr. Systems AdministratorCommented:
looking at your top output, 2tb ram and 64mb of swap space used is very low

you start seeing performance degradation when swap usage is more consistent

you could adjust your swappiness setting so that it would be much less aggressive in swapping out memory pages and would keep in physical memory.  with 1.2tb in file cache, i don't see this being a problem.  by default (value is 60) it will swap out memory pages that haven't been touched for a while so what i see here isn't of any concern but can understand how you don't want to see swap file touched in the first place with that much physical memory

add swappiness = 0 in /etc/sysctl.conf for permanent change; echo 3 > /proc/sys/vm/swappiness for immediate
0
 
Duncan RoeConnect With a Mentor Software DeveloperCommented:
You can actually turn swap  off. I have 8GB RAM and don't use swap.
It seems to me unlikely that the writes reported from 11:40 to 12:00 can be to the paging disk, otherwise it would have grown in size.
%vmeff remains resolutely at zero, which means no pages are being scanned (there are always enough available).
0
 
Gerwin Jansen, EE MVEConnect With a Mentor Topic Advisor Commented:
Hi, nice system you have there ;)

Do you experience any performance issues between approx. 11:50 and 12:00?

From your SAR output you can see there is (probably scheduled) load in that time frame. What is the CPU load at that time? Your first screenshot shows just 2.3% CPU.
0
 
anshumaEngineeringAuthor Commented:
Yes we did see performance issues at that time, but our CPU is never very stressed. I will try to get more information for you. Can you tell me the exact SAR command for this time period.
0
 
anshumaEngineeringAuthor Commented:
thanks experts
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.