Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 278
  • Last Modified:

NTFS permissions issue

Hi I have a server with a folder that when users put files in it the files don't have the users group added to the permissions of that file only the creator and admin group  is added.  I have inherit permisisons turned off and tried it turned on and have the users group with full access to this folder.  When I manually "replace all child object permissions"  it does apply the users group to all files in this folder but when a new file gets created the user group is not part of the permissions of that newly created file.   Any idea on what I need to change  for permissions on this folder to allow the user group to be part of permissions on newly created files?

This is server 2008 R2.  No domain.
0
nologytech
Asked:
nologytech
1 Solution
 
Rich WeisslerProfessional Troublemaker^h^h^h^h^hshooterCommented:
Just to eliminate the 'easy' possibilities:
Confirm that you are creating a new file, and not copying/moving a file into the folder from another directory on the same volume.  (Just to make triple certain, open up notepad with a blank file, and safe the file in that directory... confirming that the expected permissions aren't being inherited.)  MS Office and other office productivity products are notorious for moving/renaming files (especially hidden files) rather than making new files.  In many cases, it to protect the contents... but it can make troubleshooting file permissions when the directory permissions are changing... challenging.

And it sounds like you've been making several changes to this folder permissions recently.  Take a step back... and test the behaviour in a different, unrelated folder.  Create a new empty folder with the permissions you want to be inherited, and try creating a new file there, and check to make certain it receives the permissions you expect.  

The good news is that it sounds like you're already approaching the problem well.  Unfortunately, that's also the bad news.  There's an assumption being made, or some piece of information missing.  If neither of the 'easy' approaches, I think you need a fresh set of eyes.  Again, two ways to get'em.  (1) Step away from the problem for an hour... get some food, and approach the problem as if someone brought the problem to you and start at the top and confirm all the assumptions.  (2) Option two, grab some screen shots and redact anything you don't want folks to see.  Start with the directory structure, and contents of the folder.  Then get the permissions screens.
0
 
nologytechAuthor Commented:
Thanks I disabled all inheritance and set the user group as owner and now its working.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Tackle projects and never again get stuck behind a technical roadblock.
Join Now