Solved

Network Printer problem

Posted on 2014-01-23
8
726 Views
Last Modified: 2014-01-23
Having a strange problem with a new network printer. We got it gave it an IP installed the drivers on the server, shared it and connected the workstations and at first it worked. Now 2 days later if I print to it the app (any app) it stalls for 5-6 min and then eventually does print. On the server if I right click on that printer and select printer properties it does open but again after 5-6 min. Other printers I can access fine. I have done the standard things deleted and readded it to the server. When I re add it it takes 10 min of 'installing printer' I can add other printers in 30 sec. So thinking maybe its a server problem I try and install the printer locally to a few PC's. With the driver installed it still takes 10 min of 'installing printer' and then installs. From there if I right click on it to adjust the trays etc it takes 5 min for that right click menu to open. I can put in the printers IP in the browser and it connects instantly. But anything else theres an extreme delay. is there anything I haven't checked beyond just having a bad printer?
0
Comment
Question by:Axis52401
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 17

Expert Comment

by:pjam
ID: 39803682
Are you using 32-bit & 64-bit drivers?  If so they must be the same version, for example:
PCL6 version 5.65
0
 
LVL 2

Author Comment

by:Axis52401
ID: 39803686
all 64, we have a few 32 bit PC's but I did those locally on those PC's. And I'm having the same problem either connecting to the shared printer on the server or if I install the driver locally on the PC.
0
 
LVL 95

Accepted Solution

by:
John Hurst earned 500 total points
ID: 39803709
We got it gave it an IP installed the drivers on the server, ....
I can put in the printers IP in the browser and it connects instantly


Have you got an IP conflict of some kind?  Is the IP Static?  That is, not inside your DHCP scope.

... Thinkpads_User
0
Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

 
LVL 2

Author Comment

by:Axis52401
ID: 39803712
No no other device using that IP, I checked, its static and outside the scope
0
 
LVL 95

Expert Comment

by:John Hurst
ID: 39803725
Since you have tried installing the printer again on the Server and Locally and since you are fairly sure IP conflicts are not an issue, then I suggest you try restarting the Server as the next step (tonight or tomorrow).

.... Thinkpads_User
0
 
LVL 95

Expert Comment

by:John Hurst
ID: 39803763
One thing I do for Windows 7 is the following:

Go to Devices and Printers, Add Printer, Local, Existing Connection, Next. Now see the Windows Update button beside Have Disk. Run Windows Update. This takes a while. Cancel out and restart without installing anything.

Now try installing locally on the Windows 7 machine again.

On a Windows 7 machine I have here, I do not see the Xerox 4250 printer, so Windows may not have yet updated it.

Another thing to try on a local machine is to remove the printer, click on another printer to open the sub menu, go to the Drivers tab and remove (delete) the Xerox driver.

Now restart and try installing locally again. Map the IP of the printer after installation.

.... Thinkpads_User
0
 
LVL 13

Expert Comment

by:Michael Machie
ID: 39804041
As a former Xerox Analyst who has installed hundreds of these devices the first thing to check is
whether or not you are using DNS name or IP address for the print driver. I always use the IP address when possible and this will help you identify a DNS issue with the device as DNS problems will cause massive delays or even failures. Also, make sure your gateway is proper as this can be the cause too.

Also check your Network Speed setting. Make sure you are at Auto. If you are at auto, back down the speeds to 10m half duplex and test. If the same, change it to 10meg Full, then 100meg half, then 100m full.

I have also seen issue with PoE on the switch port feeding the 4250 also cause an issue with data transfer as the 4250s do not like PoE.

These are three of the main reasons I have seen this occur in the past. If one of these does not solve the problem let us know.

I love those little 4250s, fast as heck in a small package.
0
 
LVL 95

Expert Comment

by:John Hurst
ID: 39804524
@Jason0923 - Thanks, and I trust it is all working now.

.... Thinkpads_User
0

Featured Post

Creating Instructional Tutorials  

For Any Use & On Any Platform

Contextual Guidance at the moment of need helps your employees/users adopt software o& achieve even the most complex tasks instantly. Boost knowledge retention, software adoption & employee engagement with easy solution.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When I recently replaced my image transfer kit on my office HP color laserjet 5550dn printer, I had a slight problem.  The left bracket that holds the transfer kit got stuck in the upright locked position instead of being at a 45 degree angle facing…
We recently endured a series of broadcast storms that caused our ISP to shut us down for brief periods of time. After going through a multitude of tests, we determined that the issue was related to Intel NIC drivers on some new HP desktop computers …
In an interesting question (https://www.experts-exchange.com/questions/29008360/) here at Experts Exchange, a member asked how to split a single image into multiple images. The primary usage for this is to place many photographs on a flatbed scanner…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question