Solved

WDS on Windows Server 2012 PXE errors

Posted on 2014-01-23
22
7,187 Views
Last Modified: 2014-02-27
I setup the WDS on server 2012 and it also has dhcp service running with no scopes setup yet.

When I try to pxe boot a laptop it gets to PXE-E55 Proxydhcp service did not reply to request on port 4011.

PXE-MOF Exiting Intel Boot Agent
Selected boot device failed . Press any key to reboot.

There is no 60,67 options in the DHCP server
0
Comment
Question by:AGenAdmin
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 9
  • 3
22 Comments
 
LVL 51

Expert Comment

by:Netman66
ID: 39806203
If you have no scopes, what is the server going to respond with?  You need a scope to assign IPs to the client.

You probably need option 60, but test it with a scope first.
0
 

Author Comment

by:AGenAdmin
ID: 39806814
Added the 60 option to the dhcp server and still get the Proxy Dhcp did not reply  to request on port 4011

pxe m0f exiting intel boot agent.  The laptop does get a valid ip from the dhcp server
0
 
LVL 51

Expert Comment

by:Netman66
ID: 39806862
Is your wds server pxe role working?
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:AGenAdmin
ID: 39807039
Were using server 2012 and windows deployment workbench to deploy endpoints with windows 7
0
 
LVL 51

Expert Comment

by:Netman66
ID: 39807073
OK, but if you don't have a PXE service running there is no PXE booting going to happen.
0
 
LVL 16

Expert Comment

by:vivigatt
ID: 39807078
Check my article:

http://www.experts-exchange.com/Networking/Misc/A_2978-PXEClient-what-is-it-for-Can-I-use-PXE-without-it.html

AFAIK, PXE-E55 Proxydhcp service did not reply to request on port 4011 means that the PXE client received a DHCP answer with Option 60 set to "PXEClient", which indicates that it must send "PXE" requests to UDP port 4011 on the same server that runs DHCP service, and thus that the PXE service MUST run on this server and be bound to UDP 4011.
If your PXE service runs on another host than the DHCP server, then you must NOT set dhcp Opt 60. Then, the PXE service will get DHCP DISCOVER packets sent by the client on standard DHCP port to broadcast address and will add its magic PXE sauce to the DHCPINFORM packets that the client receives.
IOW: if your PXE and DHCP servcie do not run on the same host, no DHCP opt 60.
Furthermore:
if you have a true PXE SErvice, no DHCP OPT 66 or 67 (PXE service role is exactly to provide this information, dynamically).
If your clients and DHCP/PXE servers are not on the same subnet, you need to setup a dhcp-relay/ip-helper so that dhcp broadcasts sent by clients are forwarded to the correct dhcp/pxe server(s).
If you have all that checked, then you may have a PXE issue. Check for PXE/BIOS updates for your clients.
0
 

Author Comment

by:AGenAdmin
ID: 39807660
I removed the dhcp role off the server that hosts the WDS and have the dhcp boxes now unchecked under the Windows deployment services server options.

I also checked to be sure the option 60 is removed off the remote dhcp server.

Same issue when pxe booting the laptop so I then started the wds workbench from scratch to start over and no luck
wds.PNG
wds1.PNG
0
 
LVL 16

Expert Comment

by:vivigatt
ID: 39811907
You MUST authorize this WDS server in AD. This is not the same as assigning a DHCP role to your WDS server. WDS/PXE SErvices are using the same ports (bootpc, UDP 68) as the DHCP servers (unless they are running on a host that already runs DHCP/BOOTP service).
0
 

Author Comment

by:AGenAdmin
ID: 39812100
Set authorize wds server in AD and now when I boot a laptop Im seeing PXE-E53 - No boot filename received.
0
 
LVL 16

Expert Comment

by:vivigatt
ID: 39812183
MUCH better.
Now you have your DHCP/PXE system working, at least for the first phase.

Check that you DO NOT have any of the DHCP option 60, 66 nor 67

Check that WDS/PXE is configured to serve your clients.
0
 

Author Comment

by:AGenAdmin
ID: 39812651
Checked and have no options on dhcp server for 60, 67,66. Checked and the pxe is set to serve both known and unknown clients
pxe-tab.PNG
boottab.PNG
dhcptab.PNG
0
 
LVL 16

Expert Comment

by:vivigatt
ID: 39812668
This config seems OK to me.

Have you restarted the WDS server?

Isn't there another WDS/PXE server on your network?
Are the WDS server and clients on the same subnet? If not, you need to set a DHCP-relay/ip-helper.

Can you run a packet monitor (Wireshark or MS Netmon), filter on UDP 67 and 68 and send the captured packets?
0
 

Author Comment

by:AGenAdmin
ID: 39812759
Just restarted the wds server and this is the only WDS server active on our network same subnet.

On the WDS event viewer I see this under operational however I still get the No boot filename received on the laptop.

 An endpoint was opened by provider WDSPXE.

Type: UDP
Address: 4011
0
 
LVL 16

Expert Comment

by:vivigatt
ID: 39813262
could it be that the WDS/PXE server is bound only to UDP 4011?

Easy to check. Run the following command on the server:
netstat -ba -p UDP -n

you should see a list of connections.
There should be one line ending with :4011 (proxy DHCP) and another line ending with :67  (bootps, the port that DHCP/BOOTP/PXE services are bound to).

Can you copy these lines, each one along with the line just below which states the exe name that created the binding?
0
 

Author Comment

by:AGenAdmin
ID: 39815065
See document attached
could-it-be-that-the-WDS.docx
0
 
LVL 16

Expert Comment

by:vivigatt
ID: 39815104
WDS server is correctly bound to UDP 67 (DHCP server), UDP 69 (TFTP server) and 4011 (ProxyDHCP server).
Please check any firewall/access rule, on the server or on the switch/routing device(s).
Also try to grab WDS logs if you can.
You may also do a simple test: connect a laptop to the cable that your client is usually using, check that you get an IP address and that you can ping the WDS server.

If nothing works, a packet trace will help us identifying the issue, if seems that the client does not receive boot file information. You can also double check the DHCP option( server option, scope option, reservations etc).
0
 

Author Comment

by:AGenAdmin
ID: 39815500
This is the only error I see under event viewer Deployment services

[WDSServer] [base\eco\wds\wdsmgmt\src\wdsdirectoryservicesusepolicy.cpp:295] Expression: , Win32 Error=0x2
0
 
LVL 16

Expert Comment

by:vivigatt
ID: 39815570
No reference to this error anywhere I could find.
Win32 error 2 is "file not found". It must refer to "directory service use policy" and certainly tells us that the WDS does not use any AD policy. I don't think this is a real error.

Please run the ping test. I think it will succeed, but it is worth checking.

Then, well, a packet capture might be the best tool for me to help you.
0
 

Author Comment

by:AGenAdmin
ID: 39815971
rename to .pcapng
testcapture.txt
0
 
LVL 16

Expert Comment

by:vivigatt
ID: 39818109
The capture was captured on the WDS server right?
it does NOT receive any of the DHCP broadcast that the client sends, thus it does not answer...

Have you checked access rules on the switches, firewall etc? DHCP snooping maybe?

A test to consider would be to connect a client and the WDS server to the same switch as the DHCP server and see if this is any better.
0
 

Author Comment

by:AGenAdmin
ID: 39854439
Im thinking it is due to the wds server being on Server 2012 and the dhcp server on 2008 but may be wrong. Going to start fresh and follow everything to a t and see if this works
0
 
LVL 16

Accepted Solution

by:
vivigatt earned 500 total points
ID: 39854815
Nope, this is not a problem of this kind. Your WDS/PXE server does NOT receive the DHCPDISCOVER messages from the clients that are the start of everything in PXE boot process.
If your WDS server is not on the same subnet as the clients, you must configure a DHCP-RELAY (ip-helper address in Cisco word) so that the DHCP packets sent to broadcast address by the clients are forwarded to your WDS server.
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you're not part of the solution, you're part of the problem.   Tips on how to secure IoT devices, even the dumbest ones, so they can't be used as part of a DDoS botnet.  Use PRTG Network Monitor as one of the building blocks, to detect unusual…
Most of the applications these days are on Cloud. Cloud is ubiquitous with many service providers in the market. Since it has many benefits such as cost reduction, software updates, remote access, disaster recovery and much more.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

710 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question