Solved

Need help getting Xorg.conf dual head configured

Posted on 2014-01-24
15
1,016 Views
Last Modified: 2014-02-18
Hi Guys,

Having some challenges getting Xorg.conf sorted.

Everything was fine, then I installed an nVidia geforce 6200 card that I had from a previous build and installed kmod-nvidia from elrepo - hell then broke loose.

Did some tinkering with a generic xorg.conf and get one monitor working "screen 0" (Connected on VGA), the other - "Screen 1" (connected on VGA) just has flashing cursor. I'm not sure what modules to load in xorg.conf.

Running 2.6.32-431.3.1.el6.x86_64 kernel on 8gb ram and i5 quad core processor.

Another thing that has gone wrong is that when I try to watch video in VLC  CPU usage jumps to 100% but the video is blotchy and I'm forced to kill it.


OUTPUT OF: xrandr

Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 8192 x 8192
VGA-0 connected 1280x1024+0+0 338mm x 270mm
   1280x1024      60.0 +   75.0*
   1152x864       75.0  
   1024x768       75.1     60.0  
   800x600        75.0     60.3  
   640x480        75.0     60.0  
   720x400        70.1  
HDMI-0 disconnected
DisplayPort-0 disconnected
HDMI-1 disconnected
DisplayPort-1 disconnected



OUTPUT OF: lspci | grep vga

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
07:00.0 VGA compatible controller: NVIDIA Corporation NV44A [GeForce 6200] (rev a1)

xorg.conf & Xorg.0.log attached.
Xorg.0.log
xorg.conf.txt
0
Comment
Question by:bimrock
  • 9
  • 4
  • 2
15 Comments
 
LVL 14

Accepted Solution

by:
ThomasMcA2 earned 162 total points
Comment Utility
Hmmm, I can't help with the driver issue, but maybe the wrong settings in xorg.conf is breaking things. So try this:

1) Rename xorg.conf. It is not needed for default settings.
2) Connect your 2nd monitor.
3) Run xrandr (without any parms) to see the device names
4) To enable the 2nd monitor, run an xrandr command like this (using your device names)

xrandr --output VGA-0 --auto --output VGA-1 --auto --right-of LVDS

Remember to change VGA-1 to the 2nd device name returned from the xrandr command.

The --auto switch tells xrandr to use the default resolution for that device. I have had pretty good results with no xorg.conf and the --auto switch.

The above xrandr command even works for me at work when connecting to various overhead projectors.
0
 

Author Comment

by:bimrock
Comment Utility
Ok Thanks, will give this a try.
0
 

Author Comment

by:bimrock
Comment Utility
Ok so I tried the suggestion and here are the results:

When I run with no xorg.conf file the display appears fine until I login to the desktop and then all of the icons and text are upside down.

Interesting enough the xrandr command only locates 1 monitor so part of this may be a driver issue.

The output from xrandr is:
Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 8192 x 8192
VGA-0 connected 1280x1024+0+0 338mm x 270mm
   1280x1024      60.0 +   75.0*
   1152x864       75.0  
   1024x768       75.1     60.0  
   800x600        75.0     60.3  
   640x480        75.0     60.0  
   720x400        70.1  
HDMI-0 disconnected
DisplayPort-0 disconnected
HDMI-1 disconnected
DisplayPort-1 disconnected
0
 
LVL 14

Expert Comment

by:ThomasMcA2
Comment Utility
Does the nVidia D/L page have your driver?
0
 

Author Comment

by:bimrock
Comment Utility
Apparently not... I tried installing the linux X64 (AMD/EM64T) Display driver version 325.15 which does not work with my GPU so I reverted to the 304.1190 version and it worked after I killed xvnc (had to run in runlevel 3 so X was not running). It ran to completion, however on reboot it now identifies my card as VGA1 but still doesn't recognise the nVidia card.

The thing is that I know the monitor is working for sure and I am assuming that the nVidia card is still working as the BIOS picks it up and uses it to display the POST info before it switches to the onboard VGA...
0
 
LVL 61

Assisted Solution

by:gheist
gheist earned 163 total points
Comment Utility
nvidia driver is not friend of original xorg drivers
try removing nvidia driver and using nouveau.

Both drivers will work perfectly, just DELETE xorg.conf for auto-detection to work
http://nouveau.freedesktop.org/wiki/FeatureMatrix/
0
 

Author Comment

by:bimrock
Comment Utility
Will give that a try was using nouveau before and got no love though so blacklisted it to try the nvidia... Linux is a horrible mistress.
0
Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 61

Expert Comment

by:gheist
Comment Utility
Nope, everything just works out of the box...

You need vdpau capable player to get kicks from HD2000 or nouveau... (not vlc, more like mplayer & co)
0
 

Author Comment

by:bimrock
Comment Utility
Sorry for the delay guys (had some other fires to put out), tried everything but got no love from the Nvidia so I found an old ATI Radeon which the is recognised but now I am not seeing the onboard card... will have a go at that shortly...

the output of lspci | grep VGA now gives:

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV610 [Radeon HD 2400 PRO/XT]
0
 

Author Comment

by:bimrock
Comment Utility
Hi Guys,

So here's what I ended with:

Disabled onboard intel card
Used AMD ATI Radeon HD 2400 which give two VGA outputs - which incidentally is recognised by Centos 6.5 native.

xrandr now gives:

Screen 0: minimum 320 x 200, current 2560 x 1280, maximum 8192 x 8192
DIN disconnected (normal left inverted right x axis y axis)
DVI-0 connected 1280x1024+1280+0 (normal left inverted right x axis y axis) 338mm x 270mm
   1280x1024      60.0*+   75.0  
   1152x864       75.0  
   1024x768       75.1     60.0  
   800x600        75.0     60.3  
   640x480        75.0     60.0  
   720x400        70.1  
DVI-1 connected 1024x1280+0+0 left (normal left inverted right x axis y axis) 338mm x 270mm
   1280x1024      60.0*+   75.0  
   1152x864       75.0  
   1024x768       75.1     60.0  
   800x600        75.0     60.3  
   640x480        75.0     60.0  
   720x400        70.1  


Thanks so much for all your help.
0
 

Author Closing Comment

by:bimrock
Comment Utility
Ultimately the troubleshooting steps helped me to understand the problem more and get to a conclusion - Nvidia cards are more stress than profit. Just use Intel / AMD.
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
elrepo.org have the "latest" driver repository
Maybe all cards work at once...
0
 

Author Comment

by:bimrock
Comment Utility
Thanks.
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
Not really that cards are bad. nvidia driver replaces opengl libraries, so it cannot work with other xorg drivers. Radeon on the other hand is well supported by xorg-s drivers.
0
 

Author Comment

by:bimrock
Comment Utility
Ahh... noted.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

After running Ubuntu some time, you will be asked to download updates for fixing bugs and security updates. All the packages you download replace the previous ones, except for the kernel, also called "linux-image". This is due to the fact that w…
If you use Debian 6 Squeeze and you are tired of looking at the childish graphical GDM login screen that is used by default, here's an easy way to change it. If you've already tried to change it you've probably discovered that none of the old met…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now