Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

SSRS Report Crashes

Posted on 2014-01-24
8
Medium Priority
?
603 Views
Last Modified: 2014-02-01
Hi,

I have created an SSRS report that requires a lot of parameters (basically it is a report that allows its users to search by everything... nearly)

The report has about 50 parameters.

When I open the report in IE it looks like:
Report
I enter the mandatory parameters and then click on "View". Once the report has rendered I then click on the >> pointing up to hide the parameters so that the report is visible. If I then click the >> to show the parameters again and then Internet Explorer hangs and becomes unresponsive.

Please could someone help with this as I really need to deploy the report.

I have checked the Show\Hide parameter feature using other reports (with far less parameters) and it works OK.

Thanks, Greg
0
Comment
Question by:spen_lang
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 2
8 Comments
 
LVL 22

Expert Comment

by:Nico Bontenbal
ID: 39808499
I'm afraid you'll have to experiment a bit with reducing the number of parameters and see if the report start working with a certain number of parameters. Could also be that some of the drop down parameters have a lot of values and dropping one or two of those might also solve  your problem.

Then the next challenge is to find a way to get the report working with less parameters. Maybe you can all the 'like' and 'not like' parameters into a few parameters. In the first parameter you select the field (Account, Col Add1, Col From etc.) In the second parameter you select the type of search (Like/Not like) and the third parameter is the value. Might even be possible to do the same for the in parameters. Maybe you can reduce the number of parameters this way.

Another option might be to split the parameters over two reports. The first report could have only the parameters that are enabled in your screenshot. When the user runs this report only a line is shown in the report that says how many records are found. The user can click this line to go to a second report that has the other parameters. But you pass the 'original' parameters as hidden parameters to this second report.

Also you could check if the report works in other browsers. That way you can find out if it is a browser or a server problem.
0
 
LVL 27

Expert Comment

by:planocz
ID: 39809370
It would be better to have a set of reports to fit the catagory that you want to stay in.
You will have fewer parameters and a lot happier users who will be using the reports.
0
 

Author Comment

by:spen_lang
ID: 39811323
I have tried the report in Chrome and Firefox but these browsers do not give the ability to hide/unhide the parameter lists. The problem only exists when I run the report and then hide the parameters and then unhide the parameters again.

The point of this report is to allow the users to search by everything so that they can find what they need, so I am unable to reduce the amount of parameters by creating several reports.
0
Use Case: Protecting a Hybrid Cloud Infrastructure

Microsoft Azure is rapidly becoming the norm in dynamic IT environments. This document describes the challenges that organizations face when protecting data in a hybrid cloud IT environment and presents a use case to demonstrate how Acronis Backup protects all data.

 

Author Comment

by:spen_lang
ID: 39811324
I have removed the "available" values for the multi-value parameters and this has not made a difference.
0
 

Author Comment

by:spen_lang
ID: 39811419
The problem seems to occur if the list of parameters go out of view and a vertical scroll bar is required to view the parameters. If I reduce the amount of parameters down to 48 then all the parameters fit on my screen (1920x1080) without vertical scroll bars. The problem does not occur.

But, if I run the report on a different PC using a resolution of 1661x942 then the parameter list requires a vertical scroll bar to see all parameters. If I hide\unhide the list then IE crashes.
0
 

Accepted Solution

by:
spen_lang earned 0 total points
ID: 39811845
OK, it does not seem to be a parameter issue.

The problem was within the tablix header, I had set the column headers to "keep header visible while scrolling" by setting the "FixedData" property of the Row Groups to "True". Although this method works for some reason when I hide/unhide the parameter list in IE (tried different versions) it caused IE to crash. I have now set the "FixedData" property to "false" and the report is now functioning correctly allowing me to hide and unhide the parameter list (although I have lost the functionality of scrolling headers).
0
 
LVL 22

Expert Comment

by:Nico Bontenbal
ID: 39811911
Good to hear you (kind of) solved your problem. Sorry I couldn't be of any assistance.
0
 

Author Closing Comment

by:spen_lang
ID: 39826050
Worked it out myself
0

Featured Post

Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Large Outlook files lead to various unwanted errors and corruption issues. Furthermore, large outlook files can also make Outlook take longer to start-up, search, navigate, and shut-down. So, In this article, i will discuss a method to make your Out…
Many people use more than one email account and so it becomes difficult for them to manage them when they use separate accounts,  so, in this article, I have shared an easy way to add Other Mail Accounts in your Google Inbox. It helps to combine all…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…

704 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question