?
Solved

Slow internet after migration

Posted on 2014-01-24
8
Medium Priority
?
403 Views
Last Modified: 2014-01-24
I have just installed a new windows 2008 server and migrated a small peer to peer network of 5 workstations running windows 7 enterprise. The server is attached to a router and the rest of the network using a gigabit switch. I have run dcpromo on the server and set up the dhcp server. The server has a set ip of 192.168.1.20 The ip scope has been set as 192.168.1.20 -  254. The router Dhcp is set to start from 192.168.1.100 so this range has been reserved on the Dhcp server to avoid conflicts. The gateway is set as the router address 192.168.1.1 and the dns on the server and the workstations is set to the server IP.
Since implementing this, the internet has slowed considerably - any ideas on how to fix this please?
0
Comment
Question by:dobby69
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +1
8 Comments
 
LVL 97

Expert Comment

by:Experienced Member
ID: 39807665
How fast is Internet on the Server with no Workstations attached?  That is, is this a server problem?

Why did you use 192.168.1.x?  I suggest changing it right away to 192.168.74.x or some such to avoid later conflicts. That is not likely your speed issue however.

Did you set your Workstations to DHCP, automatic DNS and not alternate?  Old settings may be causing issues.  

On one workstation, reset TCP/IP to see if that helps.
Open cmd.exe with Run as Administrator:  netsh int ip reset c:\resetlog.txt

After changing the IP range, restart the server just in case you have changed something along the way that a restart will benefit.

..... Thinkpads_User
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 39807716
It sounds like you have DHCP enabled on the router and the server.  It should be disabled on the router, and although you said it is, and Thinkpads_User posetd a reminder, it is critical the workstations point ONLY to the current server for DNS.  There should be no alternate and the server should also point only to itself.
0
 

Author Comment

by:dobby69
ID: 39807721
Thanks for responding so fast.

All the workstations are set to automatic DCHP and are being assigned addresses by the server as per the server ip scope. The primary DNS on each is set as the server ip address and the secondary dns is blank.

The reason I kept to the range 192.168.1.x is that it is the range used by the router. I have set the DC server to use 192.168.1.21 to 192.168.1.99 and the router is assigning addresses from 192.168.1.100 to 192.168.1.254.

I shall follow your suggestions and see what happens. If you have any other thoughts I would be most grateful. Thank you.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 38

Expert Comment

by:Hypercat (Deb)
ID: 39807727
Turn off DHCP on the router completely if possible. SBS does not like other DHCP servers on its subnet.  If the reason you have DHCP active on the router has to do with wireless connections, you still don't need to run DHCP on the router.  As long as the router is on the same subnet as the SBS server, as you've described, any wireless devices connecting to the router will be able to "see" the SBS server and will get a DHCP address from it.
0
 
LVL 97

Accepted Solution

by:
Experienced Member earned 2000 total points
ID: 39807739
By trying the Server by itself you can divide the problem in half (a) Server, router and (b) workstation.

I suggested earlier restarting the Server. Further, if you make changes to the router, restart it.

Your server should dish out DHCP and not the router, so there is no need to stick to the router range of IP addresses.

... Thinkpads_User
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 39807752
You may find the DHCP service on the server is disabled.  Some versions of windows server will automatically turn off the DHCP service if there is a second DHCP server on the network.
0
 

Author Closing Comment

by:dobby69
ID: 39807833
Thank you all for your help, I shall turn off the router dhcp and remove the scope restrictions. Hopefully after restarting the server it will cure the internet lag. Again thank you all
0
 
LVL 97

Expert Comment

by:Experienced Member
ID: 39807854
@dobby69 - Thanks for the follow up and I was happy to help.

.... Thinkpads_User
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
Trying to figure out group policy inheritance and which settings apply where can be a chore.  Here's a very simple summary I've written which might help.  Keep in mind, this is just a high-level conceptual overview where I try to avoid getting bogge…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…
Suggested Courses

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question