Java on 64bit Windows 8 Fail

Hello,

I am running 64bit Windows 8.1 and I have installed java 64 bit but it fails to run if there are sites that require java.  I have uninstalled and reinstalled java multiple times but it still fails to work.  Any solution....

I have used IE, Firfox, safari, chrome.  None of the browsers see java.  Don't know where to start or where to end.  

Windows 8.1 is a fresh install that I installed 2 days ago.  So I see nothing that can really prevent it from running.

Thanks
kaushalkAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
JohnConnect With a Mentor Business Consultant (Owner)Commented:
Try the Java 32-bit (V7 R51). I have that running on my own Windows 8.1 Pro 64-bit machine and it works fine. I would stay away from 64-bit Java until ALL software around it is 64-bit (and that is a while away).

Uninstall Java completely, restart the computer, download the 32-bit version and install. It should work fine.

.... Thinkpads_User
0
 
aadihCommented:
If your browser is 32 bit, you need to download and install 32 bit Java (irrespective of the fact that your machine is 64 bit). From:

http://java.com/en/download/index.jsp >
0
 
kaushalkAuthor Commented:
OK.  Thinkpads_user, I got java to work on all browsers except for Safari.  This is the error I get when I verify java install on safari...

Please see attachment
2014-01-25-19-42-03.png
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
JohnBusiness Consultant (Owner)Commented:
On Windows 8 I only use IE.

Did you install 64-bit Safari?  If so, that is probably the reason Java won't work.

In another thread where I helped a Java user, they had both 32-bit and 64-bit Java installed. That made a bit of a mess and they had to settle for one bit strength (32-bit in their case).

So three options here (since you have Java 32-bit working for the other browsers).

1. See if you can run Safari in 32-bit mode (IE installs 64-bit and runs either way and we mostly all use 32-bit IE).

2. If no, see if you can find a 32-bit version of Safari. Uninstall the current and install 32-bit.

3. If that does not work, then use a different browser when Java is called for.

..... Thinkpads_User
0
 
kaushalkAuthor Commented:
lol.  Well I have decided not to use Safari as my default browser although I like Safari.  

As much as I want to use IE as my default browser, I have major issue with pop-ups.  I had reset the browser to default settings and I still get popups on about 98% of the website I use.  It is becoming very frustrating.  

Because of IE issue, I went to Safari.  But now Safari will not open java or at least not yet.

My choices, Firefox or Chrome.  Not a big fan of either.
0
 
JohnBusiness Consultant (Owner)Commented:
I only use IE and I get very few pop-ups. Chrome is a popular browser and I do not wish to push you to IE.

However, should you use it for some site, go to IE, Tools, Internet Options, Privacy and add the website to need to the Pop Up Blocker to Accept and then turn the blocker to High.

.... Thinkpads_User
0
 
kaushalkAuthor Commented:
Appreciate it.  I have been testing all browsers since yesterday and I am down right bombarded with popups no matter which browser or site I go to.  Heck, I also get popups if I log into my own router for configuration.  Just wondering if this is an issue with Windows 8 or Windows 8 on a 64 bit OS

I never had these kinds of issue with Windows 7.  None whatsoever.  I enjoyed browsing using any browser without the fear of annoying popups.

Personally, I am thinking of installing the 32 bit of Windows 8 and move away from 64 bit
0
 
aadihConnect With a Mentor Commented:
(1) Please stay with 64 bit version.

(2) Try using the browsers from the safe mode with networking and verify that the pops ups spring up then also.

(3) Please check up Chrome settings to block pop ups (and in other browsers). Have you installed an adblocker extension also?

(4) Please scan your PC with (a) Malwarebytes Antimalware (b) TDSSKiller, and (c) AdwCleaner.

[Note: I am sorry if any of the above suggestions were already made above and I missed them somehow.]
0
 
JohnConnect With a Mentor Business Consultant (Owner)Commented:
Just wondering if this is an issue with Windows 8 or Windows 8 on a 64 bit OS

No, Windows 8 does not cause pop ups and bit strength does not cause pop ups. I recommend staying with 64--bit Windows for speed and additional memory.

This thread was originally about Java, so on thing you could do is match Java with the Browser you want and stick with that. I use IE 11 32-bit version and Java V7 R51 32-bit version both on 64-bit Windows 8 Pro.

Moving on from Java, as aadih has suggested above, scan for viruses and malware with the tools suggested and your own AV to begin with.  

As I noted earlier, try Pop Up Blocker on HIGH to block pop ups and then allow what you need.

.... Thinkpads_User
0
 
kaushalkAuthor Commented:
Thanks.  I found the issue with all your help.  I had a file "Plus HD 1.3" installed on my computer from where, I don't know.

But this file seems to cause major issue as mentioned and now that I have removed this file, all works just fine.  

I can use any browser and java opens just fine in every browser.  If  you need to read about this annoying virus/file, here is the link

http://malwaretips.com/blogs/plus-hd-1-3-removal/

Thanks for all your help. I can finally rest and enjoy Windows 8
0
 
JohnBusiness Consultant (Owner)Commented:
@kaushalk  - Thanks for the update and I am glad you got it fixed.

.... Thinkpads_User
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.